Tracks source causing confusion!

Hi all

Interesting one for you all

Tidal main source of my playlists.

Recently tried out beatsource but have since cancelled the subscription.

Was playing a gig last night and several tracks were only loading half of the song had no idea what was going on!!

Now I realise my playlists are sourcing some songs from beatsource which has a song time limit of 1.30mins for users who aren’t subscribed to necessary subscription.

Tracks are still showing tidal symbol as the source and I haven’t done anything to change the source of my previous playlists.

Have tried signing out of beatsource but still happening!

Help!

Thanks all

I’ve seen the behaviour before as well when I switched from Spotify to Tidal and then again when switching from Tidal to Beatport LINK.

Any idea what to do as it’s quite serious.

Lots of my tracks are sourcing from beatsource and only half the track is loading!

Also when I search for the same track in tidal and load it from the search box it’s fine, however if I then add it to a playlist it still sources beatsource!

At a loss…

  1. Make sure you log out if Beatsource from within djay.
  2. I’d probably log out of Tidal as well.
  3. Then close djay and do a full reboot of your device.
  4. Open djay and only log into Tidal.

To log out of the streaming services go to Settings>Library

1 Like

Had logged out before in djay and hadn’t worked but followed your instructions, logged out if tidal also rebooted and it’s done the trick.

Slak you’re my saviour!!

1 Like

@Ben4 you’re welcome! Glad that worked.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.