Traktor S4 Vs Djay Pro - Works on Mac not on Win

*Win 11 Laptop Version of djay: Newest Djay Pro Trail Version installed yesterday Hardware/controllers used: Traktor S4 mk1

I been spending a good amount of my time trying to make my old yet beloved Traktor S4 mk1 to work in Djay Pro - I found a midi mapping on the internet and it worked like a charm on my old Mac OSX w. Djay Pro.

I did take a few steps in the right order to enable midi mode, load the midi file, but then it worked. Unfortunately the old Mac couldn’t handle the software.

So… I switched to my windows laptop, got Traktor software up and running and I did exactly the same steps as I did on OSX.

The thing is; it isn’t working and I am absolute clueless why - the only difference is that it’s Windows.

What I do is:

  1. Copy the midi file for Traktor S4 (that i know is working from OSX) into the music - Djay Pro - Midi folder
  2. Turn on S4 controller and launch Traktor Pro 2 - it works (all drivers installed at latest version)
  3. Shut down Traktor Pro 2
  4. Push shift + browse to put controller in midi mode (display shows “on”)
  5. Open Djay Pro and press yes to new midi configuration detected.
    6a) it works - on OSX
    6b) it doesn’t work on windows

I have also tested double clicking the midi mapping file. It opens Djay Pro, gets the midi mapping message, I press yes, but nothing works.

On OSX I can see that the midi file is loaded/imported and all the buttons, jogs etc are mapped.

In windows it’s just empty under midi - only clue is that it says Traktor Pro S4 at the top. In Windows I cannot load/import the midi file from within the software. There is nothing I can click on - just empty. Although, if I press a button, it shows up as ready to be mapped, hence the midi signal is working.

So what’s going on here? Why is the same software, same hardware, same midifile and same process working on OSX and NOT on Windows?

I have tried every possible hacks and solutions mentioned in this community and on djtechtools (and the rest of the internet :sweat_smile:). No luck making it work.

NB. The Macbook that it works on is from 2011 and some of the keyboard letters doesn’t work, so even if I formatted that one and used it for DJing it’s a bad solution.

I feel the easy and expensive solution is a new controller, but my engineering brain just want a logic answer to why this isn’t working on windows.

Hope you fellow digital DJ’s can help me - I would instantly see this day as a good investment instead of hours wasted if it works :clap:


Hi @Goetze, I can try to help you with some general troubleshooting, but please note that this hardware is not officially supported and I do not have access to it for testing. So, if you’re good with that, let’s try the following:

  1. Are you using the free version of djay for Windows or are you properly logged into your Algoriddim djay account and on an active paid subscription? Note the MIDI Learn tool is not supported on the free version so non-natively supported hardware will not work. Also note that a paid subscription on macOS will work cross platform on Windows without the need for another subscription.
  2. Assuming you’re logged in and have a subscription, please make sure the S4 is connected to your laptop, connected to it’s own power supply, powered on and switched to MIDI Mode.
  3. Launch djay and navigate to djay Settings>MIDI Devices and select Configure next to your hardware.
  4. In the next window, select the drop down menu next to MIDI Configuration and create a new MIDI Mapping.
  5. Now press a button on your S4 and try mapping it to something.
  6. If this works, then we should be able to load your custom mapping or at least create a new one from scratch. If this doesn’t work, then we’ll need to dig deeper.

That was constructive and swift reply. Thanks. As I know the controller it’s not official supported, it still should be able to function on windows, as it does on OSX - and I take any help I can to resolve this. Thanks.

Okay, to the questions:

  1. I installed Djay Pro and opted in for the 7 day free trail through Microsoft using PayPal to pay for a year after the 6th of June. As far as I am concerned it’s the full version I got for 7 days. I do not believe I am logged in - unless it’s done automatically in the process of activating the trail. I will go ahead and check that tomorrow, and if I am not I will create one.

  2. S4 and my laptop are both connected with each of their own PSU. S4 doesn’t work without. I ensured it is plugged in directly to the laptops usb port and not through a hub.

  3. I have verified earlier today that any button indeed shows up ready to be mapped in the midi configuration when pushed. Hence, I believe that part works, but I have not interest in mapping it from scratch when I have the midi file ready to go.

So I guess the conclusion would be to go ahead and login if I am not automatically from the installation and signing up for the yearly subscription process?

I am curious what you mean by your last bullet about being able to “load midi mapping” - is that replacing the saved one with my custom in the windows folder? Then I have done that a couple of times without luck. Or maybe is a button that is only revealed when signed in as a user?

Thanks again, let’s solve this

Okay great. If you’re able to create a new mapping then it sounds like everything is fine with your djay license. I would start by giving your new mapping a unique name that you can search for. Then I would make sure that you put your downloaded mapping in the same folder as the new one. Next confirm that they have the same file extension. Finally, try to select this mapping within the MIDI configuration where you created the new mapping.

I recommend that you also rename your downloaded mapping to something unique and not try to save over the built-in or other mappings in this folder.

I have now logged in with my email in Djay Pro - the same as used for the trail subscription and Microsoft where I downloaded from.

I went to the midi options setting in the menu, and I created a new midi mapping by pushing “play” in the controller and mapping it to “play” on deck 1. I named the midi mapping “Traktor S4 Test 1”. I then created another one within the Djay software, which I called “Traktor S4 test 2” adding play for deck 2.

I closed the Djay Pro software and verified that the two new midi mapping files would show up in explorer - and they did. They were located in the same folder as I have c/p´ed the midi mapping that worked on OSX.

I have also checked that they are identical (and have the same file extension). All seems good.

I then found a few midi files for Traktor S4 mk2 online, which I have c/p´ed into the same folder. Same results. Djay Pro only shows the two new “test” files, and none of the others that are located in the same folder.

I have attached screendumps (new users are only allow to post one png file, so I will create another reply with the second screendump:

Update on my post from 30 minutes ago…

I made a copy of both midi files - the one I just created and the one I copied from the Djay Midi Folder on my old Mac OSX.

I open them both in the native Windows Notepad app, to see if could spot anything difference. And there is massive difference. The Midi Mapping working on OSX version of Djay Pro looks radically different than the one with the few mapping I just created. See attached screendump.

I reckon that´s why it isnt showing within the software, as Djay Pro on Windows simply doesnt read (or write the same format). I am able to spot the difference, and how the current Windows version has a simplified (less command lines) than the other one, but this is a massive job to change (not even knowing if it will work).


  1. Why are they different?
  2. Is there a quick way to “update” the midi mapping file from OSX to look like the one on Windows?

Hi @Goetze, it looks like you’ll have to build a new MIDI Mapping from scratch on Windows then. I have used my custom mappings cross platform without any issues, but all of my controllers are natively supported. There must be something unique with the MIDI mode on the S4 between Windows and macOS.