Trouble with Serato and the Rane Seventy. Cue Points are slipping.

Hey DJs,
I have an issue for years and no one can fix it.
There was a topic with that problem, but it‘s closed and the solutions didn’t fix my problem. I‘m using Serato and a Rane Seventy Two with Phase. When I use cue points they are moving backwards. For example: Using the cue points to mix in a new track., cutting it in with a „Baby scratch“ the start point is moving backwards. It takes only a few seconds while scratching and the marked start point is turned about 180 degrees to the other side. Have the same issue with usual needles. That make things like backspins almost impossible. There was a YouTube video in the closed topic. I‘ll try to post it here.


OK but this is the Algoriddim forum. Where does DJay come into it?

In the title it says Rane Seventy. In your post, Rane Seventy Two, and the video shows a Rane One.


Forgot the „two“ sorry.
Google send me here. The video is not mine. Found it in the topic where Google send me. Sure it‘s not my equipment but the same issue.

If the issue is with Serato then you’re on the wrong forum.

There is an old topic (it‘s closed now)
Where they tried to find a solution. With Rane and Serato.

Hi @NicoLassDas, please note this forum is dedicated to discussions related to Algoriddim djay only. Please post your question on the Serato forum instead. Thanks!

Serato, even the support, can‘t help.
As I said before, this was the only where I found somebody with the same problem.
Sorry guys, didn’t want to harass you.
Thanks for your „help“

No worries. Just a side note. Have you tried Djay Pro with your setup?