Turning the Loop Off Makes the Song Skip a Beat


On the Mixon 4, whenever I create a Loop, then turn the Loop off, the song will skip a beat and the whole crowd can hear it. The transition is not smooth.

Thank you

@E_Flem can you please provide a bit more information to help troubleshooting?

  1. Can you actually see the track jump out of alignment on the waveform or is it only audible?
  2. Are you using streaming services or tracks stored on your device when this happens?
  3. Are you playing 1, 2, 3 or 4 decks at a time?
  4. Is Sync enabled on all decks?
  5. Is Quantize enabled?
  6. Are you also using Neural Mix when looping?

This might be a long shot, but I’ve noticed tracks jumping out of alignment when using streaming services and Neural Mix at the same time. It seems that djay doesn’t load the individual STEMS and render their waveforms until you perform a Neural Mix action or use the Neural Mix waveform view. So my workaround has been to perform a quick Neural mix action when I first load a track or to use the Neural Mix Waveform view.

Hi @E_Flem,

I’m sorry to hear that you’ve been experiencing this issue as of late!

By any chance, do you have any new updates regarding this issue?

Was @Slak_Jaw’s informative response helpful in this scenario?

Looking forward to hearing back from you.

  1. Jumps out of alignment
  2. Streaming
  3. 1 & 2
  4. Sync is enabled
  5. How can you tell if Quantize is on or off?
  6. No Neural Mix


  1. See below for how to turn Quantize On/Off. It’s On when the Q is Blue. You can also adjust the quantize value between 1/16 of a beat and 4 beats. I recommend setting it to 1 initially.
  2. Experiment with Quantize On and Quantize Off to see if it helps.
  3. As a separate test, after you load your 2 tracks, try switching to the Neural Mix View as I described above to see if that makes a difference during Loop Exit.
  4. If neither of the above suggestions help, I suggest turning Sync Off before exiting the Loop to see if that helps.

Thanks for all of your help


@E_Flem you’re welcome. Did any of those suggestions work for you?

Quantize and Sync were the issue. I sync by ear but use the sync on loops because Djay drifts.

Thanks again.

1 Like

@E_Flem thats great to hear. Glad that worked.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.