Two semi-related Automix bugs: out-of-order playback, and lockup/getting stuck between tracks

Hi friends. I’m having trouble with Automix and wondering if anyone has these bugs. Here is a short narrated video demonstrating both issues:

My Hardware:
-M1 Mac mini
-Focusrite Clarett+ 8Pre thunderbolt audio interface
-Behringer BCF2000 control surface (in HUI mode- for use with Pro Tools, not configured for djay pro- bug happens with and without)
-numark DJ2GO controller (used occasionally and not connected for this demo- bug happens with and without)

Software:
-Djay Pro AI 4.0.9
-MacOS 12.4

These two bugs are preventing me from using the software, which I otherwise think is great. Bug #1 existed back in version 3x too I’m pretty sure. It was annoying but could be worked around. Bug #2 is new in version 4, and it’s the real dealbreaker for me.

The Bugs:
Bug #1-
If I launch Djay Pro AI and drag a selection of tracks from Tidal into Automix (source=manual, shuffle off), then click the Start Automix button, the playback order will be scrambled in the following fashion:

playlist order: Track1, Track2, Track3, Track4, Track5 etc…
Automix order: Track1, Track3, Track 2, Track4, Track5 etc…

Automix loads Track1 onto Deck 1 as expected, but erroneously loads Track3 onto Deck 2. Track2 vanishes from the Automix queue, and doesn’t appear anywhere again until Track1 finishes playing on Deck 1, at which point Track2 is loaded onto Deck1. The result is that Automix transposes Track2 and Track3.

This behavior is repeatable (for me at least!) every time and from any list of tracks on Tidal. Notably, is does not occur when loading a playlist from my own local library, only with Tidal. I don’t have any other services to test with. It happens most prominently and repeatably on the first activation of Automix after launch, but subsequent activations of Automix do not always exhibit the order scrambling of tracks 2 and 3, though they sometimes do, and sometimes exhibit different strange orderings.

Bug #2-
Following the same workflow as Bug #1 (launching djay pro ai, loading a playlist and starting automix), playback will halt after the first track on Deck 1 finishes. The “picture disk” animation on Deck 1 stops but the tone arm remains in the center. The “platter” animation continues to run. The fader does not move to Deck 2. The program will stay stuck here silently until I manually drag or click the fader to Deck 2.

This behavior happens consistently on the first activation of Automix after launch, but happens regularly (though randomly) any time Automix is running. It often has trouble progressing through 3-5 tracks without getting stuck in this fashion.

Additional General Info-
My Automix settings are:
-Transition: Automatic
-Duration: Manual - 0 bars
-Tempo Adjust: Off
Start point: Manual - 0 sec
End point: Manual - 0 sec
Use start and end point: Enabled
Maximum song duration: Disabled

Thanks for sticking through all that! I tried to be thorough but I’m sure I still left out some important detail somewhere. I’ll try to reply with more info if needed!

Bonus Bug / Question for anyone who is still reading this really long post:
When using the Automix source “Matching Songs”, Automix will populate with songs from Tidal if Tidal is the library I have selected, or from My Collection if I’ve selected that library.

It didn’t used to do that.

The problem is that the music in My Collection sucks, so I’m listening to matching stuff that I don’t have. I hear a cool track and drag it to My Collection. Now Automix is populating from My Collection, so soon I’ll start hearing matches from there instead of from Tidal. And like I said before, My Collection sucks.