Unable to activate perfect sync


I’ve been using Djay 2 for iPad for almost a 6 months and really enjoy its “perfect sync” functionality - i.e., when you double-tap on the sync button, making it appear so the button lights up in blue and the beat grid of both tracks playing are always matching.

However, I’ve just changed from an iPad 2 to an iPad Air and now I cannot make the perfect sync work anymore on some specific songs : whatever the number of time I press the sync button, it only sync the bpm but it never sync the beat grid…

Here is how I used to in the past (assuming I’m starting with no song being played):

  1. load a track on the left side and playing it
  2. load a 2nd track on the right side but not playing it
  3. wait that I’m getting to the transition point
  4. press once the “sync” button on the left side : now the bpm are synced but the song on the left side is still not playing
  5. whenever i want to start the transition, I’m pressing the sync button on the left side a second time : now the song on the left side is being played and it is perfectly synced with the one on the right side - both on a bpm standpoint and on the beat grid standpoint

Now, when I am at step 5, for some songs, it only starts playing the song on the left side - no beat grid matching.

What surprises me is that I am doing this on songs that used to perfectly accept the perfect sync functionality… And, the perfect sync works on some other songs…

What could be potential explanations for that?
> an issue to the fact that i am using an iPad Air instead of an iPad2?
> an issue to the iCloud syncing : the way the song was on my previous iPad 2 is different from the way it was on my new iPad Air?

Any answer / feed-back will be greatly appreciated.



— further details:

  • iPad Air 128Gb purchased in 2014
  • iOS 7
  • Djay 2
  • song right : “Katty Perry” / I Kissed a girl
  • song left : “The Toxic Avenger” / Angst One

Perfect sync is not working for me at all: iPad Air, iOS8.2, Djay 2.7.4.

With or without Reloop Beatpad.

Only shows the red frame or no sync. I need Traktor like auto-sync where both grids are in sync at all times, not just current beat.

Hello? Anyone listening to this topic?

Does not work. Why isn’t perfect sync the default mode, like in Traktor? Would save so much frustration.

Hi, I can recommend this iBook http://www.digitaldjtips.com/2015/10/…

I have the same issue on an iPad mini. A hard reset fixes it, haven’t tried the above work around yet.

Tried this solution but did not work for me. Only a hard reset of the app would work, which is really annoying and makes it basically unusable to dj. Also resetting the app resets your entire interface state.

The above workaround will not fix it, only a hard reset.

Ok, I played with just the iPad and no controller attached. Yes, I saw the blue outline around the Sync button

“Perfect Sync” just means Sync is enabled, or locked. It’s confusing when they say to hit the Sync button twice. That’s only true when the next song is not playing and standing by. Only then the first touch of the Sync button will adjust the tempo to the song playing. This first touch will not start the song. the next touch will start the song and lock the beats together and for better or worse, match the first beat of the measure. If the two songs are both playing and are two beats apart, but actually correct after manually beat matching. hitting Sync (or “Perfect Sync”) will make the song jump to match measures and probably ruin your mix. I think that this might be the problem for some in this thread.

It’s been suggested to readjust the phase by clicking on the pencil icon but it’s usually the playing song that is off phase after a breakdown or drop. that would not work if you wanted to start your mix right after the drop.

I don’t like that the Sync button ever starts playback and I hate that there is no way to disable the matching of the first beat of the measure. If it weren’t for this, Djay would be my current favorite iPad app.

The technology that determines the first beat of the measure is impressive and most likely very important to facilitate the Automix feature, but it should be able to be switched to “Perfectly” Sync to the beat rather than the measure for those DJs that prefer to have more precise control.

Thanks again. We haven’t been able to reproduce this problem yet though. It’s great to know that there’s workaround at least.

Which songs are affected?

Hi Zalen,

try the work around posted above by Jerod.

Our developers are still investigating this issue. We haven’t been able to reproduce this problem. It seems to happen randomly with some songs. In the meantime, please do try the workaround as it only involves a couple additional taps.

I had the same problem when using iCloud syncing especially on tracks where I had doubled or halved the BPM, if I went in reset them then halved or doubled them again, it would work, I even posted a video on here about it awhile back.

Hello Jerod,

Just tried your solution and it worked perfectly. I could’nt find anything on this with Google though - thus my post on this forum.

Thanks a lot for your help!

Yes : basically, you “touch” the BPM, make any change to (double it, reset it, etc.) and bring it back to what you want. Make it on both songs > magic: perfect sync works again!

I’m having the same problem using djay 2 through my air. Have tried the above, some tracks are fine others are all over the place. Is there going to be a proper fix to this?

I have the same problem. I don’t want to re download because I have too many recordings saved but is there anyway around it?

I too am having the same problem as the guys above and yes it’s on the iPad air. We need a proper fix for this not some mish mash of playing with and resetting bpms. That’s not what we paid for, right? Come on algorridim, help us out

Hey Erik. I have no troubles whith autosync, but i only use spotify tracks. It was ok, and it is ok with 8.3.

I also use the ipad air, and a ipad mini 2 retina.

Sometimes a bit trouble with some trance track’s that were not analysed correct, but only a few of them.