Using Automix in the old DJay Pro 2 style.

How can I make thew Automix perform like the old Pro 2 style? I want the crossfade to begin at whatever seconds I enter in the crossfade time before the end of the playing song, and fade into the next song with the number of seconds in the other crossfade time. But no matter what I set it to, I can’t make that happen. It always plays to the end of the first song completely before starting the next one and CROSSFADING.

I wish I could attache a screen cap, but I tried to draw it out below.

Deck 1               Deck 2   

<4> <4> <—When I set these two times (seconds) on the old DJay Pro 2, the crossfader will begin to move at 4 seconds before the end of the Deck 1 song, and AT THE SAME TIME, the Deck 2 song with begin and take 4 seconds to complete the crossfade, overlapping each other.

So can someone explain how I can get that OVERLAP crossfade effect in the new AI Automix system?

Thank you!

Hey @JoeyDK ,

Thank you for posting this here in the Community.

Writing to let you know we have replied to your email request regarding this and just shared some interesting updates for you in that same conversation.

Cheers :slight_smile:

I did receive your reply in email, but it did not solve the issue.

I am reposting the exchange here, hoping perhaps another user on the forum has an answer.

I’m attaching links to two Gayzo GIFs to show you what your app is doing and not doing.

The first link is showing what your Automix function does no matter how I set the settings.

The second link is showing what I want it to do, though I had to trigger it manually to demonstrate.

No matter what the setting on Automix, it behaves exactly the same way: the song on Deck A runs to the very end of the track, then the song on Deck B begins, and the fader executes the move from left to right. I want them to crossfade. I want Deck B to start rolling before the track on Deck A ends, and the fader to crossfade between the songs, so I don’t hear any gap or stop between. While one fades out the other fades in on top of it.

I have set the Automix for “Fade” (as in the attachment image) but I’ve also tried “Automatic” and “Dissolve” and neither gives me the result I want, a result that is very commonly used by DJs. I simply can’t believe your system doesn’t do this. Your old version did.

[See the next message]

[con’t from last message]

You suggested that my issues “seems to be due to the fact that “Start” and “End” point are set to “0” in the Automix —> Song Range sub-menu (see attached screenshot).
Such indicators reflect the moment in which the effect you choose (in this case, “Fade”) will be applied: you should try setting “Start” and “End” points to “4” to see if that resolves the issue.”

It did not solve the issue, it introduce another issue.

When I set the “start” and “end” points to (for example) “4”, what happens is the next song itself BEGINS at four seconds in. I don’t want that, I want the song to begin at the beginning of the track, not at four seconds in. I want it to begin rolling at zero seconds, and at the same time the fader does the cross fade.

You can see from the screen cap, the song on Deck 2 (Poker Face) is cued up to four seconds into the track.

So no, this is not a solution to what should be a very simple thing: when the song on Deck A reaches four seconds before the end, Deck B rolls, and the fader begins to cross over to Deck B, and completes the crossfade in four seconds. Then Deck A stops, amnd Automix loads the next track.

DJAY PRO 2 DID THIS!!! It did it without all the fancy auto crossfading options. On all other iterations of your application, I just set the crossfading numbers on each deck to “4” and DONE.

I just don’t understand why this should be such a hard thing to set up on the AI version.

Please help me. I use DJay for internet radio broadcasting, and often it involves me not being at the controls to execute the crossfades. I need Automix to do this for me, the normal way DJ’s do crossfades. Otherwise, you guys have made DJay AI a useless application for me.

Just to let folks know, the techs at Algoriddim did find a solution to my issue, so I’d like to post it here in case anyone else runs into the same problem.

Upon carefully reviewing your case with the help of our Testing Team, we have reached the conclusion that the Automix Start Point Manual settings should be set at 0 seconds after the beginning of the song. This means the song on deck B will start the transition at 0 seconds, as per your desired outcome.

As for the manual end point, you should play around with it and set it at either 4 or 5 seconds before the end of the song, so that’s when the playing song begins to transition into the next song: if you set both start point and end point at 4 seconds, this means Automix will start the transition 4 seconds before the end of the playing song, and 4 seconds already into the next song.