Version 2.1.1. Tracks out of tune

Since I ran Update 2.1.1. on my Mac and connected the CDJ2000nxs2 with USB to my Mac (as I always do) the tracks sound out of tone. I tried disabling “key lock” but still no succes. Friday all was ok and yesterday I updated and now the problem is there. I already rebooted and tried different things but nothing works. Sometimes when I start the track with the saved CUE’s on the CDJ, the sound is better in the beginning, but as the track continues, the key out of tune again. 
Any quick help would be appreciated as where in the middle of the Carnival here in the South of the Netherlands.
Best regards,


Thank you for getting in touch.

Are you pitching the key of your tracks in djay for Mac?

Have you tried changing the key by tapping it in djay?

I never change they key, only work with Master Tempo and Pitch. We have run multiple test with different Mac’s and different setups. The problem only occurs when you connect the CDJ2000nxs2 directly to the Macbook and stream the audio from Macbook into the CDJ’s and than from the digital out to the DJM900nxs2. The problem is gone when you connect the CDJ2000nxs2 and the DJM900nxs2 via USB to the Macbook and stream the audio directly into the DJM900nxs2 and use the CDJ’s only as MIDI triggers. We haven’t been able to test the Macbook via USB into the mixer and use the CDJ’s as trigger over LAN, this we must test.
So the problem seems to be from USB to CDJ’s to Digital Output to DJM900nxs2.