Vestax VCI 300 MK 2 with DjProAI (IOS) not detected

Hello peeps,

Vestax VCI 300MKII is listed as a compatible device for IOS version but it seems its not auto detected? I lifted a 2nd hand unit for this and I’m kinda bummed.

Currently on IOS 16 on an Ipad Air3 which supports Neural Mix. I hooked up a Numark Dj2GO2 touch without any problems.

Also tried running via a powered usb hub but to no avail. What am I missing?

Was also testing this with Midi Scope but I’m suprised to see it isn’t detected as a Midi compliant device? But the VFX1 is.

Update, hooked it up to Serato Pro Dj and it works =/

Any help is very much appreciated. Cheers

I’m assuming you’re using a Lightning to USB camera connection kit to connect your iPad the the VCI-300.

  1. Make sure you are using a genuine Apple camera connection kit. I’ve experienced issues with 3rd party adapters.
  2. Make sure you update your iOS to 16.5.1. There’s a bug with 16.5 that prevents the camera kit from working properly.
  3. Make sure the camera kit is also connected to power and that your iPad is charging before connecting the USB cable to the VCI-300.
  4. Make sure the VCI-300 power supply is connected as well.
1 Like

Appreciate the prompt assistance. Points 1 to 3 checked. The power adapter is a separate purchase which I’m lifting tomorrow, cos that’s the only reason I can think of now. - will report back.

@Joachim you’re welcome. I’m almost positive you will need the VCI power adapter to make this setup work. I have a VCI-400 and need to have the power supply connected when using my iPad.

@Slak_Jaw Yeaaap, it works with an adapter! I just now need to sort out the mapping. Some of the buttons doesn’t seem to work or readily mapped.

Am gonna google around abit but do you know if there’s an online guide for us Vestax users with DjProAI IOS? Else I’ll prob need to fumble around the whole of today.

Oh oh, also, do you know if the VCI380 is supported? I find it kinda odd 300 and 400 is but no mentioning of the 380 model

@Joachim glad that worked for you.

  1. I recommend you just map the missing functions yourself. The VCI-400 was missing a bunch of functions as well so I just mapped it to my liking.
  2. I doubt you’ll find an online guide for Vestax and djay.
  3. No idea about the VCI-380. It’s possible that it’s not class compliant. If so then it won’t work with iOS.

Hey @Joachim - Welcome to the Community! Thanks for your first post.

We’re super happy to see that @Slak_Jaw was able to point you in the right direction to get your Vestax controller up and running! (Thank you :pray:)

Feel free to reach out here in the Community if you have any further questions or suggestions, and have a great day! :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.