Visualisation disappeared

Hi,

Since the last update (IOS 4.0.14) al my visualizations disappeared from the menu. Even when I click “more packs”, nothing appears to choose from. See the attached screenshots.

Hi @hjvdw80,

Thanks for posting to the community!

From your attached screenshot it looks like you are experiencing this issue on Mac, is that correct?

Please note that the latest version of djay Pro AI on both macOS and iOS is v4.0.13.

Additionally, are you connected to the internet when you click on the “More Packs” button?

Looking forward to hearing back from you!

Hi Nathaniel,
Yes, as mentioned during the posting of this question, I have the Mac version 4.0.13 and I’m connected to the internet.
I experienced this bug after upgrading to the latest version.

Where is the support when you need it? This is not some kind of freeware program. Come on guys, I need the visualization for my DJ gigs, which is not working at the moment.

I already tried:

  • Check internet connection, which is ok.
  • I run the latest version, which is: Mac 4.1
  • I uninstalled the program (full deinstall and installed again).

Please note (again) that this bug appeared when upgraded from version 4.0.12 to 4.0.13.

Looking forward to hearing from you a bit sooner :wink:

Hi @hjvdw80,

I wanted to let you know that today we released djay Pro AI v4.1.1 in which we have yet to recreate this issue.

Would you mind updating the app and letting us know as to whether or not this issue is continuing to occur for you?

Eagerly awaiting your response!

Hi Nathaniel,

The issue is still continuing to occur, even after upgrading to v4.1.1.
To be clear. There is a visualization visible when playing a song, but I can’t change it or load more packs.
See screenshot.

Hi @hjvdw80,

Thanks for sharing that additional information while I gathered additional data from our teams.

Could you please follow the steps below to see if this solves your issue?

  1. Save one of the automatic backups made by djay Pro AI to a different location on your Mac (this is optional and not required but it may serve you well if you would like to keep your djay library in tact).
  2. Uninstall djay.
  3. Restart your Mac.
  4. Reinstall the latest version of djay Pro AI, v4.1.3, from the Mac App Store.
  5. Open djay and test whether or not the issue has been resolved.
  6. Restore djay from your previously saved djay library backup (optional).

Looking forward to hearing back from you. Have a great day!

Hi Nathaniel,

I followed all the steps in de above post, but still no visuals or more packs visible after I pressed the “Get more Packs”, so the problem hasn’t been resolved unfortunately. As already mentioned the only time a see one is when I load the first song (see screenshot in de post above).

FYI: I use a new Macbook Pro 2021 16" 32GB, with no change to the hardware configuration or what so ever. The only thing I can thing of, is that my computer is blocking the visualization or get more packs, but therefore we need to know how Djay Pro AI is handling the visualization part (online / locally stored / database / file etc etc.

Eagerly awaiting your response!

Hendrik

The bug occurred when upgrading from 4.0.12 to 4.0.13.

Maybe I could try a clean 4.0.12 install and see if the problem still occurs, but then I need a download link to version 4.0.12.

Sorry, but again there is a lack of support here.
I am a paying customer. A respond would be appreciated.

Hi @hjvdw80,

Thanks so much for sharing that info as well as for your continued patience while our teams have been trying to reproduce your issue. At this time, we have not had any luck in recreating this same issue but are committed to assessing this with you nonetheless.

We’ve created some follow-up questions which we feel will help us better address this issue.

  1. If you follow this Finder path “/Applications/djay Pro AI.app/Contents/Resources/visualizer-pack-tunnel-triangle-1” is the folder with the default visualizer shown in your second screenshot visible? I will include a screenshot down below for reference.

  1. Do you currently have an active PRO subscription?

  2. Do the Audio Loops and Audio Samples in the downloadable content window populate as expected as opposed to the current behavior of the Visual Loops tab? I will attach a screenshot below for reference.

  1. Do you have a VPN, firewall or proxy server that might be blocking djay’s ability to request this downloadable content?

We aim to better assist you with this issue in a more timely manner and look forward to finding a solution for this issue so that it does not potentially affect other users in the future.

Looking forward to your response. Have a good day.

Hi,

  1. The folder is visible with the default visualizer. tunnel triangle12.mov. When I load a song though, the default visualizer is not visible (just a black square in the player).

  2. Of course, I currently have an active pro subscription.

  3. As already show in previous posts, the audio loops window is empty as well.

  4. No firewall, VPN or Proxy. But the default visualization is stored on my HD, but doesn’t load either.

  5. In the previous post, I already requested to download a version where this problem didn’t occur, so maybe you could provide me a download link.

Attached soms screenshots.




Hi @hjvdw80,

Thank you very much for sharing that additional information. Additionally, your screenshots were incredibly helpful!

We’ve passed these updates along to our respective teams for further review.

As soon as we hear back from them we will update this thread accordingly. Thank you again!

HI @hjvdw80,

I’m happy to announce that our dev team has gotten back to us regarding this issue.

They’ve asked if you could complete the following steps for us.

  1. Close djay Pro AI.
  2. Open the Finder application.
  3. Navigate to ~/Music/djay (I will attach a screenshot below for further reference).
  4. Delete the djayMediaLibrary file(s) that are visible in said djay folder (I will attach another screenshot below for reference).
  5. Launch djay Pro AI (This will create a new djay Media Library file in the same file path).
  6. Share that new djay Media Library file with us at the following link Upload to Dropbox.

From there our dev team can get a better understanding of this issue which I will report on once I’ve received additional information from them.

Looking forward to hearing back from you!

Thank you for your quick reply.

I shared the file at the Dropbox link.

Looking forward to hearing back from you!

Hendrik

1 Like

Hi @hjvdw80,

Thank you for sharing that file.

Our development team is reviewing your library as we speak and I will update this thread as soon as I see an update from them.

Looking forward to finding a solution for this very strange issue!

Hi Nathaniel,

Thank you for your follow w up.

The issue also exists when opening a brand new clean installation with a fresh new library. So I doubt to find the bug there, but we’ll see…

Thanks

1 Like

Any news?

Been busy with this issue since beginning of December '22.

I’m also open to a remote session to explore the settings in my PC. Don’t you agree we have to do something? I also suggested to sent me the latest working version (4.0.12), but no response :wink:

Hi @hjvdw80,

I wanted to let you know that our dev team got back to me with additional information.

Please check your DM inbox for further instruction.

Have a good day!