VU-meters always in the reds since 3.8.0 on various controllers

A post was merged into an existing topic: Key Lock Set to ON default settings

I have a similar level meter issue with my Denon Prime 4 since the update. The channel meters don’t register at all until I turn the gain past 12 o’clock then they go straight into the red. If I turn back to 12 o’clock they don’t register at all.

This occurs with my DDJ-SZ2 after the latest 3.8 update

My VU meters are going crazy too, on Numark NS6ii

And with regards the Key Lock having a setting to permanently stay on …

Hahahahahahahahaha :joy::rofl::man_shrugging:t2::face_with_symbols_over_mouth::rage::hot_face:

We asked for this back in September 2012, Yes, Nine years ago, and have been waiting/asking ever since.

This was the reply from the gods in 2012

Warren

Sep '12

Hi,

"This feature is very processor intensive so we decided that it should only be turned on manually whenever necessary."

I wonder if 8 years later that the IPad is now powerful enough to have the feature always on :rofl: and not make 90%+ of us have to keep turning it on every time we restart Djay?

Algorridim closed the thread in 2020 after 23 users had asked for the feature over multiple years and with only the one replay above :man_shrugging:t2:

We love you really Algoriddim :wink:

Just tested the Rane One and the issue is there as well, although it doesn’t appear to be problematic at this stage…

3 posts were merged into an existing topic: Key Lock Set to ON default settings

Hi All,

Thanks for letting us know about this issue with the VU meters since the 3.8.0 update on iOS. We really appreciate you bringing it to our attention.

I’ve passed it along to our development team for further investigation and I’ll keep you posted with any updates here.

Thanks in advance for your patience.

1 Like

Testing the VU-meter issue further.

The VU meters in Djay still appear to be showing the correct readings for me and the audio doesn’t clip until they hit the red.

My controllers used to “almost” follow the Djay VU’s and had no major issues before the updates. They did still go into the red slightly before the Djay VU meters though.

Since the updates. The controller VU’s now go into the red when Djay is only at about 30%-50% of the level.
By the time that the Djay VU’s are just starting to blink the red/clipping level, the controller VU’s are totally solid all the way up.

Solutions.
Easy
1: Put it back the way it was so they are almost correct again.
Better
2: Add a setting to allow the user calibration of individual controllers to match the Djay VU’s, as I’m sure they don’t all act in the same way. The calibration would simply ask the user when the controller’s VU meter hits the first Red/clipping led and then sync that with the djay VU meters.

1 Like

Just to add to this, on my SX2 the channel VU meters are now clipping unless I turn auto gain down a tad and the master VU meters are now OFF permanently.

So the exact opposite of what everyone else is getting! :rofl:

Hi Sootee,

Not opposite to me. Mine are doing the same as yours on my NS6ii.
I think the point I was making was that on my controller the midi VU meters are just visual, the audio is not actually clipping so turning the gains down is sending out less signal than you should be to the master out. The proof for me was by looking at the djay VU’s on the screen and turning up the gains past the red clipping on the controller which still sounded fine, until the djay VU’s went into the red, when the sound then got distorted.

My master VU’s are now usually off or don’t get past 2 bars (if I turn the gains to 100%) which is obviously wrong.

If I disconnect djay/iPad usb and change my input from pc to line in, and play the same track from my iPhone using djay into the ns6ii rca input, the VU meters work properly!

Can you test if your VU’s are now giving a wrong indication by djay sending the wrong midi out information or whether it is really clipping. My controller is currently working with the VU’s
clipping on every song, but the sound is fine so it doesn’t make sense to turn the gains down (I just don’t take any notice of the vu’s).
I guess after having a pioneer wego for a long time that didn’t have VU’s, my ears are my distortion meter. The auto gain & djay vu’s still seem to be ok for me if I ignore the controller.

Atleast we are all of the same one opinion. It changed, it’s wrong, and needs to get fixed :wink:

1 Like

Hi @SteNight, I’ll have a play with it all later and report back!

Trouble is since I added the PreSonus E5 pair and Sub, I can’t / don’t turn the controller up too far as it sounds like I’m about to blow the bloody windows out! :rofl:

I’ll clag the old speakers on and have a tinker.

:+1:t3:

Tried it last night and no joy with the master VUs working at all…until…I turned everything up to max and it showed 1 bar continuously and sometimes hit 2.

I couldn’t keep it at that volume level though as the radiator in the room was rattling that much it was threatening to detach itself from the wall!!

Anyway, once I’d dealt with the blood pouring from my ears I gave up and decided that it’s currently FUBAR.

Will have to wait, the next update will either fix or fux it!

:rofl:

Yeah, same for me on the master. Completely unusable.

But the question is on the fader vu’s. The update has pushed them up into the red with the same settings as before since the updates. For me it’s just visually wrong and I don’t think it’s really clipping the output, but some people are turning the gains down to compensate when they probably don’t need to. If they are doing that they are probably then turning up the master out which may then clip the active speaker :rofl:

Algorridim need to tell us if the updates are just sending higher midi levels for the VU meters or are sending a higher audio output. If it’s the former we just have to ignore the vu’s till it’s fixed, if it’s the later you do actually have to turn the gains down, which is impossible if you have auto gain turned on (unless you adjust every single track after loading which defeats the purpose).

And on the subject of auto gain. When in this mode the deck output is always higher than the sampler & microphones set to max (others have commented on this). The only way to compensate for this is to either turn off auto gain and bring the gains down (no thanks) or play with the faders pulled back and the master turned up, it’s what I do now, but not happy with it. It’s nice to be able to throw up the faders and know they will be at the rIght levels.
Please add the Serato feature that allows you to reduce or increase the max auto-gain db. That way it can be reduced to match the sampler & Mic volumes while still retaining automatic track output levels.

I just turned the Auto Gain and Audio Limiter off.
Although it’s not ideal, it doesn’t seem to be clipping or going into the reds

I’m not sure if it’s related but since the latest update, I’m randomly getting a clipping/cracking noise in my headphones whilst playing random tracks…It’s not happening all the time but is happening occasionally…This definitely wasn’t there prior to the latest update…

A note to Algoriddim,
We users trust the updates that you guys provide, and in most cases are very appreciative of them…
However there are times where the updates appear to fix problems that aren’t broken,and in some cases make things worse,the latest update with the VU levels is a perfect example…
In reading just about all the bug issues and requests issues that users are experiencing, I don’t think I have read anywhere that users were experiencing issues with the VU meters, besides Rane One users experiencing Line VU meters not working prior to Version 3.7.6.
In contrast, a lot of minor and easy fixes/upgrades get swept under the table…(ie Key Lock being on as default whenever Djay is started)

I wish there was a way to roll back the update and “downgrade” to a previous version if we are experiencing issues with the current versions…

2 Likes

Unfortunately this update (3.8.2) didn’t fix it for me. Hope I don’t have to wait for another month.
It honestly sucks to have no usable VU-meters on a system that’s not even capable of remembering gains. Especially considering it was perfectly doing its job before that. I can’t understand how you set priorities. Maybe focus on what people actually need to properly djay. Like we can’t even rate or tag songs and that’s just so horrible for a library. Or remember pitch lock finally. Can’t imagine this to take even half a day of development. I hate to rant but I just don’t get it at all. And please stop with the “various bug fixes and improvements”. Just list them all. That’s why people read the changelog. A few updates ago you finally fixed the isolator-eq and you didn’t even mention it. I had to check manually after every update.

There’s so much good about this app but the wasted potential here feels immense and I’ve gotten a bit frustrated over the time. Please focus on actual issues and the major missing features that are so important, they should have been added a long time ago.

2 Likes

Hi @frgld, Thanks for keeping us updated and sorry to hear the recent update didn’t fix the issue for you.

Could you please tell me which controller you’re using exactly? Also, are you using a customized MIDI mapping in djay for your controller? If so, you should have received a popup message in the latest update (3.8.2) letting you know an updated MIDI mapping is available. If this is the case for you, please try using the new updated default MIDI mapping provided in djay for your controller, and this should solve the issue for you.

Please keep me posted on how things go with this. Also, thanks for your additional feedback about other features you’ve been waiting for. I’ll be sure to pass this along to our team.

Yes, the app noticed me today afternoon there is a new MIDI-config file for my Mixon 4 and asked me if I want to update. Now the VU-Meters are out of the reds. Thanks for that!

I was even able to manually integrate the new midiMaxValue from the .djayMidiMapping file into my old mapping so I didn’t have to rebuild it from scratch which would have been a lot of work as it’s heavily customized.

Appreciate this was taken care of!

3 Likes

@frgld That’s great news! Thanks for keeping us updated. I’m really happy to hear things are working properly for you now and that you didn’t have to rebuild your customized mapping from scratch either. :sunglasses:

Feel free to reach out any time. Happy mixing! :musical_note:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.