Waveform stopped displaying on Djay Pro after a long set.

System info:
Macbook Pro mid 2012
Yosemite 10.10.5
Memory 8GB
Djay Pro 1.4.3

After about 8 hours of usage of Djay Pro during a wedding, some of the song I was loading didn’t show a waveform anymore. The songs were playing normally, but without any visual or time info. I would say one on every 5 songs were acting that way. This problem also seemed to increase over time during the last 2 hours of the set.
I didn’t thought about refreshing the screen at the time. I also tried to reload the song again but with no success.
I never had this problem before after 1 year of working with Djay Pro. Could this be a bug related to a long time usage?

Mac’s and Windows systems are complex systems. Not always DJay Pro is the problem. Somtimes other Apps change drivers or libraries wich are also used by DJay Pro. Mac is more protected but on windows this is often the case. If your System worked ok over a year and suddently you have this problem this could be the case.

The only way is to make a Backup of your System and reinstall the operating system.

I am not from Allgorithm.

Hey there,

we are sorry to hear that.
Since the first encounter of this problem did you have to deal with this issue again?