Waveform zoom bug

  • Device model Custom PC Build (i7-13700, 3080ti, 32GB DDR5) :
  • Version of operating system: Windows 10:
  • Version of djay: 5.1.8217.0

Summary of the issue:

I’ve noticed that one of the waveform zoom modes doesn’t work properly and only displays part of the waveform which makes this mode pretty much useless. On top of that the order of zoom levels is wrong if you use the + and - buttons to change it.

  1. Djay Pro has 6 levels of waveform zoom. Go into the waveform zoom settings, and click the ‘-’ button until this option is no longer active. Let’s call this zoom level 1/6 for clarity. Now. While doing this you probably noticed something strange. Click the ‘+’ option again and the waveform becomes more zoomed out instead of zoomed in. Each subsequent press of the + button works fine so it’s just a problem with the 2/6 option.

I actually like this level of zoom, I like to see more of my waveform, especially when i’m not very familiar with a song i’m playing, but sadly that’s not the only problem with it.

  1. Only part of the waveform is rendered in this mode which makes using the 2/6 zoom level quite pointless.

How to reproduce the issue:
Explained above ^

It seems to me that the two problems are related.
It would be nice to have a properly working heavily “zoomed out” setting like this so I hope it won’t be too difficult to fix. Thanks! :wink:

Hi @unumi, thanks for the detailed explanation and screenshots! This is super helpful. I was able to reproduce both issues on my Windows laptop, however the missing waveform section at maximum zoom out is very small. What sized monitor are you running djay on? Thanks!

Hi! The screenshot was taken on a QHD monitor (2560x1440). I have just checked this on a Full HD monitor and this problem is less noticeable, however still over 3 bars of the waveform are not rendered.
It seems that this problem only increases the higher the resolution is used.

More and more people are using 1440p these days so it would be great for it to work properly regardless of the resolution. :pray:

Thanks for the additional info @unumi. I’ve passed this onto the engineering team for review.

1 Like