XDJ-RX mapping won't work

I have an XDJ-RX with this custom mapping. https://maps.djtechtools.com/mappings…

I have installed the mapping, my XDJ-RX reacts to the day Pro software e.g. dials move on the software etc but it doesn’t seem to be coming up an option to output on the XDJ-RX. The music doesn’t load in to the deck but the XDJ-RX can control the software… strange.

Hi Carl, 

your device settings are looking fine, have you checked that output settings on the controller like the Master Output Volume are ok?

Lukas E.

Oh I see, sorry for the misunderstanding. In which mode is the XDJ RX?

Lukas E.

Hi Carl,

thank you for the follow up. Are all Drivers updated? You can find them here:

Lukas E.

Hi Carl,

glad to hear that this helped!
If there is anything else we can do, you know where to find me :slight_smile:

Lukas E.

Hey guys,

after quiet some time, we are very happy to announce that

djay Pro for Mac 1.4.4 comes with full plug & play support for Pioneer XDJ-RX, DDJ-RR, DDJ-RX, and DDJ-SZ2 DJ controllers!

You are good to go after updating djay Pro.

Thank you for your patience.

Lukas E.

I am only using a demo of djay pro to see whether I like it, does this make a difference?

I think it works fine apart from the fact that the music won’t go through my rokit speakers? The output is from my laptop.

I basically can’t get this image to come up…

Output for XDJ-RX

Anyone? :frowning: thanks.

Ok I’ve purchased the software and the problem is still the same… I can’t use it at all through my speakers plugged in to my XDJ-RX. The output doesn’t have the option to use the PIONEER XDJ-RX like in above photo? Merry Christmas but please help lol :frowning:

Hi Lukas, thanks for your time.

The picture above is not my settings, I can’t get the above picture to show on my screen.

When my controller is plugged in, it doesn’t show PIONEER XDJ-RX an an option for output. It plays the music through my MacBook Pro instead?

The thing is I can turn the dials on my XDJ-RX and it reacts on the software… ? just can’t get the sound to come through my Rokit speakers.

It’s in MIDI mode, cables are all fine, just don’t see why it doesn’t recognise the XDJ-RX as an output source.

Well I’m on 2.10 but I’m trying to update to 2.20 and it’s not really letting me. I don’t know if the update will fix my issue but I’ll try get it up to date and see whether that fixes it with a firmware refresh.

Sorry I misread your message. I updated the drivers and it worked! I now have the XDJ-RX as an output. Brilliant! Thanks your help, such a simple thing to.

And on that note does anyone have a really good mapping for the XDJ-RX? The one I found on DJTechTools I don’t think is working properly.

Just finished a (better) MIDI-mapping for the XDJ-RX

Check it out here:

It works best with the XDJ-RX in “XDJ-RX-Mode” -> Change setting in “UTILITY” (longpress “MENU”) and djay Pro in “External Mixer Mode”. If no sound; could be that you’ll have to turn up once the volumesliders for ch 1 & 2 in the software itself.

Only thing that might seem weird in the mapping, is that “DELETE”, “MEMORY”, “JOG MODE” and “VINYL SPEED ADJUST” (also in combination with “SHIFT”) are used for FX 1, 2 & 3.

Any complaints or suggestions are welcome.

O and +1 for native support!
It would be awesome if it would work just like with the XDJ-1000’s. And as the XDJ-RX is one of Pioneer’s best selling djay-gear at the moment, there probably will be quite a lot of happy potential djay Pro customers.



Awesome! Thankyou!!!