5.0.1 FX Favorites & Loop Issues

I noticed that the stem seperation quality for nureal mix has dramatically improved and sounds amazing… however…

Two recent bugs have appread in the system.
The main one being the fx select button although still scrolls through the fx, it cannnot seem to go through the faviroutes list, and although still scrolls through the fx, it doesn’t appear to show the listed fx on screen, making things very hard to know what you’re doing.

Second one, on the looping since the update, there is a slight but sadly noticeable delay when hitting the button, almost like the software is trying to quantize/sync the beat but almost struggling to time it to what the user requires.

I dont know if anyone else is dealing with this but I think algoriddim should know this because thier software is my personal faviroute by this point.


Hi @Martial_Autist, thanks for the information.

  1. FX Favorites: to get the FX Favs to work, you need to first switch to the Star tab at the far right and then select an FX from within the list. Just switching to the Star tab alone doesn’t work. Also you need to do this for all of your FX units on all Decks. The system uses the FX Audio tab by default. However, once you have done the work above, the system should remember to use the FX Favorites tab next time you use djay.
  2. Loop Delay: can you please confirm if you have Quantize enable and if so what the value is set to? Also, what type of Loop are you setting? A screen shot would be very helpful. Thanks.

Looping issue solved, cheers guys not sure how I buggerd that one :laughing:

I will just say with the fx thats not quite what I meant.

It’s more like when on screen using the pro visual (which I personally love more then the hardware visual thanks to tempo faders being on screen)
The bitcrusher effect will be on screen but the fx knob only works for the one I can’t see unless I scroll with the fx button, but even then it’s hard to know what I’m doing without being able to see which fx are on screen.
I’ve also noticed that it’s no longer affecting the wet/dry and now it’s affecting the volume of the actual effect now. Again I think this might be a glitch that came with the recent update.

1 Like

Hi @Martial_Autist I’m not sure I understand what you’re looking for. Can you please provide a screen shot with markups to help describe what you mean? Thanks!

Thanks for that, looping has been solved.

Not quite what I mean about the fx.
A couple other issues since the update.
So, on the pro visual, the fx don’t change when I press fx select on the
ddj 400, and it won’t let me re map it as the app is now acting like the fx
select button doesn’t exist. However it is scrolling throughout fx on the
faviroutes, just not showing me at all which fx are on.
Also the fx release knob isn’t actully doing a wet/dry function anymore,
now it’s keeping the fx the same all the way through when the fx release
button is active and instead changing the volume of that exact effect.

Another issue are the bars on the wave length, when I try to use the
downbeat it sometimes asks me out of nowhere if I want to do another
function that involves putting a small blue dot on the wavelength and
extending it, which is not really what I want unfortunately, and it kind of
gets in the way when trying to mix/transition.

I’ve also noticed that the beat sync now cuts itself off when I move the
jogwheel when this never happened on the previous update.

It would be hard to send screenshots as I’d have to send an actual video to
show what I mean.

Thanks for getting back to me and I apologise for the long winded email.
Hope you are well.

Hi guys, I’m still really struggling with trying to get this to work.
Basically I’m struggling to conprehend how to show you the bug issues with
screen shots, as I don’t think that’s physically possible when the issues
can only be explained with a video, is there anyone I can talk to via a
phonecall/online call?

Hi @Martial_Autist you can record a video of the issue then upload it to a cloud storage like Dropbox or Google Drive and share a link to the file here.

1 Like

Yes mate I’ll get on that asap, cheers mate.

Here you go, I editied it down because I waffled a bit which is why there some clip cutting but all the important stuff is there :wink:

Thanks for the video @Martial_Autist. This is helpful.

  1. There are some known issues with sync that are already being addressed for the upcoming 5.0.2 release.
  2. Have you checked the Pioneer DJ website and made sure you are running the latest firmware for your DDJ 400?
  3. Regarding the changes to how the FX are working with your DDJ-400, can you please confirm if you are using a custom MIDI Mapping or the default Built-in mapping. If you are using a custom mapping, can you please try using the Built-in to see if that addresses the issues?

If step 3 above doesn’t fix the issues, I recommend you:

  1. Backup your iPad, including your
  2. djaymedialibrary database, then
  3. Delete djay, perform a
  4. Forced Restart (Force restart iPad - Apple Support) then,
  5. Reinstall the latest version version of djay Pro 5.
  6. This should clean things up.

You can find the djaymedialibrary here:

  1. Launch the “Files” app on your iPad or iPhone.
  2. Select the “Browse” tab.
  3. Select “On My iPad/iPhone” under “Locations”.
  4. Select the “djay” folder and navigate into the “User Data” folder.
  5. Copy this file to your iCloud storage, an external drive or simply to a new folder on your iPad outside of the djay folder.

Thanks my guy, so I can confirm that the firmwafe is up to date, currently running the latest, on the previous version, it ran without issue, and I can confirm it is neither the edit or built that is causing the issue.

I did the the the steps as shown and the only thing it resulted in was me having to put everything back where I left it but the fx processing is still an issue.

I hate to sound like a boomer… but… can I have version 4.1.10 back please? :sob:
I’ll actully give you 40 years of my life :grin:

Jokes aside thank you for the help, I genuinly do appreciate it :wink:

Hi @Martial_Autist, sorry that didn’t fix your issue. If you have a full system backup of your iPad you can use that to rollback to a previous djay version. Unfortunately, there is no other way to rollback djay. It’s well after 11pm where I live, so I don’t think I can be of more help tonight. I’ll try to have a look at this again tomorrow to see if I can think of anything else. Thanks.

Thats all good mate, I can still beatmatch manually and eqing and looping is good enough so come sunday it will just be a show without fx or sync :sweat_smile: it’s just the one night and the average listener doesnt usually care about technical DJ transitions so I should be okay regardless. At least the issues are addressed and the fact you’ve gone out of your way to communicate is a godsend, good luck getting that with other companys :relieved:

1 Like

I just got the new update.
Problem with it but the things that it claims that have been fixed are unfortunately all still there.

Before the release of the new update these issues never happened.

My issue with the fx knob is still there sadly, and the beat sync cutting off when literally anything happens is still an issue.

I’ve just thought of a theory.
By any chnace would you say the new update’s controller compatibility is more focused to recent controllers then it is a ddj400?
Because I’ve done some testing and the smart fader fx work just fine, and it feels like it would be more to compatible to a flx4 by this point.
Is there something in the programming where there it might be holding back the old fx trigger for the sake of the new one considering that as far as the software is concernd, the fx nob is only kind of there and not really able to do as much?
Considering that a lot of recent controllers come with a smart fader button and the ddj400 doesnt have anything like that built in.

Hi @Martial_Autist, sorry, but I’m fresh out of ideas to try. I have forwarded this to the internal dev and support team to see if they can reproduce the issue and offer some suggestions. I’ll report back here as soon as I have some news. In the meantime, you could also submit an official support request via djay Settings>Contact Support. Thanks for your understanding and patience!

1 Like

Legend legend cheers mate :wink:

Hi @Martial_Autist,

  1. Can you please try the FX Select button with the FX On/Off button enabled? (To see if its a lock or sequence).
  2. Can you also change FX View in djay to Instant or Manual to see if anything changes on screen when using the DDJ-400 FX buttons?


This is very intresting.

The actual w/d is controlled by the bar between the on/off icon and the nob on the side that is being turned both ways is what’s affecting the volume. How bizarre :thinking: but the fx button that was giving me trouble is very commited to these two particuler places in the software, it outright refuses to target anywhere else :thinking:

As for having the fx button enabled, it doesnt lock or unlock anything, litrally just scrolls through while enabled :unamused: