Akai AMX sound through mixer on iOS Djay Pro AI 4 -- how?

Just to clarify, youre running an amx with the ios version? Tried playing around with the settings you posted for DVS but for some reason theres no audio output. :frowning: , the serato time code vinyl works fine.

1 Like

The Amx works with an iPhone. Set up your camera connection kit and whatever else you need. *

The last thing to plug in just before opening the app is the amx.

My next setup with dvs using the amx as a sound card for external mode. Main out deck1 to ch1 on the denon mixer and headphone out into ch2 on the Denon mixer.

You will need a battery like in the first pic or a powered hub like in the second pic.

3 Likes

Nice, but i got it to work differently just with the AMX after fumbling around with a traktor split headphone cable - this is without the need for an additional mixer.

After hooking up everything, I found the workaround to be

  1. Audio Device Setup , turn on Output to Ipad Speaker
  2. Then open up DVS , enable and calibrate your decks - this will deactivate point 1 above.
  3. Once timecode vinyls are calibrated set Main Output to headphones (ipad output), Pre cueing to Split output (using the traktor split cable)

Screenshots of settings attached. Also keen to explore your method to see if it can bypass an additional mixer. Are you able to clarify on

“Main out deck1 to ch1” on the denon mixer and “headphone out” into ch2 on the Denon mixer."

By main deck you mean the AMX master output , yes? But where’s this headphone out from? The AMX only has 1 main and 2 inputs at the back , or are you referring to the headphone jack at the front (near the crossfader) ?



1 Like

I don’t need an additional mixer for dvs. I can just use the amx alone. :joy:

Just showing people that amx works with dvs on iOS and that you can use it in any type of setup, like how you pointed out in your method. It always worked plug and play for me as long as I follow the proper ritual.

The issue with iOS is that it will only use the last device that you plugged into before opening the app as the default sound device. This is most likely why most can’t get sound out of the amx. Also you will need to turn up the volume on your iOS device as you mentioned but I just do it from the vol buttons on my iPhone.

Also just wanted to point out again that the amx needs to be powered. And it’s pretty cool to show that you can use a battery to do it isn’t it? Along with a battery powered SOUNDBOKS speaker.

Glad you got it working and now you’re happy.

Just so we are all on the same page this is the setup everybody’s looking to make work?

2 Likes

I am back with a free test-month for Djay and found back to my old thread here, willing to give it a new try…

After looking at the photos (thanks for those!) it looks like I have the EXACT same setup as you, @Wyley. But I do not get any sound through my AMX. Using Djay on my iPhone I could get the AMX eq to show that something was playing, but no sound came from the speakers. Weird. So to test I started Serato on my laptop. Sound there via the AMX works perfectly fine as always. I then plugged in my iPad with Djay and tried it on that one. Same problem but now the eq LEDs are dead. Same for headphones/cue via the AMX - no sound.

I connect by first removing all cables, then plug in the iPhone/iPad to the Apple Camera Adapter which has power via the Lightning cable to the 65W power brick, in the last step I plug in the AMX with USB to the Adapter and start Djay.

I also tried setting up DVS in Djay (I use Phase), after calibrating I can control the soundwaves perfectly with Phase even though I can’t hear anything.

I use a powered hub with 65W power, it is more than enough. I have tried replacing the cables for everything (power, AMX-usb, lightning/usb, even cinch lol) … tried two other powered usb hubs as well (10W and 30W). But nothing helps.

Regardless of what I do, there is no sound and it is making me crazy. Could you please make screenshots or photograph your entire Djay preferences, maybe share your midi file and please explain step by step exactly how you connect this setup? I would appreciate it so much, I really want to get this working. :sob:

Thanks in advance!

As a side note: I tried some midi programming in Djay and I must say that for example the crossfader is moving super jerky inside Djay when I move it. It is not smooth at all, jumping around a bit at random sometimes. Do you guys also have this?

I am out of ideas so I am going to order a new Apple Camera Adapter to see if that helps. If anyone has any other ideas, I’d appreciate it. :slight_smile:

@Tessel

  1. Disconnect everything and close djay.
  2. Perform a hard reset of your iPhone by quickly pressing Volume Up Button and release, quick press Volume Down Button and release then hold the Lock Button until the phone resets and you see the Apple logo. Then release the Lock button.
  3. Launch djay.
  4. Connect only the official Apple USB 3 to Lightning Camera Adapter.
  5. Confirm the blue peripheral icon shows up briefly on iPhone at the top right.
  6. Connect power to the Adapter and confirm the iPhone is charging. If not, disconnect everything an try again.
  7. Connect your controller then turn on the power.
  8. If that doesn’t work, disconnect everything, reboot the iPhone and repeat the steps above.

@Tessel as for the jerky crossfader problem, this sounds like it could be 2 things:

  1. A dirty crossfader
  2. External interference

Are you using a USB cable with ferrite chokes on either end? If not, I recommend getting a high quality cable like the ones from DJ TechTools. This could also be causing your audio issues.

Thank you for the tips @Slak_Jaw! I will try with your method tonight. It just feels unlikely that both the iPad and the iPhone both needs a reset, but who knows. And I am willing to try everything. :slight_smile: Regarding the crossfader, it is smooth as butter in Serato so IMO it’s not likely to be the cable. But I’ve ordered a double ferrite cable which should arrive during the day so I will see if that still makes a difference.

You’re welcome @Tessel. Hopefully that helps.

What midi mapping are you using for the amx?

The amx is not natively mapped in djay. The best place to go for a mapping is on the djtt website.

Hey @Slak_Jaw and @Wyley, first of all thanks a lot for your previous posts, it’s helped me a lot.

I bought a new powered usb-a hub (one with its own power plug), previously I used a usb-c one with an adapter. Now it works probably because power is more stable! Yay.

I even started configuring my Xone K1 as an extra controller, and it works as well. I started learning how to manage mapping midi and have managed to make the lighting work for buttons etc. Moving from iPhone to iPad works flawlessly, I share the midi files via my iCloud Drive.

I have yet to try my Phase for DVS in Djay, but I guess that should work fine.

The problems I still have are:

  1. Getting sound to work is super fiddly and hard. Sometimes I get distorted sound on my speakers, sometimes there is no sound at all. I switch from “Internal” sound (AMX) to the iPhone/iPads own speakers, then the sound moves to the iPhone/iPad speakers, when I deactivate that sometimes the sound moves over to the AMX and it starts working but it is extremely unstable and feels random to get working. You wrote we should make sure to add the AMX in the last step to get sound working but it doesn’t seem to work reliably for me. Can you explain exactly how you start and connect to get it working every time? Thank you!

  2. I see no Volume EQ for the main or the two channels on the AMX, do you? If you do, do you know how to fix that? I think I saw it before but it’s not there anymore, it’s just dark. Weird.

  3. Did you manage to get pre-cueing (Monitor 1 & 2) to work (incl. having the buttons light up)? If so please share your mappings, I need to press mine twice for them to activate, I don’t know if it’s possible to correct that.

Here are my midi mappings for the AMX and the Xone K1 if you want to take a look. I tried to keep it standard on the AMX, except I swapped the “Search 1” button to cancel out of the file browser. Also the “Panel”, “Search 2” and “Touch” buttons are unmapped. “Shift” as well, I don’t know how to use that, I don’t think Djay has a shift modifier function.

AMX: 10.9 KB file on MEGA

Xone K1: 13.4 KB file on MEGA

I have a bunch of other controllers that I might create mappings for, like the Pioneer SP-1, Xone K2, Launchpad Mini and of course the Akai AFX. :sunny:

Ok I see it’s probably a mapping issue.

There are things that you can do with the mapping ui and other things you have to via the text editor using the xml file such as adding a shift function and getting the vu meters on the amx to work.

The mapping file I use can be found here DJ TechTools - AKAI AMX - DJ.MG Official Mapping for Djay Pro (by Jay Neural) (DJ Juwansome edit)

Another one can be found here.
https://maps.djtechtools.com/mappings/10072

Make sure that the amx is the last thing to connect before opening up the app.

1 Like

Here’s how I setup.

1 I start with everything disconnected

2 I connect the Apple certified camera adapter.

3 I power the adapter

4 I add a 10 year old usb hub (unpowered) I explain later why at least for this setup.

5 I add my usb sick with music

6 I add the AMX and plug into my speaker

7 I open the app and verify that I’m in internal mode (don’t use external mode)

8 I plug in my headphones and play. And yes I can add turntables for dvs as is.

Notes

Your iOS devices require a 3amp source for optimal performance. With the 3amp source i found that my iPhone will pass 2amps through the USB port on the camera adapter. That’s why I don’t have to use the power plug for my hub :smirk:

Most usb hubs dish out 2amp total to spread out between the devices plug into it. The Akai amx needs 2 amps for the device itself. This means if you want to hook up multiple devices you’ll have to get at least a 3amp usb hub.

If you exceed the power draw from the usb hub or the pass through your setup won’t work properly.

1 Like

@Tessel you’re welcome. Glad to hear you’re making some progress. As I mentioned above, this is the preferred order of operations:

  1. Disconnect everything and properly close djay.
  2. Launch djay.
  3. Connect only the USB Hub.
  4. Confirm the blue peripheral icon shows up briefly on iPad at the top right.
  5. Connect power to the USB Hub and confirm your device is charging. If not, disconnect and try again.
  6. Connect your secondary MIDI controllers (before the AMX).
  7. Connect the AMX.
  8. If that doesn’t work, disconnect everything, hard reboot the iPad, and repeat the steps above.
1 Like

Thanks again both of you @Slak_Jaw and @Wyley! I followed your instructions and it is still not working as stable as it should. Sometimes I get sound, and I noticed sometimes I get distorted sound with extreme lag on the controller, most times I get nothing and have to start over. Even though I use the same method each time for connecting I get these problems. I have to fiddle a bunch, remove and reconnect, restart, switch to iPad speaker sound, deactivate that to activate Internal sound again, etc. And then sometimes it works. Sometimes not. It could be that my AMX is somehow broken but just now I saw that my new powered USB hub (which has 7 USB-A 3.0 ports I can activate each with a switch next to the port) only says “5V 1A” on the power brick so I guess it is too weak after all. That could explain it. My dream setup would be AMX + 2X AFX so I guess I would need a hub with a 6A power brick (each of the three controllers at 2 amps)? I skipped electricity class…

I loaded the midi mapping you linked, @Wyley, that is better, and when it works I get EQ lights. Thank you!

Also I should mention that when I open the “Djay menu” (Djay icon middle top) on my iPad there is a switch on the top right which says “Hardware mode”. Does it matter if this is on or off?

And @Slak_Jaw, step 4 does not happen on my iPad nor iPhone. There is no blue peripheral icon when I connect the Apple adapter. Maybe we use different iOS/iPadOS versions. I am on version 16.

Thanks for your patience with me, Algoriddim should put you both on their pay roll. (Great community.) :smiley:

2 Likes

The amx requires more power because of the 4in/4out sound card with phono pre amps. The afx has no sound card so the power draw is usually 0.5amp-1amp. (Most commercial devices and midi controllers use only 0.5amp)

You could plug the amx directly into the camera adapter and it should work just as long as you have a 3 amp charger plugged in. But you only get to use one device.

At least we can confirm the most likely reason why a lot are struggling to get the amx working properly. The Amx requires a lot of usb power.

Hope this helps

Btw I bought this hub a long time ago 5v-2amp

1 Like

@Tessel I’m on iPadOS 16.5.1(c). The blue peripheral icon only shows up briefly when you first connect the USB hub then it disappears so it’s easy to miss. See below.

@Tessel I agree with @Wyley. This sounds like a power issue or potentially an issue with your USB cable.

1 Like

Thanks! I just ordered another active 5A hub, if that doesn’t work I give up. :smiley: All my cables are good quality, ferrite new ones so that shouldn’t be the problem.

@Slak_Jaw Strange, I don’t see that symbol, but I think in some cases different devices show different icons (because of screen estate). I use an iPad 6th generation and an iPhone 13 Mini.

2 Likes

I’m using an iPad Air 4 and an iPhone 11. Well hopefully the new hub solves this for you.

2 Likes