Automix Randomly stops

I have been using djay 2 with my iPad mini 2 for well over a year with the supported ddj-wego2 controller. I use it to automix playlists before starting a live set. On June 12th, for the first time ever, the automix just stopped in the middle of one song. I tried to press “play” but it was just stuck. I had to manually start the next track on the other platter. This continued to happen that evening, randomly. I thought perhaps this could be due to the most recent update as of that time, so I updated to the latest release once it came out, restarted everything, iPad, the djay2 app and controller but it still “randomly” happens.

It is not specific to a specific playlist or song, so I cannot reproduce it on demand. I’ve gone over an hour without it happening, but at other times, it happens within 15 mins,

Has anyone ever experienced this issue or can someone please shed some light on what the issue might be?

No one has heard anything from them in about a week or so…

I am pretty sure that beta testing is dead… nothing for months now and they told me that nothing new was coming until sometime next year.

Sorry to hear that.
Did that also happen without your Pioneer DDJ-Wego2 controller being connected?
Which iOS is running on your iPad?

Ok, thanks a lot for the detailed information. We’ll start testing immediately.
Did you have similar problems outside the Automix?

I always use Automix with the wego2 controller. I am running a few tests with and without it to see if I can replicate and identify if the controller has anything to do with it. I will still be lost if it is the controller causing this.

My current iOS is 9.0 but this was happening with 8.4.1 and 8.4 which were what I was running from June until v9 came out. So it had happened across those two versions (8.4 and 8.4.1).

I’m running djay 2.7.10 and typically upgrade to the latest once a new version is out. This issue first started happening with either version 2.7.6 or 2.7.7. This also happened with 2.7.8 & 2.7.9.

The thing is, I have not changed anything with respect to the wego2 since May/June 2014. So I was running with this successfully without issue for a full year until June 12 2015 (which is when I first experienced this).

I’ll post some test results here once I’ve run several tests but please let know if you have any ideas.

Ok, so I ran 4 tests each for around 40 minutes using a playlist with automix with just the djay 2 app and it worked flawlessly as expected. I then ran 2 tests using a playlist with automix WITH the ddjwego2 and the tracks froze both times at the ~15 minute mark (test 1) and the 5 minute mark (test 2).

I actually noticed one time that after the track stopped, it restarted with some hesitation but then stopped within a second.

This concludes that there is an issue when using the ddj-wego2 with djay 2 on automix. As I stated above, this worked flawlessly for one year but started happening since I upgraded ios to 8.4/8.4.1. I have made zero hardware/firmare changes to the ddj-wego2 since day 1. (FYI, I just upgraded to 9.0.2 before running these tests).

What are your suggestions for next steps? Can I send Algoriddim the logs for analysis?

Algorriddim, I just found the same issue reported by several users at this post:…

Thanks Adrian. I have not experienced this issue outside of automix as of yet… We very much appreciate the support to get this reproduced and addressed! Let me know if there is anything I can help you test to identify the root cause.

Adrian, any update on this?

Algoriddim, do you have an update on the status of this issue?

Allgoriddim, any update on this?

Algoriddim, you asked me for specific data and test data months ago. I have provided that and am willing to help in any way to figure this out.

Over 3 months ago “Adrian” states that “you” will be testing immediately. After constantly trying to follow up, I have heard nothing for over 3 months.

I have not gotten a response from anyone and I am disappointed in your customer service. I’d appreciate a response either way. If trouble shooting this issue that is clearly affecting MANY and is one of the TOP issues on Your site is not in any of the current sprints, then please just say so.

If you intend to work on this, I’d like a tentative timeline of when this will be addressed. If I don’t hear back in a few weeks, I will abandon the Djay software altogether and just use Serato as my backup with my other laptop where I have received great support.