Beat grid not consistent lengths on one track

Hi,

I have a track where the beat grid is perfect for the first 4 bars and then has one beat that is slightly longer than the others so it suddenly is off by a small amount. It maintains this amount for the rest of the track.

I made this track so I know the beats are straight yet the algorithm seems to make 1 or 2 beats a bit longer, pushing it out. You can see in the image that the first 2 are in time and the 2 are a bit longer pushing it out by a little bit.

edit: this image makes it clearer. Both synced…

This only seems to happen for this one track. Are you able to advise?

Thanks

I don’t know anything that solves this because djay does not have the following:

I have multiple songs that exhibit the behavior you describe and I stopped trying to make it work because the features above are missing. One user once commented that it might be possible to rectify a beat grid by using the “Tap” functionality but this didn’t work as desired for me.

Man that’s annoying. It should affect me too much as I think it still plays the track consistently at the right speed so for live mixing, it’ll be fine. But it’s a shame to have the distraction of beat grid lines not being in the right place. I do like to use them in clubs with shoddy monitoring to help keen the mix squeaky clean.

Algoriddim chaos - can you add functionality to fix the BPM or edit specific beats? Any plans for this?

Yes I have the same issue with some tracks.

it’s definitely a glitch as the beat grid then stays constant for the rest of the track. so it’s correct and then suddenly has a couple of long beats and then it returns to being the right distance but is now a little off.

I hope they look into this as it’s a bit of a shame when it’s clearly done the BPM bit well - just randomly adding a bit of extra time suddenly.

Hi @Mrbigmouthbeats,

Thanks for reporting this issue with the beatgrid. If possible, could you share the track file with us that you’ve found this issue with? This will allow our team to reproduce the problem and take a closer look into what might be happening here. If so, please go ahead and drop it here, and let me know when you’ve done so.

Also, just to be clear on all the details, could you please tell me the following:

  1. What device are you currently using?
  2. Which OS version is running on your device?
  3. Which djay version are you using? (please open the djay settings and scroll down to determine the version number.)

Thanks in advance!

Hi Emily,

I have just uploaded the file for you to take a look at.

This happens on iPad and iOS (latest OS - 15.5). Haven’t looked at the Mac
version.

Djay version 4.0.2.

Cheers,
Dan

Thanks a lot, Dan! We’ve got the file, and I’ve sent this to our development team for further investigation. We really appreciate you sharing this, and I’ll keep this thread updated with any updates.

Hi Emily,

I have just uploaded the file for you to take a look at.

This happens on iPad and iOS (latest OS - 15.5). Haven’t looked at the Mac
version.

Djay version 4.0.2.

Cheers,
Dan

Hi Dan, can you please try the following:

  1. Open the track’s BPM settings in djay and enter a different BPM and apply.
  2. Then enter the correct BPM again (125.0) and apply.
  3. Finally use the edit icon on the waveform to set the grid (down beat) at the correct location (e.g. at the first cue point you have set for the track).

In my testing this allowed me to get the grid corrected. Hope this helps!

1 Like

Thanks for this! That has worked on both iphone and ipad. I’ll try on mac when I’m back home.

Dan Mason-Kyle
Mr. Big Mouth Beats
DJing, Music Production, Mixing and Mastering Services
Www.mrbigmouthbeats.com

Hi Anders, can I also drop am example in there?

Sure. Is it a similar case and did you try the steps above?

Oh. No. Sorry for bothering you, I mixed up a couple of posts. :sweat_smile:

1 Like