Cannot load rack error (OSStatus error - 12178)

I’ve gotten a (could not load track) the operation could not be completed (OSStatus error - 12178). This has happened several times right in the middle of a mix. My OS is up to date and it has happened with tracks that have played fine in the past.

Once it occurs, everything freezes and you have to restart the whole program in order to get it to work again. Has anyone else experienced this. This is disconcerting to say the least. I would never use this at a party. Wasted my money

Got the same! Got tracks from beatport!! Strange?

But the update doesn’t work when recording a set? It’s recovers but it stops the recording completely …

This reply was created from a merged topic originally titled
ERROR CODE 12178.

What does error code (OSSTATUS 12178) mean??? I brought some new tracks off of beatport, loading them on my iPad. Started a set, got 15 minutes in, then I went to load a track, the track playing, skipped then stopped and I got the error message come up … COULD NOT LOAD TRACK
The operation couldn’t be completed. ( OSstatus error 12178)… And everything went quiet

1 Like

Convert the mp3 files from beat port to AAC on iTunes, until ios7 drops !!! Problem solved!

Convert the mp3 files from beat port to AAC on iTunes, until ios7 drops !!! Problem solved!

Thank you everyone for your patience. We have released djay 1.6.4 for iPad and iPhone on the App Store, which significantly improves handling of this issue.

Specifically, while you might still get the loading error caused by the iOS audio system, djay will now recover from the error and continue playback (after approx. 3 seconds).

Unfortunately the underlying cause is an issue in iOS that we cannot work around, but we have notified Apple of the issue and will let you know when it gets fixed in iOS.

As said we have reported the issue to Apple and notified them of the importance of this issue for our users, and we regularly check on any updates. We hope this will get fixed with the next iOS update, but unfortunately it’s not in our hands.

We haven’t seen any issues with files using 256 kbps bit rate MP3 files, so that should work.

We think there’s a good chance it will get fixed with iOS 7, but we can’t say anything about it until it gets publicly released.

Unfortunately this issue is not something we can fix on our end, as it’s an issue in iOS 6.1 which Apple has to fix in an iOS update. :frowning:

We feel your frustration, unfortunately sometimes things don’t move as quickly as we would want them to. We cannot talk about iOS 7 until it is released due to being under NDA.

We know Apple is aware of the issue and are positive they will fix it, especially since it also affects their own Music app.

As written in the official answer above, this is an issue in iOS which we cannot fix in djay. You will find that every music app (including the official iOS Music app) has this issue. We have of course notified Apple about the problem.

This issue has been fixed by Apple in iOS 7.

We also just released version 2.1 of djay for iPad and iPhone, which is all-around enhanced for iOS 7 including a new library, faster song loading, and support for Inter-App Audio. It also contains new sample packs by Snoop Dogg and DJ Qbert. :slight_smile:

Enjoy!

Hi Jay,

Did you also send an email to our support team?

We’re currently investigating this issue. Please answer the following questions:

  • Which iOS version do you have on your iPad/iPhone?
  • Which djay version are you using?
  • Does this happen with the same songs consistently?
  • Do the affected songs have anything in common?
  • Are you using iTunes Match?
  • Have you tried re-syncing your music library via iTunes?

Please answer the questions in my previous post. Also, can you send the crash reports to support@algoriddim.com? Thanks!

Thanks. Yep, I just posted the questions for others who experience the same issue.

But if e.g. song “A” is affected, does it happen every single time you load song “A”?

Which audio file format are your songs in?