Cannot set focus on queue

This has been closed before as it’s a year old, but still no sign of a fix!!!

This thread explains the problem.

But with at least the DDJ-SX2 it is impossible to select the queue via midi as the controls when mapped do not work.

I’ve reopened this topic and will probably have to open another one in a year’s time when it still hasn’t been resolved….:face_with_symbols_over_mouth:

Hi @sooteee, thanks for your post. Unfortunately we currently don’t offer any MIDI actions to move the focus in the media library on iOS. I’ve added an internal ticket for our developers to look into adding this functionality.


As mentioned in the old thread though, ‘Switch Library Table’ should move between the various sections.

This doesn’t work.

Also, if you press Tab on the keyboard it toggles around and misses out the queue, but if you click into the queue and then start tabbing, the selection will happily skip in and out of the queue no problem.

Seems to be a massive oversight that we can have a queue but no way of accessing it from a midi controller?

Plus with other conversations with users on here some of them seem to be able to do it, so there must be something available for them that isn’t available for me…

I see, thanks for clarifying. I was thinking about the “Focus Playlists” etc. actions that are available in djay on macOS.

You’re right that “Switch Library Table” is available on iOS, and does not currently allow focusing the queue if it’s open. I’ll pass this on internally.

Yes, switch library table is also on MacOS but doesn’t get to the queue either.

There are two ‘focus’ options on the Mac midi table but the focus queue option is sadly missing there as well.

Cheers @Anders hopefully something will be sorted soon, as not being able to get to the queue without a faff is a bit of a grind.


On macOS “Switch Library Table” does move the focus to the queue for me if it’s open. Can you describe the behavior you’re seeing, e.g. which tables does the focus move between for you?

Thanks @Anders, after previous discussions I’m sure it’s a bug with the mapping for my DDJ-SX2 as other controllers don’t seem to have the issue.

Emily sent me a Dropbox link a while ago, I’ll screen record the behaviour and drop it in there for you to see.


@Anders unfortunately the link Emily sent has expired.

So I can’t Dropbox you the two videos I have of the behaviour in action.

Where would you like them sent?


Please use the following link to upload the videos:


Thanks, I’ve uploaded 2 vids, the first shows the behaviour without a controller attached and just using Tab on the keyboard.

You can see that Tabbing cycles through source>search>tracks and omits the queue, until I physically highlight the queue with the mouse and click on a track in the queue. The tab behaviour then cycles through and picks up the queue, but will not do so until physically selected.

The second vid using the SX2 controller shows the selection moving between folders and tracks, I then bring up the midi editor and use the same button, you can see that it is programmed to Switch Library Table and only moves between the two items. I then physically highlight the cue with a mouse click and continue to use the SLT command and it still does not select the queue regardless of what I try.

So, for me, it’s only possible to select the queue by tabbing on the keyboard and only after physically selecting the queue first.

Hope that helps.


Thanks for the videos @sooteee, they were very helpful.

It turns out this issue is specific to the “Finder” media library source. This is why it worked fine for me and other users, as they were probably using other sources like Music or TIDAL. I’ve passed this on to our dev team. :+1:

In the meantime, as a workaround you could import your tracks into the My Collection source, where Switch Library Table should work as expected. Simply drag your folder from the Finder source onto the topmost source (with the djay icon), wait a second for the source to get selected, and then drop the folder into the playlist section there.

Thanks @Anders, just gave this a quick go and all works as expected.

I can now use the controller! :tada:

Many thanks for troubleshooting this and providing a useable workaround.

Much appreciated.

S :+1:t2:

1 Like

Can you send a video of what you’re experiencing so I can better understand the issue? If it’s what I think it is then yes, this needs to be addressed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.