Connection issue with M1X-DJ

My IPad Air running IOS 7.1.2 with DJay 2 only intermittently connects to my Philips M1X-DJ. Most of the time it won’t recognise it and when it does it will suddenly squeal and then not reconnect. I have tried google and this forum and tried all different order of boot-up. Please don’t waste my time with the standard " hardware" problem. It does the same on two iphone 5’s. It is brand new ( a few hours old) as is the IPad Air.

Am regretting investing in all this equipment and App and it does not work

Hi Manie,

Thanks for contacting us. If you’re having the same connection problem with different iOS devices, then it’s most likely a problem with the Philips M1X-DJ. I recommend contacting the store where you bought it or Philips support directly to get your controller checked.

Hi Fernando,

If it’s not working with any of your devices, then I recommend contacting Philips support as well.


I actually just mixed with M1X with my iPhone 5 two days ago and had no issues.

As with the others above, please contact Philips support to get your controller checked.

Same issue here - kit just arrived, plugged in and powered up but won’t recognise my iPad (Air 2) iPhone 6, or other iPad Mini 2s in the house. I called Philips they just quoted compatibility at me (which is Air but not Air 2 and iPhone 5 not 6. I don’t believe there are any significant differences between these models so it looks like the item is faulty. Did anyone get this sorted? Is there a later build that works?

Hi I am having this same problem with 7.1.2 and with ios 8.

I have tried ipad mini, ipad air and iphone 5s

I also have a pioneer ddjwego and it works perfectly

I purchased through Amazon

It looks like a firmware problem to me

I have contacted Phillips support, opend a case with them and waiting for feedback

Hi Warren ios 8.0.0 or 8.0.1? thanks

You gotta be kidding me - terrible news!!

I tried to do a return on mine using amazon but they only have a 30 day return policy - so far Phillips does not give me straight answers on the phone and does not respond to my emails

I now have an oversized Bluetooth speaker in my office. This is the worst crap. Return it if you can and get your money back

This reply was created from a merged topic originally titled
iPhone 5 Connection Issue with M1X-DJ Running DayJ 2 Software.

I just bought the new Philips M1X-DJ sound system and it won’t connect to with DayJ 2 app via the lighting cable. I think the issue is the Day J 2 app won’t connect with the MIDI controller. Anyone have any ideas on how to make this work?

This is crazy after using the M1X for an hour and it was working fine now it won’t recognize the phone anymore and won’t work. I can’t believe Philips puts out a product like this. This is my second one with the same issues.

Yes, and to further troubleshoot the issue I’ve now switched both controllers with both base units to see if that made a difference. The short of it is the Philips M1X is a piece of crap and the controller sometimes works and then other times doesn’t. They probably brought it to market too soon and didn’t test it enough. It’s too bad as I wanted this to work as I have many good uses for it. I would advise against anyone buying it until Philips can work out the bugs with the controller.

No… in plain 2018 with iOS 10.2x my unit is not working anymore.
on the site of PHILLIPS
they suggest, that the unit is outdated and will no longer be compatible with iOS upgrades… (what a shame… Here in Brazil the unit still SELLS in some stores and on the internet???)
Does anyone confirm IF Phillips actually CAN??? update the unit?
I mean… Is there a way an iPad suck down a firmware and installs?
Also… Has anybody the unit working with iOS 10.2 (the latest as of JAN2018??
Help appreciated

Hi there, anyone solved this issue already? I returned my unit to Philips, got a new one but still the same issue. Can’t test it with another iOS device - I suspect it may be the ipod connector…

I am also having the same issue. I have tried both my iPad Mini as well as my iPhone 5S. I contacted Philips consumer support but the person I spoke to hardly knew what a Philips M1X-DJ was. They suggested a hardware issue with the M1X-DJ. Has anyone had any progress with this? Is there a sequence to getting it working e.g. Turn on iPad, started Djay2, plug iPad into M1X-Dj and then power on the M1X-DJ, or is there another order it should be done in? I have manually done a “Rescan for MIDI controllers” from the Djay2 app, but this hasn’t fixed it.

I called Philips. As my M1X was new, they suggested I send it back for replacement. I contacted the supplier who said they were happy to “refund”. So I purchased another before returning the first one. Same problem with the second M1X. So before packing the first to return it, I thought I would take some videos showing how I connect the ipad to the M1X and how they do not work together. Unbelievably the first M1X I had started working all of the sudden. I also tried my iPhone5S which didn’t work previously but now did. So I again tried the 2nd M1X I have and could not get it to work/recognize. I tried this many times but still could not get it working. So I returned my 2nd purchased M1X and kept the first. Interestingly when it wasn’t being recognized both the iPad and iPhone showed “Not Charging” where the battery/charge icon is on the screen; but it still charged. After it was being recognized, the iPad showed “Charging” properly. I have no idea why it started working all of the sudden. Did the M1X download a new firmware automatically when connected to the iPad? I haven’t tried my M1X with iPad for a while to test if it’s still working. It could be worth powering everything up for a while and just leaving the iPad or iPhone connected to the M1X for sometime. Maybe it takes a long time to recognize. You wouldn’t think so but maybe there’s something going on in the background before it can start working.

I think thar problem in initialization so maybe you should start working together with Philips and little patch will solve the problem.

I’ve got the same issue as well, i just bought the philips m1x dj for only 2 day, and now it won’t fu#king connect to the ipad, it said that there something worry with the cable, please give me a answer. i really love this device.