Crossfader FX and Old Automix Behaviour

And the pic for the automix section

@JahNick if you press the Mix Now button from the CFX menu while using Automix, it will use the mix duration set in CFX. Otherwise, if you let djay automatically perform the transition it will use the mix duration set in the Automix settings. To prevent confusion, I recommend you set the duration the same in both.

Hi, thanks for the answer. Maybe I’m missing something, but I don’t see a MIX NOW button in the CFX menu. Can you explain the advice regarding the MIX NOW button in more detail?
If you mean the cross fader function on or off, top right, this does not matter. Whether it is on or off, the CFX continues to master over the automix settings in the top left. Also as the automix auto or manual set. And that is exactly what I want and could do and can no longer do; set the bars yourself


1 Like


@JahNick it’s called Mix Now on iOS and macOS, but Transition on Windows

Just set the number of bars in the CFX menu at the bottom and the Automix Settings to the same.


I understand what you’re saying, but I don’t just want the choice that the transition only gives a limited number of bars on it. (2 - 4 - 8 -16 - 32). The automix feature does provide more options (all bars up to 32). And the transition mastering continues over the automix feature, even when the CFX function is turned off. It makes mixing much more difficult for me and the extra CFX feature is unnecessary for me. It worked better for this position. If it cannot be solved, I have to switch to another package to be able to mix properly

Hello! I want fully manual transitions. In particular, I’d like a track to end if I don’t intervene. Perhaps this is not something anyone ever wants?

If I play a song in Deck 1, then I cannot prevent djay from playing the next song in Deck 2. The only way I have found to stop this is to have no song in Deck 2. That does not seem normal to me, but maybe it is. I’d rather be in charge of my own transitions than have a mandatory automatic transition. Even if I stop Deck 2, it resumes on its own. I’m a novice, so apart from tenacious searching with google, the user manual, and these forums, I don’t have much expertise.

Settings: Crossfader FX = Off. Mode = Pro or Classic. Automix Off (“Off” meaning: Start Automix not pressed and Select Playlist or Add Songs not used). Start Playback Off. In Settings. → General everything is off except: Reset EQ…, Maintain Sync…, and Invert slider. Start Time = 0, Stop Time = 0. Autoplay when moving crossfader = off. Sync Mode = Sync + Tempo Blend.

iPhone 14 Pro. iOS 17.2.1. djay Pro 5.0.3.

Thank you for letting me know if I can turn off the automatic transitions.


1 Like

Simply turn off automix.

Hello everyone,

djay Pro 5.0.4 was just released. We made some adjustments to the CFX and added a new simple Fade Transition with no EQing or FX. Please test and confirm that this has addressed your issues. Thanks!

1 Like

Hello @Slak_Jaw
I’m about to run out of steam. Despite the 5.0.4 update, the simple cross-fader doesn’t work. I have no idea what you are testing - but it still doesn’t work.
As soon as I activate the cross-fader with the file buttons (right or left), the cross-fader FX switches on directly.
You can’t be serious any more ;-(
DJ Siggi


  1. Please try either turning the CFX OFF or,
  2. Selecting the Fade Transition.

Hello @Slak_Jaw

THANK YOU! That was it. I can’t see the wood for the trees. I will now test it extensively and also give feedback here again.

DJ Siggi

1 Like

You’re welcome @DJSIGGI. Happy to help

1 Like

Looks good! The Manual and Automatic crossfader transitions are behaving as expected. I tested the basic configs I use; it’s been a very good experience so far.

Crossfader Configurations:

  1. Crossfader FX OFF
  2. Crossfader FX ON
  3. Automix ON with Crossfader FX OFF
  4. Automix ON with Crossfader FX ON

Crossfader FX OFF

  • Manual crossfades uses standard Crossfader Curve.
  • Automatic Transitions (Left, Right, Inactive Transitions) use standard Crossfader Curve.

(Crossfader Curve Setting)Screenshot 2024-01-24 at 2.49.07 AM

Crossfader FX ON

  • Manual crossfades uses Crossfader FX.
  • Automatic Transitions (Left, Right, Inactive Transitions) use Crossfader FX.

Automix ON with Crossfader FX OFF

  • Manual crossfades uses standard Crossfader Curve.
  • Automatic Transitions (Left, Right, Inactive Transitions) use Automix settings.
    (Automix Settings)Screenshot 2024-01-24 at 3.03.35 AM

Automix ON with Crossfader FX ON

  • Manual crossfade uses Crossfader FX
  • Automatic Transitions (Left, Right, Inactive) uses Automix settings.
    (this configuration is the best of all worlds … in the Crossfader Multiverse)

Thanks for the summary.
This looks like the good old days too.

1 Like

Yes, I’m happy with these changes to the crossfader functionality. Just did two gigs with this stuff, and it works beautifully.

Only issue now on the DDJ-FLX4, the Smart Fader button cannot be mapped to the Crossfader FX Toggle (using the built-in mapping).

Hey Algoriddim, fix this important issue please.

1 Like

Hi BlackJack, You asked about the stems working with Tidal: Yes, in the older version (4.1.8) you can still use stems with Tidal. I need this for my gigs, so won’t update :wink: but I’ll miss all the 5.0 fun :frowning:

Sadly I had auto update turned on and I have got only iCloud backup and I can not go back to 4.1.8 :frowning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.