Crossfader Fx on external mixer

Hi I am running a pioneer djm a9 and 2 cdj300’s with a 2023 MacBook Pro, I have noticed On the latest update it says “Crossfader FX is now available on external mixers and all DJ controllers” however I can’t seem to find this option available anywhere? Is there something I’m missing ? Thanks

1 Like

Hey Peter

Just enable this option here, see pic below. I hope this help!

Hi @Peter_Lazarenko,

Please ensure that you are using the “built-in” MIDI mapping for your mixer (or if you made any edits, re-apply them to the built-in mapping).


The mixer doesn’t show up as a midi mappable device. Also the tab next to crossfader isn’t visible. Is this option only available on iPad ? Or should it work on MacBook to ?

Thanks but I do t have this tab or have the crossfader visible. Are you running djay on iPad or MacBook ? Thanks

once you have connect A9 to MBP just switch EXTERNAL MIXER mode / HARDWARE MODE

1 Like

There’s no option to do that on mbp only on iPad

oh boy, go to devices tab, select external

Hey thanks for picture but I have already selected that and when I do the crossfader fx and fader disappear. It’s only visible without the mixer connected. Is the djm a9 supported for this function?

as @NathanielAlgo wrote up there, use built in MIDI then should appear a small fader icon

The djm a9 does not show as a midi mappable device. I have it set to external mixer for audio but there is no option anywhere to set to use
“Built in” could you please explain where this is found ?? And also why doesn’t the a9 show as a midi mappable device?

is MIDI ON on A9? Should be state ON
also no one can help you if you can share only pierce of info about your setup! Its not string theory :))

Midi is switched on the a9 and no tab appears. Not sure what other information is needed im using a djm a9 connected to a 2023 mbp with cdj 3000s and ive shown all information available and it still doesn’t work. It does however work on my iPad Pro so I just dont understand why it’s not working on mbp.

As soon as the djm a9 is plugged in to the mbp the crossfader disappears on the djay app and left with no option to select cfx.

Oh and all firmware is the latest and everything is updated as should be so that’s not the issue.

I have tested with my own gear X96 with 5k iMac, and that drop down arrow appears - Do some restart, re-plug or something, that should be there. But don’t worry about CFX, currently doesn’t work well, its buggy enough.

Thanks for your picture. I have tried everything and it just doesn’t show the same as yours. Mine doesn’t show external mixer in the middle. l can only assume it doesn’t work with the a9 or there’s some kind of bug, Apart from that it all works perfectly.

Strange…try to add A9 in MIDI section…but I’m sure that will be just a small glitch in setup/adjustment…

That’s the thing it doesn’t show up in that section it’s not selectable I can only select it as an external audio device and there are no other available settings for the a9 whithin djay.

I have got it to work now, But I had to uninstall djay and re install it. Now I have the tab available to select cfx. Thanks for all reply’s people.

Glad you got it all sorted out @Peter_Lazarenko. Thanks for the follow up and for letting us know.

I am having the same problem with a Rane 70 - what exactly are the new MIDI settings? I am using a heavily customized midi mapping and really don’t want to have to remap like 75 things…I simply don’t see the crossfader effects tab (works in internal mode of course)