DDJ-WeGO Crossfader / Tempo control / Monitor Cue/Mix

Hello all,

as Apple Music is now available on Djay Pro for Mac (and iOS i guess) i thought about playing around with the software. So i grap out my old DDJ-WeGo controller, hooked it up to my Macbook Air and started the 2 month trial.
Works very well with the controller. So glad so good.

But i have a threee issues with the controller.

1.) Tempo Control. When i speed up the tempo it works. But when i want to slow down the tempo, the fader in Djay Pro stops at 0% i can not slow down to minus percentage. Do i have to change something to get the slider to minus percentage?

2.) Crossfader control does not work. When the DDJ-WeGo is connected to the mac, the crossfader control in Djay Pro disappears and i can not control it on the DDJ-Wego Controller. Why? (This is not realy a show stopper, as i am not using it so often)

3.) For queuing the next song on my headphones i have a mix knob on the controller. This lets me set up how loud i can hear the current song on deck 1 (played to the public) mixed into the song i want to queue up next. This does not work. (Knob does nothing)

For all three issues:
When i go to the MIDI settings for the controller the selection is jumping to the correct line. There is also set up the correct action but it seems i am missing something here.
The MIDI setup is done automatically by Djay Pro

Hope someone can help me to solve this issues. Thanks

I tried now to connect the controller to my ipad Pro M2. There everything seems to work. But why is the mac app not working correctly?

Edit 2
Ok, seems i had an old ipad version installed. In the new one, working with apple music, the tempo control also does not work correctly. Crossfader works.

Hi @gegy,

  1. Can you please clarify what controls are still NOT working on your WeGO on macOS?
  2. Which Pioneer DDJ-WeGO controller are you using (WeGO, WeGO2, WeGO3 or WeGO4)?
  3. Please visit the Pioneer website and download the latest firmware for your specific WeGO: https://www.pioneerdj.com/en-us/product/archive/#controller
  4. What version of macOS are you running?
  5. What version of djay Pro are you running?


Hey. Let me first thank you for your answer and your questions.

1.) Controls not working:

  • Knob Monitor/Cue Mix
  • Crossfader Slider

1a.) Controls not fully working:

  • Tempo sliders (only speed up a track, but can not speed down)

(Controls are marked in the attached picture)

2.) I am using the WeGo (without any number)

3.) Firmware is the latest one

4.) macOs 14.2.1

5.) Version 5.1 from the App Store

As for the ipad version:

iPadOS Version 17.3
On the iPad only the Tempo Slider does not work correctly. Has the same issue as on the mac version. Only speed up the tempo is possible.

You’re welcome @gegy. Thanks for the additional information.

  1. Please share screenshots of the MIDI Mapping settings for each of the controls that are not working on macOS.
  2. Please share a screenshot of the djay Settings>General>TEMPO showing the Range and Invert Slider controls.


Ok, i got the crossfade and the cue/mix now running.
The issue came from setting the Mixer Mode to Extern.
Setting Devices->Internal worked.

There are only the tempo sliders left.

Yes, the controller definitely needs to be used in Internal Mixer Mode.

Okay, please share screenshots of the MIDI mapping settings for the Tempo Sliders with the Advance Tab expanded.

Sorry, this is a screenshot of the german version. Hope this does not matter.

Thanks for the screenshot @gegy. I don’t speak German, but I think I see the problem now.

  1. Please expand the Elementtyp menu to reveal the options there and take a screenshot.
  2. Do the same for the menu to the right that says Standard.

Also, you can uncheck the MIDI Out as this is not needed.

Also, please provide a screenshot of the expanded Optionen menu. Thanks!

I can not expand the menu which says „standard“ because it is disabled (greyed out)

I set max percentage for tempo change to 10%. I can speed up the tempo to 10% with the controller. (Slide to +) But slow down the tempo (starting from 0%) does not work.

Hi @gegy, thanks for the screenshots. The settings look correct to me.

  1. What happens if you use the onscreen tempo controls? Can you adjust the tempo in the - range? If so, please set it to max -% onscreen, then try moving the hardware faders to see what happens.
  2. If this doesn’t work, the only think I can think to suggest is to backup your Mac, including the djay Media Library database file (https://help.algoriddim.com/hc/en-us/articles/360014912211-Where-does-djay-Pro-store-playlists-cue-points-and-other-data-on-my-Mac)
  3. Once, you’ve done this, delete the djay Pro app from your Mac, reboot then reinstall it. If that doesn’t work, then my guess is that it’s an issue with the WeGO hardware.

I am going to try your suggestion ajusting the faders in software next time i turn on my computer.

I realy don‘t think that this is an hardware issue of the controller, as the ipad version of Djay works without any issue. I think there is an issue in Djay Macos Version in the midi mapping or something like this.

I also don‘t think that deleting and reinstalling djay Pro is going to solve the issue as i have two macs and both have the same issue.

But i can try to delete the app and reinstall. I don‘t have stored any playlists or cue points at the moment, so no need to do a backup of app data for me.

I would try your suggestion with tempo sliders, but they are not shown when i turn on the controller. I can only see the percentage.

Hi @gegy, in the djay Modes section, look for Hardware Mode and uncheck this. This should bring back the Tempo Faders on screen when your hardware is connected. I don’t have access to a Mac, but this is what it looks like on iOS.

There is no such section/option in the mac Version. :man_shrugging:t4:

Okay, well maybe this is an iOS only thing then.