DJay Pro 5 Serious Audio Routing issues!


I have use a Xone 96 Hardware and iPad pro, and as I facing serious audio routing, and wrong Control Vinyl detection issues with DJay Pro 5. Here is a video about that! I hope this helps to fix this quickly. On this way DJay Pro 5 is unusable!

Hi @DJ-Z,

Thanks for sharing your post with the Community! We’re sorry to see that you are continuing to encounter this routing issue.

So that I can better assist you, could you please answer the following questions:

  1. Does this issue happen when your iPad is connected to either the USB 1 or USB 2 ports on the Xone: 96?
  2. Have you tried enabling and disabling the active MIDI feature via the buttons on the controller to see if that resolves the issue?
  3. Have you tried toggling on and off the USB 1/2, 3/4, 5/6, and 7/8 Ln/Ph switches on the back of the mixer to see if that makes any difference?

Additionally, have you tried recalibrating djay’s DVS feature? It does look like there is a very strong sensitivity being detected from the turntable.

Looking forward to hearing back from you. Have a nice day!

1 Like

Hi Nathaniel,

  1. Yes, on both port I have facing the same issue
  2. Actually, I have tried lot of thing, but this issues are not belong to MIDI function. DJay (iOS version) not support well MIDI communication with Xone 96
  3. Yes, I have tried now, switching between inputs, but nothing changed.

Of course I have recalibrated the DVS. But, I don’t think so that would be an extra strong signal coming from turntables. There was no issues with DJay Pro 4. As I feel, DJay Pro 5 detecting the same signal as an extra strong signal.

Thanks for assist me! Have nice weekend!

I have an update with that, it seems the sensitivity is stronger on deck 1, deck 2 sensitivity is fine, and if deck1 would be same as deck 2 that would be great. But as I have updated to 5.0.2, the issue is still have it, both issue, audio routing and extra sensitivity too. Do you have any news about that?

That would be important to fix it! Just imagine, in a very loud club, that extra sensitivity, issue makes hard feedbacks. It is not a complain, but this way DJay Pro 5 really unusable!

1 Like

Replying here as I believe my issue is the same. I am also using an iPad Pro with iOS 17.2

I have been using DJay 4 without issues for a while now so this is not an equipment issue.

I am using a Denon X1850 with 2 SL1200’s and in external mode the routing is not aligning between the mixer channels and DJay’s config. For example, when the mixer is outputting on CH 5/6 and I’m checking deck 2 DVS settings, the calibration menu in DJay will show a signal but it will still show the signal when I change DJay to use CH7/8 or any other channel.

DJay DVS calibration has also previously shown a signal on Deck 1 using CH 3/4 but my mixer had to output on CH1/2 for the signal to be picked up.

Lastly, when closing DJay and opening again all DVS settings are lost and I have to start again.

I can take a detailed video like DJ-Z has, but I think you just need to test DVS on iPad to see the issue for yourself.

At this point in time DJay is also unusable for me.

1 Like

We still have this issue on latest update (5.0.3.) One of this issues would be the most important to fix it.

Nathaniel, have you been pushed this issues your team?

1 Like

Hi @DJ-Z,

I just spoke with the engineering team and they’ve asked me if you are still having this issue with djay Pro 5.1.1. They said there was a known bug in 5.0.3 which should now be fixed. The team has tested this out with iPads running 5.1.1 and they cannot reproduce the issue you are describing. Thanks!

1 Like

I have tested on 5.1.1 but I have try to reinstall it…

Okay, @DJ-Z. Please provide an update as soon as you can so we can ensure if your issue has been resolved or not. Thanks.

1 Like

Here is an update, after reinstall DJay Pro on iPhone and iPad so far everything work fine, except recording! Recording function not starting once I have armed it. ( hardware mode)

Also, Cue volume is too loud, louder than before had it.

1 Like

Stream recording has never worked with any dj software. Streaming services don’t allow it. Part of their licensing agreements.

1 Like

I mean just recording not stream recording, sorry my bad!

1 Like

Thanks for the update @DJ-Z. Glad to hear that the audio routing issue has been solved.

Regarding recording of your sets, please refer to the attached article. If you are still having issues recording after reading this, please open a new topic for this issue. Please note that recording will be disabled if you load any songs from any streaming services onto any deck. Thanks!

1 Like

Okay, I will try it, previously that worked, issues only on iOS, on mac works well!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.