DJay Pro - Cannot Load Track

I’ve just installed the DJay Pro (via the App Store) on a new MacBook Pro (running OSX 10.10.1.

iTunes plays all my tracks without any problems via a drive running from my Apple Extreme but DJay Pro just throws up the following error: Could not load track: The operation couldn’t be completed. (OSStatus error -54.)

Any ideas? It’s a bit of a shame that I can’t use a brand new piece of software!

1 Like

just installed jday pro this week and found this thread after searching for the error. I am using an external HDD for all my iTunes music. it was working fine for several days using both spotify and itunes, then tonight itunes starting throwing the error. tried to eject and plug HDD back in and quit and restart the app. not working still…

another restart of djay and now loading again. I didn’t touch anything else. gonna be a difficult bug to reliably reproduce, good luck devs…

We’re currently looking into this.

So, are all of you using a Wifi NAS?

Thanks. It’s also on an “external” hard drive though, interesting…

The problem is iTunes, not djay.

Check the tracks in iTunes to see if there is an exclamation point next to the tracks. If so, relocate the track.

Djay can only see what itunes is properly sending… the problem is with iTunes.

I hope this helps.

When you open iTunes, hold down the option key. Then choose your correct iTunes library. Then let iTunes open. Close iTunes and then open Djay Pro.

That is how it works.

Try a different software… I am moving on. Too many problems and no one from the company responding.

I’m having the same problem, but with a NAS (Synology DS1813+) attached via gigabit ethernet, not wi-fi. This is an issue only with djay Pro; djay 4.2.3 continues to load everything as expected.

The specific problem being discussed here (failure to load songs on network-attached disk that would otherwise properly play in iTunes and the earlier, non-pro version of Djay) was a bug that has been fixed along with myriad other bugs in one of the subsequent point releases.

I’ve tried a permissions repair. I’ve now discovered that SOME tracks play - but the vast majority give the error message. I’ve tried playing the same tracks through iTunes and they are fine there, so there is something screwy with DJay.

Hi - I’m the guy that started this thread. Since the update, DJ Pro doesn’t play ANY iTunes track - I just get the same ‘Could Not Load Track’ error.

I’m very disappointed - it wasn’t a cheap app, and I’ve not yet been able to use it.

My only thought is that it is due to having my music stored on my network, and my iTunes Library files are local, something is screwed up (although this works fine for iTunes itself).

I’ve tried fixing permissions, resetting the PRAM etc - but this app is proving useless.

I’ve just started getting this error now. It’s worked fine for 3 days…

A permissions repair hasn’t helped.

Anyone have any ideas?

Hey, just fixed this !

My iTunes library is on an external disk using an alias in the iTunes folder called ‘music’

Somehow this alias had become corrupted, fixing it and finding the correct original has fixed the problem for me !

No, I have this problem intermittently in an external USB drive .

Occasionally ejecting and remounting solves the issue but it seems pretty random.

It’s idd that other apps don’t seem to suffer from the same ‘permissions’ problem.

Getting the same problem using a WiFi NAS

Same problem as wyatt “Getting the same problem using a WiFi NAS”

It reads the song names and information, but will not play.

No problems with the NAS or iTunes that I can find, never had a problem until I got Djay Pro.

Please please please fix, otherwise this product is useless without access to my 50 GB of music.

I’ve been restarting and trying again and again… Now the only songs it WONT play are the songs in my “recent purchases” which ate about 200 songs… Also the tempo doubling/halving doesnt work, the number changes but the tempo remains the same :frowning: not looking good for the future of this product

Yes I am using a wifi nas

Hi,

I am having similar trouble as described above. Djay Pro is not loading any of my iTunes tracks regardless of location of the library files. My iTunes library is split among multiple drives (internal and external), but Djay cannot load/play any of these files.
Permissions for all iTunes-related directories and files are set to 755 and 644 respectively.