Djay pro new update broke Beatport Login

in my MacOS montery 12.4 , i just updated today Djay pro software from app store to the latest version and cant login to beatport anymore, when clicking to login to beatport button, it does nothing. my beatport subscription is obviously active. I have a live play on Monday and my set relies on both beatport and soundcloud. Please check and fix asap.

Hi @Wi_k,

I apologize that you’ve run into this issue as of late.

Our dev team is aware of this bug and are working as diligently as possible with Beatport to fix this.

Please stay tuned to our General Discussion Community Catagory as well as the djay Pro AI for macOS Release Notes page for an update regarding this issue as to when it will be resolved.

Thanks!

There needs to be another login available in the “options” area, because Beatsource is not working for me. Or if you login on the net, it automatically transfer to the app.

1 Like

I’m running Monterey version 12.6.2 and DJay Pro AI Version 4.1.3.

Still having an issue with Beatport. When I open the software, it asks me to sign into Beatport, but the “login” button doesn’t respond when I click it. I can click the adjacent button “Learn More,” and it takes me to the Algoriddim website. But the “Login” button is completely dead.

I’ve uninstalled and reinstalled. DJay and my Beatport subscription is current. Plz help.

This bug is not fixed. Please re-open.
Beatport account is current, exact same bug.
(I’m on 11.6.8 Big Sur and can’t update because its an older mac, DJay Pro AI Version 4.1.3 )

It was working until yesterday when a reboot forced a logout from beatport and now I can’t login.

Clicking the [log in] button in the library header or the [Log in to Beatport] button in the floating panel does nothing. Does not show the login window.

Restarting the app does nothing.

Same issue as above. Can’t log into Beatport either. I’m on iPad running iOS 16.2

Hi @tinhat and @Felipe_Fenton,

Thanks for posting to the community for the first time!

We’ve noted as of recent that this issue is indeed still occurring for some users. This bug is in review and we will update this thread as new information comes in.

Thank you all again!

Uninstalled app and reinstalled. That seems to have fixed it.

1 Like

Hi Algo team
Before all was running perfectly. I am using on another software successful with the same subscription.
Between some days, Using Macbook pro m1 ventura 13.1. and last Djay Pro updated, I was lock on message need log in, and limited 2minutes on song. Clic on log in or message do nothing, button has no effect, no open anything. On tidal it looks run ok open popup, but not with Beatport. I try api.beatport.com login and logout, reinstall, deselect Beatport,restart delay etc… by always lock on log in. need message when open Djay Pro. How to login or drop credential manually ?

1 Like

Hi guys, this is not working… we are paying a subscription that we can’t use… it is unrespectful for your users… Yesterday I had to cancel a show due to this… please fix it ASAP!

1 Like

Hi everyone,

Thank you for your patience as we have still been working in tandem with Beatport to fix this issue.

Our dev team has shared an update with us regarding this issue which I will share below.

First check to see if your Beatport subscription is still active by following the link below.

If you do still have an active Beatport subscription then continue on with the next instructions.

  1. close djay
  2. log out of the API by going to this link: api.beatport.com/v4/auth/logout or api.beatsource.com/v4/auth/logout
  3. Open djay and attempt to log into BP/BS

Note: These steps will only work on macOS devices and not iOS devices.

Looking forward to everyone’s continued feedback.

HI @NathanielAlgo, thank you for continuing to troubleshoot this issue and for the update.

I’m running Monterey version 12.6.2 and DJay Pro AI Version 4.1.3.

I followed your suggested steps and uninstalled/reinstalled, but still doesn’t work. However, this time I get an error message. That’s progress!