djay Pro not recognizing Hercules DJ Controller


I have been having a very frequent issue with Djay Pro, as it has troubles recognizing my dj board.For it to recognize, I have to continuously restart my computer until it works again… The issue has been extremely annoying, and has discouraged me from using the app again, have anyone else experienced these issue before?

Hi @Jake_Waggoner, for me to help troubleshoot this, please provide more details about your setup.

  1. What specific Hercules controller?
  2. Are you using the latest firmware for this controller?
  3. Does the controller have a separate power adapter and is it connected when using with djay Pro?
  4. What version of djay Pro? Do you have an active paid subscription?
  5. What macOS version?
  6. Mac hardware details?
  7. How exactly is the controller connected to your Mac?
  8. Have you tried different USB cables?


Hi again @Jake_Waggoner, I’m following up on my post from 7 days ago. If you are still having issues, can you please respond to my post above? If I don’t hear back in a few days, I will consider this solved and close the topic. Thanks!

Hi… I’m having a similar issue, I believe.

I have a Hercules DJ Control MIX Audio Mixer (38968631/p?utm_source=google_products&utm_medium=merchant&id_producte=16314850&country=au&gad_source=1&gclid=Cj0KCQjwhtWvBhD9ARIsAOP0GogKRCQ6tblu6ARfGHu-aP6tLPksJ_8Unen-nVJP0yuP4T3dDDb7be8aAozpEALw_wcB) and it used to work with DJ AI pro on my Mac PRo with Sonoma 14.4 until recently. I connect it and my DJ AI pro app does not recognise the controller but you can see the controller is turning on.

the controller does work on bluetooth with my iphone but not with the my mac. Are you able to assist or guide me on how to fix?

can you see this? Not sure if replied to the right thing.

Other answers to your questions

  • i have a paid subscription and using verion 5.1.3
  • I’ve tried different connectors

Hi @Justin_Edge,

  1. Can you please share exactly how you are connecting the DJControl Mix to your Mac? For example: wired USB connection, wireless Bluetooth connection. Photos of all connected cables and adapters would be helpful.
  2. Do you know what has changed in your setup between when it was working and when it stopped working? For example: macOS update, djay update, different cables or adapters.
  3. Please share a screenshot of your djay Settings>Audio Devices
  4. Please share a screenshot of your djay Settings>MIDI Devices


Thanks @Slak_Jaw.

  1. I’m connecting through a wired USB to a USBc. The cord works and turns on when plugged in. It just doesn’t work with the djai pro program.

  1. Nothing at all. Possibly a MAC update to a new OS but not 100% sure. Is there anyone else experiencing this issue?

Is there anything I can do to troubleshoot or is there anyone else experiencing the issues?

  1. Audio devices

  1. midi devices

Hi @Justin_Edge, thanks for the additional details.

  1. I suspect the issue is with that USB adapter and cable you are using.
  2. I recommend you use a high quality USB cable with the right connections on both ends so you don’t need an adapter.
  3. I’ve had many cheap adapters and cables fail over the years.
  4. Please note that not all USB cables work the same. Some only work for charging and cannot transmit data. Some have limits on the charging power and some transmit data at different rates.
1 Like

Hey I used Hercules DJControl Mix too and I have been using it for the last 9 months at least.

First of all, i believe this is a Bluetooth controller, rather than a ‘cable’ controller.

95% of the time i use it with my Ipad Pro Gen 5 12.9", prior to this was Ipad Pro 11" Gen 2/3 i think and prior to this was Ipad Air 11" something.
The remaining 5% i had to use 3 times with my Macbook Pro M1.
I have never tried to use it with a cable but rather through the Bluetooth to MacBook Pro.
Here’s roughly how i did it.

  1. install the driver:
  2. Bring up spotlight on your mac, type in “Midi”
  3. Open Audio Midi Setup App.
  4. Add the controller (Bluetooth
  5. Then head over to DJay app, you should see the Djcontorller in the selection~

Good luck


Only for macOS Sonoma 14.4:
Please check
in order to see if the cable/USB/hub … is considered as USB asking permission under system settings → privacy and security → allow accessories to connect. This is new feature in macOS Sonoma 14.4. Waiting apple to fix it


Thanks for sharing this @Angel!

A post was split to a new topic: Pioneer DDJ-FLX4 Connection Issue - iOS