Effects in cue - where are you?

Hey again,

for long I was using djay pro only with decks and external mixer, but since I use it with internal mode & controllers, I realised that in CUE I can not hear the effects - only of course in master cue.

But many times we would like to hear the effects, sometimes I start the mixing with the effects – and right now I can not pre-listen the songs with the effects.

Trust me, it seems like a trifle, but its not.

Cheers!

1 Like

Hi there,

This topic has been suggested here and here previously.

We all live in hope…….:grin:

3 Likes

A post was merged into an existing topic: Looper Pre-Cueing & Audio Routing Options

Hi there,

I have merged this thread into an existing topic entitled Looper Pre-Cueing & Audio Routing Options.

Have a wonderful day!

Hi @Imi_Trcz,

Could you answer the following questions below so that I can provide a clearer vision to our dev team about your request?

  1. What device are you using djay on?
  2. What OS version is running on your device.
  3. What version of djay are you running?
  4. What is your current hardware setup when pre-cueing these tracks?

Looking forward to hearing back from you!

Hey Nathaniel,

of course. MacBook Pro M1, macOS Monterey 12.1, Djay Pro AI 3.1.9., and Denon MC7000 (but was the same with NI Traktor Kontrol S3).

Thank you in advance!

Cheers,

Imi

Hi @Imi_Trcz,

Thank you for the additional information!

I will definitely make sure this gets to the dev team for further consideration and I will update this thread accordingly in the future.

Looking forward to your next great suggestion!

1 Like

Hi again @Imi_Trcz,

I wanted to follow up with you just to clarify if you were referring to the sampler “audio effects” when making suggestions about the effects playback via pre-cueing.

Am I correct in assuming this?

Looking forward to you response!

Hi Nathaniel,

thanks for getting back. Actually, I reffered to the deck effects (on the yellow box) and to the deck cue (green box). In master cue we can hear the effects - of course, that’s the master signal. But it isn’t enough, pre-cue the deck effects is essential.

Thank you, have a nice weekend!

1 Like

Hi @Imi_Trcz,

Thanks for the clarification!

I will continue to speak with the rest of the team about this request and update this thread with any new updates!

Hi @Imi_Trcz,

Are you currently using the “Post-Fader” FX routing setting when trying to monitor FX in djay?

Using the “Pre-Fader” FX routing setting would allow you to monitor FX in djay. It’s not possible to monitor these via the pre-cue channel with post-fader routing.

Please let me know if changing this setting achieves the functionality you were looking for.

Hey Nathaniel,

thanks for getting back. But honestly, I can not really understand the question, could you please help me out with this?

The point is to hear the effects in CUE, regardless the position of the channel volume. Right now I am only able to hear the effects, if it goes to the master signal.

Thank you, and have a nice day!

Hi @Imi_Trcz,

In the djay preferences menu under the “Mixer” tab you will see an FX Routing setting that gives you the choice between pre-fader and post-fader. See the attached screenshot.

Choosing “pre-fader” should allow you to hear deck FX in the pre cue channel.

This is exactly what I was thinking about / searching for. And over all the time, it was already there - shame on me.

But the point is: thank you! :slight_smile:

1 Like

I think this is not a good solution because you lose post-fader fx which I would want to have enabled at all times. It’s good to know that it‘s there and that it’s possible but this way, I will truly only use it when I’m practicing.

1 Like

As has been mentioned the pre / post fader option is not the solution to this.

If I set an echo effect, I want that echo to still be doing its thing when I’ve moved the crossfader to the opposite deck. The post fader setting achieves this, turn on a deck, set an echo, fade over to the empty deck and the echo is still audible.

With pre fader option. This does not work. Set an echo, fade over to an empty deck and silence……

I would therefore always want the pre / post fader setting to be on post, so as the fx continues working when I’ve switched decks.

The effects in cue requested here are to allow us to hear what an effect might sound like before I send the sound out to the master channel.

For instance, a track is playing along at 128bpm and I want to add a gate effect, currently (as the effects bar is a bit of guesswork) I don’t know if the gate effect is going to be in time with the beat or sound like someone’s let a 3 year old loose with the volume controls.

So I’d like to be able to PFL to the effect in the headphones to allow me to adjust it to match up prior to ‘releasing’ it and sending it to the master channel, knowing full well that the effect will sound good and match up to the music when I do.

Hopefully that explains why using the pre / post fader settings is not suitable as a solution to this problem…

:+1:t2:

1 Like