External Mixer Mode Audio Routing for Looper

I believe I am experiencing a bug with the recently added External Mixer mode on both MacOS and iOS. I am running the latest OS versions and latest DJay Pro AI versions on all devices. I’m using an iPad Air 4 and a MacBook Air M1. I’m using a 4 channel Vestax VCI-400 SE Ean Golden midi controller. I know that the VCI-400 can work as a standalone 4 channel analog mixer. I have the necessary firmware for this and have used it in this way before.

Perhaps I misunderstand how the External Mixer mode is designed to work. What I would like to do is to route the Looper audio only to Deck C or D on my VCI-400 instead of straight to the Master output. This way I could adjust the EQ, Volume and also pre cue the Looper output in my Headphones. The only audio routing options available within the External Mixer setup are ch 1-2 and ch 3-4 (see attached screenshot). From my testing using ch 1-2 sends the Looper output straight to the Master output and ch 3-4 sends the Looper output to the Headphone output. Within Internal Mixer mode I also have the choice of ch 5-6 which is the Microphone input (see attached). There are no options to select the individual Deck Channels A, B, C or D. Perhaps this is a limitation of my controller or perhaps I am trying to use the External Mixer mode in a way that was not intended. Can someone please provide some input or suggestions? Thanks.


Thank you for getting in touch. We were checking the issue internally. In the Internal Mixer Mode the Looper is directly being outputted to the Master (which is the Vestax VCI-400 in your case). External Mixers in general provide several channels to choose from which you can assign to designated decks, the Sampler and Looper. You would need a variety of channels to make use of the External Mixer mode, which I would not suggest with the VCI-400.

Is there anything limiting you from using the Master as Looper output in the Internal Mixer setup?

Hi Lukas,

Thanks for the reply. I normally do use the Internal Mixer mode with my VCI-400. However, I was hoping that with the External Mixer mode I could route the audio of the Looper to Deck C or D on my VCI-400 instead of directly to the Master Output. This way I would be able to pre-cue the audio from the Looper before playing it through the Master Output. Also this routing option would allow me to EQ, Filter and adjust the Volume level of the Looper from my controller.

there is so little discussion and answers here…I will contribute the best I can. I would guess that the VCI400 does not support true external mixing. Most “controllers” will have a stereo USB signal for master output and another for cueing. If it were designed for external mixing, I would expect at least 4 downstream stereo USB channel pairs. Controllers are generally designed to provide additional controls for mixing within the PC or laptop and then outputting the end product to the master outputs.