Has Rane MP2015 been tested and confirmed compatible on iOS?

  • Device model iPad 9th gen
  • iPadOS 17.4.1
  • Version of djay 5.1.6
  • Hardware/controllers used: Rane MP2015

I’ve now got my official Apple camera adapter and spent the afternoon trying to get DVS to work with both my Reloop Flux (works, but has known latency issue) and more importantly my Rane MP2015 which is my main mixer.

This has not gone well, djay Pro seems to lose its mind when I connect the mixer, the UI becomes unresponsive for seconds at a time and I hear intermittent clicks on the master output as if its reconnecting every 10 seconds or so. The USB input light on the mixer illuminates but the outputs are not available in djay.

On my Windows laptop things work fine, with the exact same lead. Any suggestions what’s going on here please?

According to the gear page, the MP2015 is officially supported on iOS — so it should just work.

Well yes, but has it been tested on iOS?

Also to add, GarageBand is happy to connect to it on the iPad, no problem. As mentioned djay works ok with it too from Windows using the exact same cable, it’s only the iPad+djay+MP2015 combo that has the problem.

Just checked what happens on my wife’s iPhone 12 Pro Max, and it behaves exactly like the iPad. In either case if I’m in the audio settings in djay when I connect the USB, it will sometimes show the default channels for the MP2015 but the UI becomes so unresponsive that I can’t change anything or play music. The speakers continue to click intermittently every 10 secs or so, as if it’s trying to reconnect to the device.

From what’s been mentioned so far, my guess is that the MP2015 has worked with DJay in the past (on earlier iOS versions) but over time Apple have made some OS changes that have affected the performance.

With GarageBand being Apple software, that presumably would have been updated with the same changes, but it does help to show where the problem lies.

Hi @mikeb187, please confirm that the Apple Camera Adapter is also connected to your original iPad charging brick and charging cable. Please also confirm that your iPad is charging normally when connected.

Confirmed and confirmed. Well, to be absolutely exact, my iPad was bought used and came without a power brick, but I’ve used both my wife’s iPhone charger and her MacBook Pro charger (no shortage of amps from that) with the same results. Clicking noises from the speakers and I also now notice occasionally the blue LED on the mixer’s USB port goes out briefly then re-lights, not in time with the audio clicks.

But there shouldn’t be a need to run power to the adapter given the MP2015 is mains-powered (obvs so long as the iPad has good charge) right?

I don’t see how this can be a hardware issue with the adapter, power supply or cabling given how GarageBand is working fine.

Oh, and the iPad does charge fine with either of these power supplies connected via the adapter

Great. Thanks for confirming @mikeb187. Have you checked the RANE website for updated MP2015 firmware?

Also, please try the following:

  1. Disconnect all cables and adapters from your iPad and mixer.
  2. Close djay.
  3. Perform a Forced Restart of your iPad (Force restart iPad - Apple Support).
  4. After restarting, connect your Apple Camera Adapter to your iPad and confirm there is a blue peripheral icon in the top right of your iPad screen.
  5. Connect your MacBook charger and cable to the Camera Adapter and confirm that your iPad is charging before moving to the next step.
  6. Connect your mixer to the USB hub using a high-quality USB cable (ideally with dual ferrites on either end).
  7. Confirm that your mixer powers up.
  8. Launch djay and test again.
  9. Navigate to the djay Settings>Audio Devices and share a screenshot of this page.
  10. Navigate to the djay Settings>DVS and share a screenshot of this page.
  11. Navigate to the djay Settings>MIDI Devices and share a screenshot of this page.

Many thanks for the fast help here @Slak_Jaw, much appreciated!

I’m on the latest Rane firmware, as best as I can tell, although it’s a bit confusing. The Rane Control Panel (which I’m running on Windows) is the latest v2.4.0 and from reading around it seems that it will offer to update firmware to latest if needed. It’s not doing so, so I think that means I’m up to date. The reported firmware version is 1.1.1

Re your steps:

1-3 done
4. No icon appears when I plug in the adapter, but are you sure there is one? It’s not on Apple’s list here: Learn the meaning of the iPad status icons – Apple Support (UK)
5. Done
6. I’m using a decent cable although it doesn’t have ferrite cores - it’s only 1m long tho
7. Mixer is mains-powered as discussed, I’ve power-cycled it before connecting the lead in this test sequence
8. Yep, same problem
9-11. Attaching those in a sec

You’re welcome @mikeb187!
4. I no longer have access to an iOS device with a Lightning connector, so perhaps this icon doesn’t pop up when using the Camera Adapter. This is what it looks like on my USB-C iPad when I connect a USB-C Hub:

Yep seems that is specific for USB-C connection status: Lightning cable icon on my iPhone - Apple Community

Screenshots follow, looks like it’s recognising the mixer as a MIDI device but not for audio…

Just navigating around the Settings screens is subject to 5-15 second delays. Sometimes I can catch it in the act of showing the Rane audio outputs but it won’t play a track, not even through iPad speakers at that point, and it’s difficult to know when it’s accepting user input for taps due to the delays.

Very strange.

  1. It’s a bit of a long shot, but I would check your iPad Lightning connector and clean out any dust bunnies. I’ve had intermittent Lightning connection issues before and this solved it for me.
  2. Also, try the Reset to Defaults button at the bottom of the Audio Devices menu.
  3. I can’t think of anything else to suggest, so I’m going to forward this onto the engineering team to see if they have anything to suggest regarding the MP2015.

@mikeb187 As you’ve proven so far that the MP2015 works with GarageBand but not with DJay, I’d suggest trying a few more (non Apple) audio apps to see if it works with those too.

The more apps you try (and it works) the more likely it becomes that the issue is with DJay.

Hi @mikeb187, I checked with the engineering team and they were not able to reproduce what you are experiencing with the RANE MP2015 unit they have. Can you please double check whether it actually passes multiple channels of audio in Garage Band with the exact same cable and adapter without any unusual behavior?

Yes, GarageBand can hear the inputs ok. I used an air can to blast the USB-A and Lightning sockets, interestingly after doing the USB-A on the adapter GB wouldn’t recognise the mixer at all (nor the Flux) until I blasted the Lightning port on the iPad too. So I’m now suspicious of the adapter, I think I need to try another one to check, and get a top quality lead to remove any chance of an issue there. This will take a few days to sort.

Meanwhile it’d be good to know the exact setup your devs are testing with, can you confirm please?

iPad model
iPadOS version
MP2015 firmware version

@PKtheDJ thanks for the helpful input, much appreciated too - can you suggest some (free) apps that I could try for this?

Try Figure from Reason Studios. Remixlive from Mixvibes. Launchpad from Focusrite. SoundForest.

Thanks for that @PKtheDJ :pray:

@Slak_Jaw if nothing else please can you confirm what firmware version they have for the MP2015? If it’s different (esp if more recent) than mine then that’s the first point of order for me to fix.