Headphone pre-cueing sound distortion/degradation

hi, i have a mac mini that i am using the latest verson of djay with, the master volume goes through the macs hdmi output to my tv which my speakers are connected to and I’m using some plantronics headphones which i am using for pre-cueing through the built in outputs on the mac, everything works fine at first but after 2 mins or so the sound on the headphones starts to degrade (like the bit crusher effect) to the point where it becomes inaudible and then silent…i can get the sound back perfect by reconfiguring the audio devices to a different output then back to built in output but obviously this is not an ideal solution!! please help!

I’m also seeing this issue. HDMI out to amp, pre-cueing using the headphone out on my iMac. Within only two or three tracks there is terrible distortion on anything playing through the headphones.

It’s rendering Djay unusable on my 2011 iMac - shame as it looks great (but sounds terrible).

Is there a fix for this?

Hi Ali,

We are currently testing and investigating this issue. I’ll get back to you asap.

Hi Everyone,

This issue seems to occur when combining certain audio devices.

If you have a multi-channel audio interface (or a controller with such a built-in sound card like the Spin (2)), then I recommend using it for both Main and Pre-Cueing output:

  • Main Output: Spin ch 1-2
  • Pre-Cueing: Spin ch 3-4

In case you do have/want to combine two different audio devices (e.g. built-in + another sound card), it might help if you either:
(a) use the external sound card as Main output and “Built-in” as Pre-Cueing

or (b) select the external sound card as “Clock Source” as described by Chris above.

  • Open the “Audio MIDI Setup” app (located in Applications/Utilities)
  • Select “Show Audio Window” from the “Window” menu
  • In the left tab, click on “Aggregate Audio Device”
  • On the right, select your sound card as “Clock Source”

Hi Darryl,

Sorry to hear that. This thread is for djay for Mac, though.

Please kindly create a separate post or send an email to support@algoriddim.com. Make sure to provide as much information as possible. Generally speaking, I recommend trying to restart the app and the iDJ Pro first and see if that helps.

Hi Charles,

What is your Devices setup?

…?!..

Any solution yet??? I have nearly the same problem but with my Numark Mixtrack Pro as the pre cue, and my MacBook pro’s headphone jack as the main.

This isn’t solved… Why is it marked solved?

same here

i just updated… problem sitll exists

bit of a joke. algoriddim have been developing new stuff like crazy but can’t fix an old problem to save their lives.

It’s a total disaster. The Only reason I hadn’t lost my mind completely was because over a year ago I figured out that SOMETIMES it works to restart everything and run the main out from my computer, just using the spin for pre-cue… Problem is… Sometimes it works sometimes it doesn’t. I don’t know what kind of idiot software developers work at DJay… But seriously… It has been a known issue for over a year and you guys still sell your faulty software/hardware combo.

Mick O’Donoghue

3 years of no help. I’m sure whatever issues arise with the pro version will be solved in a mere 2 years.

i have the same problem

hi

i have the same problem… i have just got the Spin 2… i have the headphones on channels 3-4 and use the mac as a main output. when i pre cue using the headphones it starts to distort… the first spin controller did not do this… any ideas…? or do i get my money back?

i hope they fix it!!! for £259 i might just send it back lol the first controller was fine no problem.

I have fixed this problem. My Mac is about 5 years old, will be getting a new one soon… however, if you are getting distortion / then no sound through your headphones, fear not… Open up your midi settings on your mac, at the top click onto Aggregate audio device select vestax spin 2 Audio Out as your clock source. This should then fix the problem! - Hope this helps!!!

Ok… so I used the spin 2 at the weekend, used it with the griffin imic. All seemed well, however the music coming out of the main speakers started to sound awful!!! I’m guessing this is because it’s fighting against another sound card!!! - Either a new Mac might fix this problem, or I’m going to have to use the main out (RCA) out… my next gig is on Wednesday…, ill keep you posted!!!