How to BPM Only Sync with Variable BPM songs?

  • Device model: MacBook Air M1
  • Version of operating system: MacOS Sonoma
  • Version of djay: 5 (latest)
  • Hardware/controllers used: Denon DJ MC7000

I have a techno song with fixed bpm as the master sync on deck 1.

I have a city pop song with variable bpm on deck 2, synced to the techno song.

Why does the city pop song only sync perfectly when „Beat Sync“ is activated (just „BPM“ doesn’t work)?

Why is the city pop song desyncing when using pitch bend to adjust the transients in „Beat Sync“ mode?

Generally said: Why don’t variable bpm tracks just sync to other tracks by fixing bpm to a stable number? It seems like variable bpm songs are only synced with Beat Sync but the moment you touch that song it desyncs.

I thought the cool feature of djay pro would be that variable bpm tracks could be transformed into fixed bpm tracks with the click of a button to create easy mashups, but I don’t get why it’s designed like I described…

Hi @Yo_damn, sorry for the late reply. I’m not 100% sure, but it sounds like you might be experiencing an issue with Master Tempo. Please carefully read the linked FAQ on how Sync in djay works and the linked discussion on how djay determines which deck is the Master Tempo Deck. In most cases, if you have both of the deck volume faders up, sync will behave more intuitively.

  1. https://help.algoriddim.com/hc/en-us/articles/360011647580-How-does-the-Sync-function-work
  2. Understanding Sync / Sync Master / Tempo Reset [Win / DVS]

If this doesn’t fix things, could you please try to capture a full screen video of this issue, upload it to your Dropbox/Google Drive, enable sharing permissions, and share a link to the video here. This will help me to more clearly understand what’s happening. Thanks!

Here is the exact issue (video has no sound but it’s easy to see what happens)

The looped song has fixed bpm (140) while the second song has much slower and variable bpm and is synced to the fisrt track (Sync is set to “BPM” not to "BPM and Beats).

As long as I don’t touch the second song, it syncs just perfectly. But the moment I use the pitchbend buttons (f.e. to correct the timing/groove by a slight amount) the second song gets desynced while the software still says it’s at 140bpm (which is not true).

As you can see in the video, the transients of the second song are perfectly analyzed, so why does it desync after some time if it says its exactly at 140bpm like the other track?


And now that I have the attention. Why is it also not possible to create loops, that start before the audio file? There are so many songs that start with a kick-off that’s not on the 1. If I want to have a loop that starts before that kick-off (to get the transients and timing in perfect phase, which is almost impossible using cue), why can’t I just start the loop before the audiofile begins?

I’m asking this especially because djay indicates the negative bars with numbers and I don’t understand why that would be a thing if i cannot interact with this silent region.

Thanks for the video @Yo_damn, that helps to clarify things. Can you please also share a screenshot of your djay Settings>General>SYNC MODE. I want to make sure I understand exactly how you have this set.

Translated Sync Mode Settings:

Thanks for the screenshot @Yo_damn. I believe this is expected behavior when using Sync Type: BPM Only. I understand why you would want to maintain BPM Only Sync with a variable BPM song while still having manual control over the track alignment using the jog wheels. I suspect this is likely a limitation with how the current Fluid Beatgrid system works, but I’ve forwarded this to the engineering team to get their thoughts on it. I’ll report back here when I have news.

1 Like