Inaccurate Looping - Loop going longer or shorter than desired

First off - I love Djay. It’s a really great, intuitive program.

Although it has one weird looping quirk that is really throwing me off. I’ll hit “loop in”. Then (when I I want me loop to end), I’ll hit “loop out.” Instead of ending the loop when I tell it to, Djay will either end it a bit beforehand or a bit afterwards.

For example, say I want a loop lasting from :35 to :38. I’ll hit “loop in” at :35. Then I’ll hit “loop out” at :38. Instead of the loop ending at :38, it’ll end at :40. Unfortunately ending the loop at :40 doesn’t sound good. I’ll try over and over, but the loop refuses to end when I tell it to.

Any thoughts? Is some weird setting turned on?

I’m using 4.2, fyi.

1 Like

Oh no it sounds like this is a dead end… i just bought Djay Pro for iPad and Mac plus a hardware controller only to find the looping is buggy. This is a disaster. Anyone from DJay team- should I jusy start returning and refunding everything or is this something you’re actively working on? Seriously guys this is a core feature you cannot afford to have it buggy like this. (As with others in this thread, seems to be on tracks with less obvious transients on the 1- Memory gospel by Moby is the one Im loking at right now). Please advise

I LOVE Djay Pro and use it all the time, but I have the same trouble on seemingly random songs.

What I don’t understand is why the GRID works at matching up the beats perfectly, but the LOOP doesn’t work? Why aren’t the GRIDs and the LOOPS calculated with the same function? Shouldn’t they both work the same?

I also LOVE Djay Pro (Mac OS X version). But…

Am I to understand that this looping problem has been an issue for 4 YEARS and hasn’t been fixed yet?

4 YEARS?

Come ON!

Mr. Hansen is describing the same situation I regularly have.

PLEASE fix this

Hi Matt,

Thanks for your feedback.

The loop start/end points always snap to the nearest beat. There shouldn’t be a 2 sec difference though.

i have this same problem - but only on certain tracks. it is very annoying, and needless to say ruins a smooth transition or danceable extension of the groove…

and yea i count out the beats and always loop on a downbeat, so it really does seem like a bug - maybe a problem with reading certain types of rhythms.

light over shadow by mickey hart is a classic example of a track i can never get to loop correctly - part of the 5 percent, as all the other loops i attempt work perfectly.

Bump this thread, trying to loop the opening piano solo of My Immoral by Evanescence, it appears to be impossible with the looping functions, even manual in/out looping. Love this software but this functionality is a big deal :frowning:

Mr. Akman is making a good point, but for clarity there are two different issues here.

The AutoLoop feature does snap to the beat, and while this is normally very useful, there may be situations where you would want this loop to be offset … so that it starts just before the beat (at the instant I pressed AutoLoop) then lasts the preset length (with the same offset on the end). This as an option would be useful. It would create a loop that is uniform in length, just “slipped” slightly off of the beat grid.

However… the issue that I and many others are raising here is actually a software bug. (speaking as a software engineer I’m pretty sure of that). The bug is that the LoopIn/LoopOut feature, which works perfectly on songs with a predictable beat grid analysis… is totally erratic on live recorded songs. Instead of ending the loop when I press Loop Out, it will end the loop at a seemingly random point within a beat or two of where I wanted it. It does not even snap to the nearest beat, it just jumps somewhere that you did not intend. This tells me that something about the loop in/out relies on the beat grid and perhaps some form of calculation… when it could have just noted the timecode at the moment I push the button. This bug is in the Mac OS X app. The iOS app behaves differently, where the Loop In/Out does seem to snap to the beat… but still snaps to the wrong beat on the Out.

A common symptom in both of these apps is that the moment you press Loop Out, it will NOT start precisely where the loop began but some time after… once the loop has completed once on its own it will start at the correct Loop In point, but the Loop Out continues to be off its target.

Again, I am using the 14 second piano intro of My Immortal by Evanescence for my test loops to illustrate the bug.

Thanks for the reply Warren!

It must be an issue with the beat matching then. The case I’ve tried over and over is with Black Sabbath’s “Hand of Doom.” I’d like a loop that takes me from :12 to :17 (the very end of beat 4 of that measure). Instead of letting me end the loop at the end of beat 4, it forces me to end the loop at :18, which falls in between beats 2 and 3 of the next measure.

Any advice?

YES. The inability to truly select a manual loop is super frustrating and prevents me from using DJAY for creative sampling.

Loops that snap to the nearest beat don’t always sound the way I need them to. Especially for music not made on a computerized grid.

Please add an option for manual looping in an update. This alone would made djay 10x better IMO.

I was hoping this would be fixed in DJAY 2.0 but I’m having the same issue.

Yep. I guess it is only with certain songs…still, very frustrating.

An option to turn on and off snapping would be great. Otherwise LOVE the program :slight_smile:

Yes I am agree…DO you work on a solution?There any update shortly?VJAY
Regards

Hey Warren, has there been any further developments with this aspect of DJay Pro? I don’t have this issue with my app version (Djay 2) but always on the desktop or laptop versions. Is there any way to bring the app functionality of the looping to DJay Pro? Like some of the others here, the majority of the music I play is not quantised or on a grid. As mentioned, the ability to disable the snapping function would be much appreciated. Cheers.

Any updates to this? Pro still snaps to grid rather than transient.

Thank you for the response and I look forward to the solution. Btw, I think the product is great and with a few more tweaks would be amazing. Good to see the support side has been stepped up. Thanks again.

Hi Rio HUNUKI - HEMOPO,

thank you for your feedback. Please note that we are aware of this issue and are doing our best in order to provide a solution as fast as possible.

Cheers,

Lukas E.

Hi Rio,

thank you for the nice feedback, we will let you know if there are updates regarding the looping issue. 

Cheers,

Lukas E.

Hey guys,

thank you for your feedback, we are working at improving the algorithm and will provide a workaround soon, too.

Stay tuned and sorry for the inconvenience.

Cheers,
Lukas E.