Interaction problems with iDJ PRO

Just picked up a iDJ Pro from Numark at the DJ Expo in AC. Having a few issues mostly small but one big one. The small ones -

  1. the tape marker does not show when hooked up to the numark
  2. according to the box, efx like sway, absorb, punch and twist, and drift are included but i do not have them- i have gate, filter, bit crunch and flanger
  3. the key lock feature should have an off/off feature in the settings. it is always on on my main hardware units. there really isnt an inbetween for this.

Now the big one. When scratching on either side, it just stops. Sometimes i can go thirty seconds sometimes 2 seconds. The controller does not interact, i can’t even search. It’s like a buffer underrun or something. any thoughts? Ipad 3 and Djay are all running current versions.

I have similar issues to the ones described above. Thought it was a hardware issue but connecting my iphone DJAY app works fine. This problem is an intermittent lock up of either some or all of the buttons on the console. Cycling the power to the IDJ Pro does fix the issue but it soon returns. Console completely unreliable and unuseable. Ive got a DJ set to do on friday night. I’m pretty fed up with this.

yes. I realise i should have bought pioneer.

Two things i’ve recently discovered that may help some people who are experiencing crashing IDJs…

  1. Make sure iPad is charged to 100% before plugging into the IDJ
  2. Perform a RAM reset on iPad before your set. To do this hold the power button and home button for over 3 seconds until the ipad reboots. This will clear the ipad’s RAM memory.

Did a 3 hour set last night with no glitches. Happy again.

Dave Hutchinson - did you try the suggestions I made here? I had the same problem as you did until I got a decent laptop type power supply for the IDJ (maplin electronics) and started my IDJ only with a 100% charged iPad.

I’m losing patience with the IDJ PRO now. Investigations lead me to believe that the fault lies with the numark hardware. I shall also be returning my IDJ for a lab test and no doubt it will return with “no fault found”. I think algorithm need to address these issues with numark before this excellent app loses all credibility!

Warren, I appreciate that you want to help us but I really don’t have the time to be trying this, that and the other. I have spent many wasted hours already trying different settings on my ipad, removing files, ram resetting, even things like turning siri off. Every time I change something, I reset, play several tunes and then it crashes again.

One thing that is apparent is that my iPad indicates “not charging” when this happens. I seem to recall the lightning flash charging symbol when it is stable. My iPad charges fine when used with normal iPad charger.

Fact is that even at this price level fundamentals such as stability should already have been ironed out. I’m already looking for a replacement, probably the pioneer xdj aero. Shame but I need to get on and play music for my listeners!

Ok so lets all share what equipment were running here. My iPad is a 4th gen wifi only with 128gb, retina display and lightning connector. Model ME392B/A.

I use a genuine apple lightning adaptor. I bought a second one thinking it might be the source of the problem.

I’m using the latest updated version of DJAY2.

My numark console has a date of March 2013 stamped on it. The long serial no is (21)N11303932100171. The shipped power pack is a “sunny sys1308”

No it doesn’t seem to happen at the moment it crashes.

I’m going to try to do my radio show tonight with my iPhone 4S instead of iPad connected. Will report back.

No it doesn’t seem to happen at the moment it crashes.

I’m going to try to do my radio show tonight with my iPhone 4S instead of iPad connected. Will report back.

Ok, so I’ve done two 2 hour sets without any problems using my iPhone 4S instead of the iPad.

So, Clearly this issue is related to the compatibility of this iPad with the IDJ. I’m also not having any problems charging my iphone when it’s connected to the IDJ - unlike the iPad which does not charge, or at very least maintains whatever charge is in the iPad.

Any suggestions for improving the compatibility if my iPad? I’ve tried removing the majority of music off the ipad, I’ve tried it in ‘do not disturb’ mode, with Bluetooth off. I’ve fully charged it, ram reset, turned off Siri, updated software. I’m reluctant to do a full factory reset as the iPad is setup for everything else I need and it’s solid in every other application.

Buying the pioneer xdj aero soon but still interested to know what’s causing this problem if it can be a help to others experiencing the same.

Just an update on my IDJ issues. I finally took my unit back to the shop (DJSTOP CROYDON) and they very kindly exchanged it for a brand new IDJ. So far I’ve had no further issues .

I have not updated my iPad to ios7 as there are still issues to be resolved by numark/djay so for me this unit is still not a good buy I’m afraid. Add stable support for ios7 and it’ll be a good little unit.

A replacement IDJ fixed this for me.

Still looking for a better unit though… Pioneer xdj looking promising but lack of decent waveform display is putting me off a bit.

The only thing that worked for me in the end was taking it back to the shop for a replacement unit. I’ve had no issues whatsoever since then (almost a year). I suspect certain units are developing electronic faults after a while.

Just to chime in, I don’t know if this is helpful or not, but I recently had a weird experience using the iDJ pro at a gig - whenever I plugged it into the PA system the platters would freak out. When I tried to recreate the problem at home the next day everything was fine, I couldn’t recreate the fault. I tried everything I could to work out what was going on, until I saw someone on the numark support site talking about platter problems and the issue seemed to be something to do with either static electricity, or an earthing problem affecting the capacitive touch capabilities on the platters.
I think the iDJ is very fussy about power, and in my case I think that I was plugging into a system that wasn’t earthed properly which was causing the fault.

Found a typo…not an off/off feature…off/on, obviously

Yea I hear ya. I sent it back to be fixed (big issue) and they respond with - we cannot recreate the problem - well I recreated it as soon as they returned it by plugging it in an turning it on and not working after about 2-3 minutes of use. It just loses All response (the left wheel) It’s BS. First and last numark product I buy. The only thing it’s good for is making my iPad look a little more pretty :0)

I only bought the unit as a backup and a ceremony piece for my mobile gigs. I have only used Denon my entire 24 year career. I still do

Thats the same excuse they said to me. Its definitely the chip inside the unit. its faulty design is destroying a great innovative idea. I only have the problem with the left platter when scratching for more than about 2 min after that - well, you know…