Jogwheels Reloop Mixon 8 pro not tracking properly

NOTE: Please use the search function above before posting to avoid creating duplicate topics.

  • Device model: Reloop Mixon 8 Pro
  • Version of operating system: iOS, latest, macOS latest, Windows 10 latest
  • Version of djay: 5.1.3
  • Hardware/controllers used: Reloop Mixon 8 Pro

I have serious troubles with my brandnew Mixon 8 Pro.
The Jogwheels are not tracking properly.
for example, when doing a backspin, the software is way sooner finnished spinning the track back and then continues playing normal, while at the same time the physical jogwheel is still spinning backwards.

also when doing scratching, sometimes the track scratches forward but not backwards, like i’m not pressing hard enough on the platters.

i found 2 video’s on youtube of someone who has the same issues, describes best whats wrong with the jogwheels:

i have contacted reloop, they advise me to return the unit to the reseller and ask for a new one.
also i noticed when flashing the firmware for the first time, v 53.39 was pre-flashed. very strange because currently the latest available firmware on reloop’s website is 50.39 (??)

another strange thing: when i unboxed the unit and tried it out, the mixon 8 could not be detected by Djay Pro 5 as it didn’t exist. not on my ipad pro, not on windows and not on my macbookpro. but after flashing the only available firmware v50.39 it became detected.

i found another thread on this forum with similar jogwheel issues, telling that after flashing the same firmware for the second time the responsiveness came back.
so i did that too, flashed 50.39 for the second time. rebooted. it is indeed a littlebit better for some moments and some time later it got a bit worse.

I also raised a support ticket at Algoriddim, but they haven’t responded yet.

Also note that i have a pro-license for VirtualDJ, which natively support the Mixon 8 Pro
when using VirtualDJ with the Mixon 8 Pro, the Jogwheels are tracking perfectly! no issues there.
even when doing a fast backspin, the software tracks perfectly with the physical movement of the jogwheels. So this tells me the problem must be within the software of Djay.
i also did some teste with Traktor Pro 3 with some custom mapping, it tracks just fine with mixon 8’s jogwheels.

i also own a Mixon 4 which does not have the tracking problem within Djay Pro 5 and in fact the jogwheels of my Mixon 4 feel far more premium than the jogwheels of my Mixon 8

Algoriddim has to fix this fast otherwise i’m returning my mixon 8 and just keep on using my mixon 4

Hi @PascalRidder,

Thanks for the detailed explanation of your issue and sharing the videos. This is very helpful. I personally have this same hardware and zero issues. I was going to suggest installing the firmware twice because that’s what I did when I first got mine, but I see you’ve already tried that. My gut feeling is this is a hardware issue, but I will follow up with our engineering and support team to see if they have any other suggestions. I’ll report back here when I have news. Thanks!

fyi: i also noticed a rattling sound when turning the unit upside down. (i turned it over because i was looking for the serialnumber, needed for registration)
it sounded like a like some loose little screw flying around inside the unit.
The reseller got back to me, telling me to return the unit, they are sending me a new one.
Personally i don’t think the loose screw inside is the problem, because everything works just fine with other software (VirtualDJ/Traktor etc)
I have lilltle confidence that a replacement will solve the jogwheel-tracking issue.
When i got my replacement, i will report back here


Thanks for the follow up @PascalRidder. Well it sounds like there’s definitely something wrong with the hardware, but I agree that it’s strange that it works with VDJ.

Please don’t forget to install the new firmware twice when you receive your replacement and report back if the issue is solved or not. I’ll also share any thoughts from the engineering and support teams when I hear from them.

1 Like

My Mixon 8 did the same the other day at a gig … right deck froze …


the horror! i think i’ll stick to my mixon 4 for now i want something that actually works flawless

@PascalRidder - Do you think this is hardware or a software issue? I’ve only updated the firmware once since I got the controller a few weeks ago… Si think after reading your post, I’ll do that again… I had the Denon prime 4, bought this because the prime 4 was having issues… :see_no_evil: I hope it’s a software issue! And soon gets fixed. Could do without the hassle!

I definitely think it is a software-issue (or software-firmware combined issue) because the same macbook connected to my mixon 8 with VirtualDJ tracks the jogwheels perfectly. the same goes with my windows 10 laptop connected to the same mixon 8 with VirtualDJ on it and even with other software Traktor Pro 3.

The issue is only in this combination: Djay Pro 5 (iOS, macOS, windows) with Mixon 8
This combination tracks perfectly: VirtualDJ (macOS, Windows) with Mixon 8

maybe i will make little video tonite to demonstrate the behavior of the jogwheels difference between VirtualDJ and Djay Pro on the exact same hardware (my macbookpro and my mixon 8). same hardware, same FW version 50.39 on my mixon 8
for the moment VirtualDJ does it right and Djay Pro does not.

I hope Algoriddim will address this issue soon

1 Like

Just updated mine again with the firmware. I agree, I think it has to be a software issue. Hopefully it will get sorted. I’m out tomorrow night with the Mixon 8 pro… Hopefully it will work!

Hey, I made those videos. I had two different units and the same thing happened with both. Also I noticed the same rattling noise when turning the unit upside down to check for the serial number. I ended up returning the Mixon 8 because of the issues I was having.


Hey LogisticalStyles! how nice of you to tune in :smile:

i hope you don’t mind i posted your videos to show what’s wrong with the jogwheels.

i shot a little video of my own to show that VirtualDJ does the tracking right and Djay does not (with all the same hardware)

note that i also have an ipad pro, making no difference on the jogwheel behavior between Djay pro on ipad and Djay pro on a macbook.

i even tried the same on a windows laptop running VirtualDJ and Djay.

1 Like

I don’t mind you posting the videos at all. I am relieved to see that I am not the only one that has experienced this issues. I tried using the Mixon 8 with Serato and had the same issue with the controller. I am not sure if the problem is with the app or the hardware. I mentioned in my last post that I moved to the Denon LC6000/ I can tell a difference in how the Denon works with DJay Pro vs Serato. The LC6000 works well with both platforms but DJay Pro seem to not be as tight with the response and it requires more effort to set up. It makes me wonder if Djay Pro just has issues with platters and displays.


I can imagine you’re stepping away from the mixon 8 and move to Denon gear with current issues you have with the mixon 8, even after you got a replacement with the exact same issues. I had not tested my mixon 8 with Serato yet, so i just tested it and it appears to track the jogs just fine, just like VirtualDJ and Traktor do. i am convinced the problem only exists within Djay pro, not in the other dj software. Don’t get me wrong, i love Djay pro for it’s amazing beatgridding and stems-seperation capabilities. this problem has to be fixed by Algoriddim in my opinion. I am sending my mixon 8 back to the reseller anyway because of the loose screw inside (opening it up myself will void warranty).
when i get my replacement, i will test it again with Djay pro. if it still has the tracking issue with the jogs, i will also move to Denon hardware. Maybe a Denon SC-live4 or a Prime 4+


FYI: i started an RMA procedure. my mixon 8 is on it’s way back to te store in Germany, waiting to receive a new one.


just a headsup:
i returned my Mixon 8 and decided not to wait for a replacement and wend for a complete different setup
Allen&Heath Xone PX5 analog mixer and a pair of Denon DJ LC6000 all three of them connected to an ipad pro. one of the LC6000s is still in backorder but will arrive this week.

in addition, PX5 has sends&returns for external gear. so i’ve hooked up another ipad pro with an external audio-interface to the sends&return channels of the PX5. running iOS software AUM and all kinds of AUV3 plugins on it which gives endless possibilities and sculpting your own delay/reverb effects just using a 2nd ipad as external fx-unit. (for those who wonder, there is some bit of a latency but barely noticeable 128 samples/2.5 ms)

i’m still waiting for the 2nd lc6000 to arrive, but so far it works really well and sounds really amazing :smiling_face_with_three_hearts: :sunglasses:


Really good to hear it’s worked out for you. You’ll be really able to sculpture a good sound there.

1 Like

Okay, thanks for letting me know @PascalRidder. The engineering team is still trying to figure this out directly with Reloop, but I’ll consider this topic closed for now and will reopen it if new information comes in. Thanks!

I’m also having a problem with my pitch fader , I’ve contacted my supplier, I thought I didn’t have any issues as I was jus palying music and not mixin ect all afternoon until started mixin at night then I noticed , I’ve poste it on ere , my controller came with firmware 3.4

First question. Have you updated the firmware?

Yes ,to latest version , everything is updated , also tried my MacBook Pro and a older iMac