Loops + Neural Mix + Sync = Weird

When I have an active loop on deck 1 and a song playing on deck 2, weird things happen when I use Neural Mix stuff in the middle of the loop. When the loop reaches the beginning again, the sound is audibly out of sync. It takes a short while to correct and then it is fine again for subsequent returns but it‘s slightly disconcerting and just sounds bad.

On older hardware, even weirder stuff happens: on my iPhone X, the playhead goes out of the loop until the neural mix effect sets in. Only then does playback return to normal.

Hardware: iPad Air (4th Generation)
iOS 14.1
djay 3.5.10

This still happens.

To reproduce:

  • have a song on each of your 2 decks
  • put deck 2 in a 16 beats loop
  • hit play on both songs
  • hit „sync“ on both songs so that the sync button turns blue
  • change to the faders menu
  • switch to the Neural Mix tab for the looped song
  • shortly before the end of the loop, bring the Drums fader all the way down for the looped song

When following these steps, the loop will be out of sync once it reaches the beginning again. It will then attempt to straighten this out again which sounds weird.

Hi there

Just tried it on my ipad Pro 11" and all worked fine…

Changed songs, force closed app, tried again etc but I cannot replicate it.

Mine stays in sync. :slightly_smiling_face:

Oooh…just tried doing something different and it does go out on the first time the loop goes around.

Once the loop is going around for the 2nd, 3rd etc time then it stays perfectly synced.

Maybe I didn’t notice it the first time I tried and as the loop had already gone around once I wouldn’t see it again.

So, yes, you’re right… :+1:t2:

True, only on the first time around! Thanks for trying it out and for the correction!

LOL, made me sound like a right grumpy old pedant now!! :stuck_out_tongue_winking_eye:

1 Like

Hi,

What music sources/formats are you using specifically? I’ve run through the steps on an iPad Pro and can’t reproduce it.

The two songs I’m using both come from Music.app, in .m4a format. The one on deck 1 is 13.5MB, the other one is 11.8MB. I’m of course happy to share those with you directly.

I made a recording of the behavior here:

It might also be that your iPad Pro is just too powerful :sweat_smile: As I say in the beginning, this gets worse with older hardware.

I replicated it on my 11" Pro…

Which year version is it?

I made the video with a version from November but can confirm that this still happens with the latest version (3.6 on iOS, tested with an iPhone X on iOS 14.3).

Hi Dan, mines a 2018 1st Gen 11" Pro.

I’ll grab a screen recording and post it up later if I can.

I can’t upload here, but you can see on the first loop around where one track is playing catch-up with the other.

:+1:t2: