Mac and iOS - Couldn’t load track osstatus error 2003334207

Hi Everyone,

Many thanks to all of you for reporting this issue here on our Community. Our apologies for any inconvenience this may have caused you!

This is an issue that has been reported by djay users over the last few days, and our Development Team was able to fix this bug with SoundCloud in djay. :pray:

The issue has been fixed on djay Pro AI for Mac and the update should already be available on the Mac App Store. For djay Pro AI on iOS, the updated version with a fix for this issue should be available on the App Store in the next couple of days. Please update your app(s) when it’s available, and you should no longer encounter this issue.

Please feel free to reach out with any further feedback or questions, and thanks again for your patience while our team worked on a fix!


Oh wow Thanks :blush: this is amazing news, thank you so much for looking into and resolving this so quick, I’m definitely happy I chose to work with Djay Pro 1st, as there software is as amazing as there customer service and team work :partying_face: I will definitely check this update today to let you no if it’s all performing well for me and look out for the App Store update also. Please say thanks to your team for resolving this in time for the weekend. Some of us will not even notice this happened, as it was resolved quickly.

KiNG Sc0RPiAN :wink:


Boom! Working on the mac now. Thanks so much!!


Ok so I’ve had sitting on the update screen that was blank for about 15mins were the tracks still wasn’t loading while testing, as I thought it might have updated automatically but after leaving it on the update screen for the 15mins. I looked round and saw the update was now showing. Installed and loading all tracks perfectly but will test it properly later today :wink:

**Thanks it FIXED :heart_on_fire: **


please hurry with the iOS app update, this is making me want to just go full on Serrato and am now forced to transfer playlists and will just drop the app if this is how it’s going to be for a while

1 Like

Hi how did you get it to work. It’s not working on my iPad Air. Can you share the steps what you did.
Thank you

1 Like

It will hopefully be available for Monday in App Store for phones etc but is already available for Mac users to download now :wink:


A post was split to a new topic: Windows and Android - Couldn’t load track osstatus error 2003334207

I’m using djay pro for iPad Air 2021 and songs that I’ve previously been able to select and stream from soundcloud are no longer loading and I’m getting the OSStatus error 2003334207. The tracks still exist and are still present in soundcloud and in my liked tab but a lot of tracks that used to be able to select are no longer being able to be selected. Any advice?

1 Like

Same thing happening to me, actually supposed to play a party and this just screwed me. Guess it’s time to drop the app

1 Like

There was a problem this week with this, that the team have fixed :sweat_smile: you will need to download the new update. The iOS version will be available in a few days but the Mac version is available to download now :ok_hand: there’s another forum here regarding this same topic


There’s a new update that will fix this issue :wink:

1 Like

Not in the apple App Store tho

Hi All,

As has been said above, this SoundCloud issue has been fixed on djay Pro AI for Mac and djay Pro AI for iOS, and the updates are available on the App Store. Please update your app(s) when you get a chance, and you should no longer encounter this issue.

If you’re having this problem on djay for Android or djay Pro for Windows, please head to this thread for news and updates:

Thanks for your patience and understanding! :pray:

1 Like

Will this be fixed on dJay Pro 2 for Mac?

Hi! It’s just wanted to say a massive thanks to all the staff who worked on the problem AND fixed it so quickly. Attention like this makes me want to continue using this great Dj app and tool. Well done guys and thanks so much. When I discovered the problem I was initially absolutely gutted but now it’s all fixed I’m a happy Statik xxx


Hey @lagoon,

If you haven’t done so already, please reach out to our Support Team for individual support with your case by submitting a request ticket here. Please reference this Community Topic thread in your request. Thanks in advance!

This is still not fixed. Having the issue with iPhone 13 no matter what I use, files, Apple Music, etc…


Please note that is another issue. This thread was about the OSStatusError on SoundCloud. Please note this error (OSStatus error 2003334207) is caused on Mac and iOS when djay can’t locate the files you’re trying to use. djay knows the location of the files, but if this error shows up it means that your files are not located there anymore. Something must’ve changed in your library pathing since the last time you used that file. Please try relocating the file through Finder/Files or re-add the new file paths to djay.