Midi Fighter Twister problem with scratch and monitor mapping.

Good day,

I tried to add some basic functions to the Midi Fighter Twister Djay mapping to be able to toggle pre-queue monitor and scratching. This, to be able to use it as a more complete controller. Pre-queue monitor should be obvious and the scratching just for positioning the track after loading.

I did sacrifice the FX2 control in Bank 1 for this, i.e. switch and rotary 8 and 11 with these settings.

Midi Fighter Twister:
Rotary

  • Sensitivity, Velocity Sensitive
  • Encoder Midi Type, ENC 3Fh/41h.

Switch

  • CC Hold

DJay:
Rotary

  • Deck X, action ‘scratch (no touch detection)’
  • Control type Rotary (3Fh/41h)
  • Speed and response for convenient control (25% speed, 75% reaction)

Switch

  • Mixer, Deck X, Monitor Active. Contol type Button, default.

Works fine, but occasionally the scratching and Play/Pause (existing mapping) blocks.
After you move the track with the mouse a bit, the play/pause works again, but the scratch only starts working again after restart of Djay.

I can’t figure out what is the cause of this, please advise.

Thanks and kind regards, Bart.

1 Like

@Brainbox its a bit of a long shot, but how is the MF Twister connected to your Mac? Could be a bad cable or interference. Also you could try turning Wifi and Bluetooth off on the Mac. Make sure you aren’t running any other applications but djay as well.

@Slak_Jaw , a bit of a bull’s-eye long shot!

After replacing a bit old Apple adaptor with a USB hub I had lying around, I managed to play about an hour without issues with mail, browser and what not running. When replacing I also found out that in case of blockages it is just possible to disconnect and re-connect the controller and everything starts working again in a running set. All Midi-out’s are correctly sent after re-connect and good to go from there.

Thanks!

1 Like

@Brainbox perfect! Glad that fixed your issues.

1 Like

The verdict is that the issue still occurs with the other hub, but with lower frequency.

Strange. What about your USB cables? Do they have ferrite chokes like these?

The cable that was shipped with it. With the ferrite chokes. I will buy a B to C cable to omit the hub / adapter.

1 Like

I received a chroma B to C cable and tried it yesterday in a performance.
The problem still persists … in a 2-hour set I got 2 blockages … :expressionless:

Ruled out:

  • Cable. Although an old low-tech A to C Apple adaptor is bad.
  • Other programs running, on a loaded system it performs equally well.

Unsure:

  • Correctness of mapping, see first post. But on the other hand, what could be wrong, it is fairly simple at that level.

I also did issue a ticket … but can’t follow it nor add new insights … @NathanielAlgo
Although this piece of hardware might be a niche, it is just fun to have sufficient knobs to mix with individual stems without a nagging cross-fader that sits in the way … I think a setup like this might be the future of mixing … :innocent:

Cheers :slight_smile:

@Brainbox can you share your mapping file here so I can test it out on my setup?

@Slak_Jaw did already try, hopefully soon, it is the pair of mapping and device settings that would be needed imo.

This is the Djay midi mapping:
DJ TechTools Midi Fighter Twister Edit.djayMidiMapping (60.9 KB)

@Slak_Jaw, all,

It looks like @NathanielAlgo algoridm is not going to change the upload options soon …
So maybe if you would like to try, you can configure the knobs as mentioned in my first post manually.
Sorry …

Cheers, Bart.

@Brainbox it looks like the DJ TechTools mapping page is back up if you want to share your files there and provide a link here.

https://maps.djtechtools.com/

@Slak_Jaw,

I’ll do that this evening, made a small improvement with the loop settings sensitivity, so if I put it there it should be the best possible, will ping here after I did … :slight_smile:

1 Like

It is either not my day or the internet became sloppy overnight … :slight_smile:

I managed to put it on dropbox, pfew …

This mapping is based on:

For my changes of bank1 see first post.

Both mapping files in a zip:

Picture of the bank 1 mapping:

Cheers, Bart.

Did anyone have the guts to download it from dropbox? :innocent:
I just can’t upload anything to the maps.djtechtools site nor to the djtechtools forum …

Sorry, I just haven’t had time. Also, it looks like the DJTT Maps site isn’t 100% repaired yet

1 Like

Hey @Brainbox, just wanted to let you know that the DJ TechTools mapping page has been repaired. Sorry, but I just haven’t had time to check your mapping out and do any testing…

https://maps.djtechtools.com/

1 Like

Ok, I’ll have a look there. I also changed the mapping because the ergonomics of the seek/scratch knob very near to start/stop, volume and AI knobs is not good. But the problem still persists. What helps is that I’m now in the “counting bars and phrases” phase of DJ’ing :-). So the problems happen during preparation and after placing start cue’s and proper DJay settings not so much during performance. If you use the scratch knob frequently, it still takes half an hour or more to make the bug happen.

1 Like

@Brainbox thanks for the additional info. Very strange. Are you using the latest Midi Fighter firmware?