OSStatus error 2003334207 when loading songs

My djay 2 won’t load some songs says "Could not load track - The operation couldn’t be completed - OSStatus error 2003334207?

Other Developers had same problem

  • The error 2003334207 is actually a four character code ‘wht?’ (you can use the Programmer mode of the Calculator app to show the ASCII)

  • It is defined in AudioFile.h as kAudioFileUnspecifiedError = ‘wht?’, // 0x7768743F, 2003334207

  • I was retrieving my url stored from the core data and somehow they got changed during the insertion. Because of your answer I investigated, and was able to resolve the issue by retrieving the correct path using the file manager instead.

Other Apps like Serato, Virtual DJ, Traktor etc. are working with the same file from itunes. It is a problem of DJay Pro and happen on Mac, ipHone, Pad.

Normally this error occurs when you are trying to access the file which is not present in the specified folder or try to unwrap the variable which has nil value. Pl. check if the fetchedResultController is returning an object.

1 Like


Im having the same problem - please advise.

* Which djay version are you using now?
* Does this happen with all your songs?
* Have you tried deleting and re-syncing the songs via iTunes?

Hi Ara,

Sorry for the late reply. I somehow didn’t get notified about your last response.

Can you play all the affected songs with the Music app?

Interesting, so this problem only occurs with songs that you sync from your Mac?

What happens if you download the songs directly on your iPad instead of syncing the songs from your Mac?

HI Nick,

Is this also a purchased song? If yes, please try re-downloading it.

1 Like

This looks like a system issue as the Music app also seems to be affected. We’ll look into this. In the meantime, try deleting and re-syncing/downloading the affected songs.

Please try deleting and re-syncing your music library via iTunes.

Our team is still investigating this issue. You can try deleting and re-importing the songs to iTunes.

I also have this problem with one song, it plays fine thought normal music player on the iPad but I get this error message when loading into Djay…it won’t analyse the track either.

No it’s an imported song from a cd?

Yeah, that never worked for me, I’m not to fussed by it, just wanted to know why really?

It plays fine in the stock music player.

Same issue pain