RANE ONE issues since the 4.0 update

Unfortunately there are more problems than the ones you have mentioned,

A big problem is one that we already had a while back and was fixed but for some reason with this latest update it has reared it’s ugly head again…
This problem involves Sync,
Whenever I have two tracks Synced together, as soon as I stop playing or fade out the track, the track playing has a slight momentary speed up.

We had this issue before and it was resolved but it has come back again

Please Please Please fix this ASAP!

Another issue that I have found is with the Crossfader…
Crossfader curve appears to switch over to Constant Power setting whenever I leave it in Default… I personally like the Default setting
Sometimes it happens whilst using the app and other times it happens on restart.

Please Fix this as well…

I have to have a rant here because this is classic Algoriddim style, Introduce updates and create problems that weren’t there…
Seriously guys, is anyone Beta testing the updates before releasing them? Or are we all the paying guinea pigs….

1 Like

Here is a link to when this happened last December and was fixed with the update at the time…

Thanks for bringing these issues to our attention, @maurizio_T! Our team is currently looking into these issues with the RANE ONE since the new update, and I’ll keep you posted here.

Thanks again, and feel free to comment on this thread with any additional feedback or questions.

1 Like

Thanks Emily, this is actually the biggest issue for me as I mainly play 80”s Funk with live drummers and Sync makes it sound right…
I have a gig on Saturday and was hoping it could be resolved by then…

So from the limited testing that I have carried out with the latest Update being V4.01, it appears that some of the bugs have been sorted…
The Sync issue looks to be sorted as has the issue with the FX parameters knob…

I would also like to thank Algoriddim for finally giving us Key Lockon as default as well as the ability of being able to kill the gain…

1 Like

Yes, you’re correct! With the latest update version 4.0.1, the FX parameter knob issue should now be fixed. Glad you found that working properly again!

As for the issues on this bug thread:

  1. Sync Issue: Our team is still working on a fix for the sync issue you mentioned with the tracks momentarily playing at the wrong speed. I’ll keep you posted once that fix is released.
  2. Crossfader Issue: Our Dev Team wasn’t able to reproduce this bug. One thing they mentioned to have you check the setting of the “crossfader contour” knob on the controller. Is that set to “constant power” mode? One possibility here is that if that’s the case, this is overriding the settings that you have set in djay. Could you please check that and let us know?

All that said, I’m happy to hear that sync appears to be working better for you. And thanks for the positive words of support! It’s great to hear you’re enjoying some of the new feature updates. :pray:

1 Like

Thanks for replying Emily,
Yes further testing it appears that my Sync issues have been sorted, thank God as l have a gig tonight!

The issue with the Crossfader is still there and I don’t move the contour knob but l have tried disabling the function in my midi map…
I will further test this set up and get back to you…

The FX parameter issue has been sorted although it wouldn’t work with my custom map,
So l re mapped the Rane built in map to suit my style and now it’s working fine…

1 Like

Hi. I’ve been using the Rane One for a couple of months but recently noticing that once I have mixed in a new track and brought the crossfader all the way over to end the mix, the new track suddenly gets lower in volume. But as soon as I load a new track onto the inactive deck the volume on the active deck corrects itself and gets loader again.

Has anyone experienced this?

Thanks!

I have experienced similar issues in the past and these are a few things to try/check.

I have Audio Limiter and Audio Gain switched off
I also have the Crossfade setting on Default.
To check these settings go to Settings/Audio and select the options there.
Also check that your Crossfader Contour on the Rane One set at the 6th dot from the left on the dial or approximately 1pm…

Try this and see if it makes a difference…

As of update 4.0, I had noticed that even though I had the Crossfader Curve set to Defualt in the Djay Pro settings, if would occasionally/randomly switch itself to Constant Power…
I brought the issue up here a here RANE ONE issues since the 4.0 update.

To fix the issue permanently, I changed the midi command on the hardware Crossfader Contour and the issue hasn’t come back…
I’m not a scratch DJ so the Contour settings doesn’t bother me

Hi @DJRyanRoach1,

Thanks for posting to the community for the first time!

This thread does fit-in with the one @maurizio_T pointed out below. Thank you for that by the way!

I will be merging this post in with the one linked above so that our support and dev teams can better manage your request.