Recording on djay problem

I was testing recording on djay on my iPad 3. When I copied it off djay to my desktop from my iTunes all I get is static. But the file is large. Am I doing something wrong?

The recording is in a compressed AIF format. When you select “Get Info” on a file created by djay 2, it tells you that its kind is “AIFF-C audio”.….

The format on the file I checked is called IMA4. It’s something iOS supports natively, and apparently it loops nicely, something other compressed formats aren’t always good at.

If you don’t want to involve iTunes, I managed to convert a file using VLC. I would assume that going from a compressed file format to a non-compressed one you shouldn’t have significant loss, but I am not an expert at all on this.

Since looking at this a little closer, I’ve found that you can use a OSX command line tool called ‘afconvert’ to convert it to something you like better; ‘ffmpeg’, another tool, should be able to do that, too.

I converted my file like so:

afconvert -f WAVE -d LEI16 my-recording.aif

which creates a 16-bit .wav version. I hope that helps.

Hi Adviner,

Did this ever happen before or is this your first recording? What happens if you play the recording directly in djay?

Please make a new recording to check whether this happens again.

Can you open the recording with iTunes? Also, what exactly do you mean by “recording HD”?

Have your tried converting it to MP3

Covert the file to mp3 then put it on soundcloud.

When you record on djay and transfer the file to your CPU it’s. NOT MP3

Use iTunes to convert the file to mp3 format. Then upload it to soundcloud! Worked for me!!

Convert ONLY the original recording to MP3 using ITunes ONLY,!

Once you have the original recorded song on your iTunes library, go to yur import settings and have it on MP3 format. Then high light the song and go to CONVERT TO MP3. Once finished, delete the original file. Honestly, You can google step by step instructions on how to do this.

I tried playing it on the app and it sounds great. So it seems like its when I copy it to my pc

how do you do that in iTunes? to convert the file to mo3 before saving ti my local directory?

I meant mp3

Thanks for the information

OK, I got it to work. Here is what i did:

Under Edit > Preference > General
Select my import Settings.

  1. Set Import Using as MP3 Encoder
  2. Settings Custom and used 256 (use what ever you like)

Your iPad has to be connected now.

  1. Go to the File Sharing section for the Apps
  2. Select the .aif file
  3. (Windows) hold the shift button and go to Advanced on the top menu
  • You should see “Convert MP3 Version” now.
  1. Save to whatever directory and thats it

Hope this helps others

This is the same with me, I’ve tried playing in the application, which is fine, but as soon as it is exported onto my PC the static is on the file (worse with large bass), and is in the file no matter which software it is played through (tried with WLM, iTunes, and Audacity). Seems to be on file transmission between devices.

Yep, same problem.…
Is the only example I had handy.

…which is that.

That’s what I did with that one, using the LAME encoder for Audacity, I’ll try it after a reinstall of LAME tomorrow, as well as iTunes.

Anyone play around with the settings for the best import sound quality?

Other apps give you a stereo wav file. Until Djay gives me a stereo wav file, I can’t do anything with it.