Reloop Mixon 8 Performance Pads Sticking

Is there a hardware issue with the Mixon8?? I’ve seen various posts here and elsewhere about the pads not working. I have a similar issue. The pads on both the far left (1&5) and also the far right (4&8) aren’t fully responsive. I’ve tried updates and it’s not a software issue as work fine on iOS pad. Given the number of people experiencing this it seems they aren’t up to scratch. Am I going to have the same problem if I downgrade to a buddy or beatpad 2? Might have to switch to pioneer equipment…

Yes, looking at other posts here, it does seem to be a hardware issue.

Easily confirmed by using the unit with alternative DJ software. If it does the same thing, it’s the hardware.

1 Like

Hi @Tom_Procter, I’ve merged your topic with this existing one. Yes, there appears to be a relatively isolated hardware issue with this device. Not all user are reporting issues. I purchased one of the early models and have had no issues myself. Also, the issue is only with the Mixon 8. No issues have been reported with the Buddy or Beatpad 2. I also own a Reloop Ready and it works perfectly. I hope that helps.

I did test this issue with Serrato and it was a hardware issue.

1 Like

I had a very similar issue on pad 1 and 5 on deck 1. I was going to send back. I pressed the pads and rubbed my thumb around the pad and it somehow freed it up like it had adhesive on them or something. Mine is perfect now.

3 Likes

This definately worked for me. Had to use quite a bit of pressure but rotated around the edges and it now works as it should.

Thanks man, saved me so much time! I was about to send the unit back.

BopDJ have been great and happy to take the unit back if the issue arises again

1 Like

Pleased it worked for you.

1 Like

Happy to read that and indeed a bit of pressure but rotated around the edges seems to work.
It looks like if the pad were glued to the metal around…

1 Like

Hi all. I’m on my second Mixon 8 and have this issue , seems to happen after a couple of hours after the controller has warmed up. I’ll play around with pushing the pads are stated above. Seems to be mainly pad 5.

1 Like

Hi there, firmly rub your finger around the pad, around the edges. See if it frees it up.

2 Likes

Jut in case, published on Reloop website:

1 Like

Thanks for this. At least it’s being recognised.

Easily sorted , mine came sticky but I sorted ,

Great. Thanks for letting us know.