Set focus on the Queue?

So, my SX2 has arrived to replace the SB3 and I’m remapping all manner of buttons and knobs to do what I want them to.

Come across an issue with the library though.

I can use the browse knob and buttons to go back and fore between tracks, playlist, sources etc and that is all good.

My big problem though is I cannot for the life of me find a way to get the focus to move over to the queue so I can scroll through it.

I can touch the screen / click the mouse to get into the queue and the rotary knob scrolls up and down as expected.

Is there anyway to set focus on the queue through the controller and just midi mapping alone?

Any thoughts out there or is it something we’re all living with?

Any pointers welcome.


Forgot to say using an iPad 12.9.

Hi @sooteee,

You should be able to remap your controller through MIDI Learn. I also recommend you to look into this community thread to find out more information on the individual MIDI commands.
The MIDI command “Switch Library Table” should jump between the different library sections.
Let us know if you have any other questions.

Thanks @Guillermo, I’ve remapped most of the controller to fit what I want so I’m fine with remapping.

Trouble is your suggestion doesn’t work, nor does ‘select next section’ nor do any of the other mappable options in the Music Library section.

There are two options one ‘Focus on playlists’ and one ‘Focus on tracks’, neither do what you would imagine they would and there is not a 3rd option to Focus on Queue in existence.

Some of the other options in the Music Library tab don’t appear to do anything either via a controller as I’ve tried them all at some point.

So it looks like there is currently no way to set focus on the queue via a controller unless someone has another suggestion.


Hi @sooteee,

Thanks for pointing this out. We are sorry to hear you’ve encountered this issue with the library browsing MIDI commands.

We are currently investigating this. We’ll get back to you with more information as soon as we can.

Thanks for your patience and understanding.

Hi @sooteee,

You were right, there are some issues on the Library Navigation through MIDI Commands on iOS. We have escalated these to our developers and will work on a solution for this as soon as possible.

Thank you for your collaboration so far.



No problem, glad to have helped out.

It should help other people sending you guys support tickets through in the future as well. :+1:t3:

Look forward to a fix in an upcoming update.



I’m back again……other things the developers may want to look at for midi controls that are missing are:

1 - You can’t set skip forward or skip back greater than 4 beats. I know I can change the duration etc but that means having the screen on the right setting to confirm what the duration is. If I could program the pads for greater than 4 beats I wouldn’t need to see the duration on screen.

2 - You can’t set bounce loops of any duration to the harmonic or vocal stems at all. The options are totally missing in the mapping.

I’ll report back with others as I’m going along….:+1:t3:

1 Like

Hi Sooteee
You may have also noticed that if you set your default skip without midi to say 16 and then use a pad set to instant skip to 4 beats with midi, it changes your default back from 16 to 4 which is totally wrong (In my opinion).
There are separate midi commands to set the default skip duration and to skip forwards and backwards based on that duration. The instant skip commands from 1/8 to 4 (and should be more) should have no effect on the default duration you set separately and can rely on.

You are also correct about the lack of focus on queue which is badly needed and available in Mac & windows. Also the other midi library commands that are present but don’t work, plus no midi to access auto mix queue & my biggest issue at the moment having no way to pop up or focus on the track search feature (there is a keyboard shortcut in Mac and windows but even this isn’t in IOS)

I may sound a little negative at times, because I’m no newbie. I have been using Djay for over 8 years! And so I tend to focus on things that don’t work, need fixing or adding (two of those midi library commands haven’t worked since midi came to iOS a thousand years ago ha ha ha).

@SteNight Fully agree with what you’re saying, I never missed a lot of it on my old SB3 as I didn’t have enough options to play with due to some pads being laden with ‘gimmicks’ that we couldn’t touch.

Now I have my SX2 I’m doing a lot more mapping and discovering some of the issues mentioned above.

I’ve been doing this in clubs since the early 90s and we never had any of these problems on 12 inches of plastic!! :rofl::rofl:

Glad I’m not the only one who was having this issue. My rotary knob only scrolls through the the playlist and I wish I had a midi mapping that allowed me to jump over to the queue (and back) but none of the options I tried worked so I have to tap a song in the queue whereas I can use my rotary knob to select a song in the playlist.

I love the “add/remove from queue” mapping and what I envision is using the rotary knob to scroll through the playlist and I have a custom mapped button that adds/removes to queue (I was able to set this up successfully), but then after I’ve added a bunch of songs to the queue use different mapped button to “jump” over to the queue and use my rotary over there to select the next song to play (this appears to be the same missing feature described above).

Hi fella, as @Guillermo acknowledged, there are issues with midi mapping the library functions.
I do feel your pain though!
I can add / remove tracks to the queue via a button press on the controller but at present there is no way of getting over to the queue without resorting to poking at the screen!
Hopefully now it’s been acknowledged we’ll get a fix in a future update.
There are numerous other functions that are missing in the mapping table as well - no skipping greater than 4 beats being a great big bear to me!!
Skip now going up to 64 beats but loop still maxing out at 32 is also another ‘annoyance’…
We live in hope….:grin:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.