Spotify login not responding

When I go to log into my spotify account from the app I click log in then put in my email and password. When I click the log in button…literally nothing happens. No incorrect username or password warning, nothing. My email and password fields are still populated with my information just nothing happens. IO have uninsalled and reinstalled. I have click create new account and then clicked log in and tried that work around, nothing works. Software was working fine yesterday (8-13-18) then today (8-14-18) it doesnt work. Any help would be great.

Great news. 

As some users already pointed out, the issue is now fixed.

Thank you for your patience and sorry for the inconvenience.

If you have any questions or suggestions, or if you would like further information, please don’t hesitate to contact us. 

Cheers,Lukas E.

Hi there,

the issue was fixed with djay Pro 2.0.10.
Please make sure you update to the latest version.

Thank you all for your feedback.

Hi Brian,

We are very sorry for that.
We recommend updating your macOS version in order to have djay Pro 1 working again.

Cheers,Lukas E.

new issue

Please reference the new conversation here: Spotify Login White Screen

Hi Vincent, 

We are sorry to hear that.
Is the problem still occurring? Did you try to log into Spotify in the Spotify app or Web Browser, is that working?

What about Windows versions ?

recaptcha won’t show up in “djay Pro” (version 1) when logging in to Spotify. I know it’s solved I djay Pro 2, but I also need it to work in day Pro 1 :slight_smile: Please help getting it to work…


Best regards
Brian Henriksen

DJ Pro not working! Can’t access my songs. So i can’t use the software anymore. It’s important! Can’t login Facebook to Spotify.

I have a subscription to Apple Music because Spotify is not working, but you can’t search like Spotify. You need Spotify.

Looking at another solution, because DJ Pro sucks!!!

5 days no response. Really great customer service here guys.

Same problem, 8/17/2018. Windows 10 (Version 1803 build 17134.165). Djay Pro (licensed) 1.0.27457.0.

I also tried installing Djay Pro (DEMO) and it has the exact same problem.

Even if you type in an incorrect username or incorrect password nothing happens when you press the green “LOG IN” button.

I have gone into my Spotify connected app settings, and revoked Djay Pro’s permission, and uninstalled/reinstalled both the Demo and Licensed versions. The problem still occurs.

Issue resolved for me as of right now. Hope it is for the rest of you.

Same here… was working a few days ago and not today.

Hey Algoriddm developers… please check the API from Spotify… Apple IOS devices had the same problem and have been updates twice on iPhone in the last 48 hours.


I am having the same problem. I am so frustrated.

This is getting extremely frustrating

Fixed for me too, seemed like an issue with recaptcha

same problem here!

i tried now:
To use another device
To use another spotify account
To use another network
To reinstall the app

Nothing helped, I’m frustrated now as I wanted to use the app in a few days.

I’m able to do the login in the spotify app as also spotify web with all my accounts. But the djay app shows no reaction, as stated by shawn.