The operation couldn’t be completed. (OSStatus error 2003334207.)

Hi I have just bought DJay Pro and keep getting this error with certain tracks. I have tried recreating an mp3 file but still won’t load the song. How do I fix this

Interesting, this error also occurs on iOS 8 and djay 2.

* By “recreating”, do you mean that you tried to delete and re-add/re-download the song to iTunes?
* Do the affected songs have anything in common?

Our team is already looking into this. Don’t worry though, this has no effect on the actual usage of the app.

Can you perhaps send the mp3 file to support(at) for testing?

In the meantime, please try dragging and dropping the file directly from Finder onto the deck as an experiment.

Interesting, are you also on the Mac with djay Pro?
What happens if you drag and drop the songs from Finder onto djay’s decks?

Can you perhaps send a test song to support(at)


Can you please send your “iTunes Library.xml” file to support(at) so we can take a look?

Same issue here, if can’t fix it in the next days I’ll as for refund.

Additionally I’m contacting Apple to advise them they are recommending an app without support.

Issues fixed by creating a new iTunes library. Not the best solution but it worked.

It seems it doesn’t give the BPM and Key when it analyzes the tracks

I’m also trying to register the product and I get this error???

By recreate I mean a created a new mp3 file via iTunes. I thought the mo3 file might be corrupt. They don’t have anything in common that I can tell. Do you know what that error means?

The same files work fine in Djay for iPhone but not on the Mac version. But I wanted a larger screen to work with so I bought the Mac version which is a big jump in price from the iPhone version, so I really want it to work or my money back. Thanks

Hello is anyone there? Can I get solution for this please??

Very strange. I opened up the app and now its playing the tracks how it should be. Will let you know if this reverts back to the error.
Thanks again


I haven’t used the app since the 1.0.1 update, but just opened it today and this issue is happening again.
If I drag the files from the finder into the app they analyze and play but if I drag from the app library they give the error.

Also my cue points won’t get logged on tracks. If I keep the app open they are there but if I quit and restart the app they have gone.

Do you have any suggestions or other users who are having the same issue?


After a months still no reply. Really!!
Why have this support area if you aren’t going to reply. I think I’ve been very patient after paying money for your product. IT’s not like this app is free.

1 Like

Suddenly and without warning. Djay2 has stopped loading music. I just spent a small fortune purchasing music from itunes and suddenly I get Status error 2003334207. It worked fine until last week. Suddenly 100 songs cant be played… Whats going on?

I’m with you. I’ve purchased Djay, Djay 2, and Djay Pro for iPad. I purchased an iPad Pro specifically for use with DJay Pro. I’ve never had an issue, but now when I’m already half way across the country, sitting in the Denver Airport, headed to go play for 8 days, I get this error! Sounds like it’s had a pretty long history without a simple resolution. I downgraded from Serato to make life easier and to support the little guy. This is a deal breaker. Divorce time. I want my money back unless someone is waiting for this email and has a quick fix that can be done away from my iMac while I’m in an airport…