Track Not Available on local system

I am running DJay Pro 3.6.1 on an iPad Pro 11” that was recently updated to iPadOS 14.4.

I had an event on Thursday where everything worked ok. I played another event this past Sunday when I noticed my local files were greyed out. The playlists I have created with songs from Tidal work ok. All of my local files are in folders in my local Files app library. When I click on a track to load it, I am getting the error:

Track Not Available
The track cannot be played because it is not available.

I checked my Files library tab within Djay and the files are playable from there with the hotkeys intact, however the files build an analysis each time of songs I have definitely played before. I noticed the Linked Files section under the Files tab also show greyed out files. My files are still located in the same place on my local iOS Files app and playable directly from the Files app. I shut down Djay Pro including all other apps and restarted them. Next I restarted my iPad with the same issue occurring. In the DJay Pro Files tab, I attempted to delete and re-add my local iOS Files music folder. Again the files appear there and are playable along with the hotkeys. I thought maybe playing it from the Files tab would relink the entry within the My Library tab but they are still not playable. Last thing I did was manually re-add the file to the same playlist however that only created a duplicate entry that is now playable but the original entry does not.

The only system differences I believe between the two events is the iPadOS update. I have it set to auto install so I could be mistaken on the date but I am pretty sure it occurred overnight between the two events.

My question is can I fix this so DJay Pro can associate the file location correctly or do I have to re-add everything back to my playlists? Is there a known iOS update issue?

Thanks in advance for you prompt response.

Hi @Deejay_Supe,

It’s good to hear from you again. We’re sorry to hear you had this experience after updating to iOS 14.4.

Have you tried re-linking your Files-Folders to djay and deleting your old Folders? Would that solve your problem?

Hope to hear from you again.

I want to avoid deleting folders if possible. I was hoping there was another method or simple change. What is the method of “re-linking” files-folders? Are you talking about re-adding all of the files?
Something else I discovered. The Hot Cues I setup with my own audio files are still functional. Figured if those were still accessible, that would isolate whether or not the audio path was somehow broken.

What’s the update? Need to figure out what is going on.

Hi Deejay_Supe,

Thanks for staying in touch.

I would recommend re-linking new files-folders. You can do so by tapping on Add Folder here:


The Cue Points should be maintained if these are the same audio tracks.