Trouble with sound on Mixon 8 and Macbook Pro M1

Hello to all.
I meet trouble with the Reloop Mixon 8 pro and Djay Pro 5.1.6. on Mac OS.

I use a Macbook Pro M1 with Mac OS Sonoma 14.4.1. This computer has 16 Go memory.
The trouble is the following.

When I load a track on deck one (the left deck), the sound is choppy. I tried to make changes in the Djay Pro settings, like sound settings, but it changes nothing.

I tried to restart the computer, restart the app, restart the Mixon 8, nothing changes. Of course, I updated the Mixon 8 Pro with latest firmware.

This does not happen on deck number two (the right deck). And, it does not happen on iPad. No problem with iPad. (I have an iPad air 3)
It just happens with the left deck. If I change settings and use computer on deck 3 and 4, then the same happens on deck 3. (left deck).
If I unplug the Mixon 8 and just use the computer to make my mixing, the sound is normal.
That is to say, the sound is choppy on the left deck, only when using the computer and the Mixon 8 Pro.
It happens with Djay Pro 5.1.6, but it was already the case on previous versions.
Did one of you meet the same trouble? Did you find a way to fix this?

Hi @RamDamArea, this might be a bit of a long shot, but do you have FX enabled on the left deck? Specifically the Instant FX. Try switching to the Instant FX Mode in djay to see if one of these is enabled. I would check the Manual FX as well. There have been some reports of sticky pads on the Mixon 8 so perhaps one of the pads is being held down.

Can you please also try to capture a video of the issue, upload it to your Google Drive/Dropbox, enable sharing permissions, then share a link to the video here? Being able to hear the “choppy” sound might be helpful in troubleshooting this issue. Thanks!

Hi Slak_Jaw. Thank you for your answer.
I checked the app and none of the instant fx was enabled. Neither was Manual FX.
I will try to capture a video next time I will use the Mixon.


You’re welcome @RamDamArea. Okay, I’ll wait until you share the video then…

Hi, here is a link to the video.

Excuse my english.

Thanks for the video @RamDamArea. This is very helpful. Very strange issue indeed. There have been several reports of hardware issues with the Reloop Mixon 8 jogwheels so I suspect this is the problem here as well. Have you noticed that your left jogwheel movement feels different from the right one?

EDIT: can you please confirm again that it works fine on the iPad? Also, can you confirm if you are connecting to a different USB socket on the Mixon 8 when using the iPad or are you using the same USB socket?

I can confirm that it works fine on iPad.
I also noticed something strange about the way the jogwheels work. If I play a track on deck 2, just putting my fingers on the jogwheel stops the music and I can scratch. If I do the same on jogwhell number one, it doesn’t stop the music. Is it normal?

Hi @RamDamArea, thanks for the additional details. It sounds like your Left Jogwheel might be in CDJ Mode instead of Vinyl Mode when using it on macOS. Please press SHIFT+ Slip on the Mixon 8 (near top left side of jogwheel). Let me know if that fixes it.

If that doesn’t solve things, then we will likely need to look at the MIDI mapping to see if there’s something going on. Can you please also confirm if you are using the built-in MIDI Mapping or a custom edit?

On final thing. Can you please confirm if you are running the latest firmware from Reloop?

Hi Slak_Jaw, thank you for your help.
When I press SHIFT+Slip on the left deck, it doesn’t change anything.
It works on the right deck, going from CDJ mode to Vinyl Mode, but it does nothing on the left deck.
I can confirm I am using the built-in MIDI Mapping for my Mac.
And, i run firmware 5039.

Thanks for the additional info @RamDamArea. Please open the MIDI Learn tool and take screenshots of the MIDI assignments for the Left and Right jogwheels when you touch & rotated them. Make sure to expand the Advanced section as well. Thanks!

EDIT: please also try installing the firmware a second time. I still had issues with my Mixon 8 after installing the firmware once. The second installation fixed my issues.

I just reinstalled the firmware. No changes.

Here are pictures of the MIDI settings for Deck 1 and 2.

This morning, during mix, Deck A totally freezed and it became impossible to use.
So, I will return it to the seller. And that’s boring.

1 Like

Hi @RamDamArea, thanks for the additional screenshots and information. This really sounds like a hardware issue. I think you made the right decision returning it. Please follow up when you receive your new hardware and confirm that the issue is resolved. Thanks!

I will do so. Thank you for your help.

1 Like

You’re welcome @RamDamArea


Just a quick message to say I received the new Mixon 8 Pro today.
I made a quick test and everything seems OK. Let’s cross fingers.


Let’s hope so. Mine is still at repair centre. 5 weeks and counting.

That’s great news @RamDamArea. Thanks for the update!

I will let you know if I meet new troubles. I will also update if I have none.

1 Like