unable to pre-cue in djay pro with pioneer ddj-sx2.....why!?

is it possible to use a djay pro with a pioneer ddj-sx2 and have pre-cueing ?everything else works but that feature

I am having the same problem with pre-cue on the Pioneer DDJ-SX. But when I use the controller with other DJ software, the pre-cue works without any problem.

Hi there,

yes it is possible. After selecting the SX2 as pre cueing output in the mapping dialog window the controller should be set up.
If you are still not getting a pre cueing signal, please check if your pre cueing volume is set up right in the software (see attached screenshot) and at the controller (headphone volume, MIX/CUE knob…).


Lukas E.

Hi there,

the SX and the SX 2 are natively supported by djay Pro for the Mac.

All you need to do is connecting the controller and accept the audio device setup window.

If you have any questions or suggestions, or if you would like further information, please don’t hesitate to contact us. 

Hi there,

can you please check if the controller is being used correctly as External Mixer controller?
You pre cue solely on the SX 2, are the SX 2 settings correct on your controllers?

If you have any questions or suggestions, or if you would like further information, please don’t hesitate to contact us. 

Hi Guys,

can you please share screenshots of your device settings?

Make sure the Master Out is set to channel 1-2 and pre cueing is set to 3-4.

Lukas E.

We are very sorry to hear that.
Can you record an exemplary video and send it to us via support@algoriddim.com?

Thank you in advance. 

Hi guys, 

Can you contact us via support@algoriddim.com and share a screenshot of your device settings with us via mail.

We will reply to you directly.

Lukas E. 

Hi guys

Terry, did you install the designated driver of the SR 2 you can find it here:


If that did not help please contact us right away via suppport@algoriddim.com.

Also this thread is about using the SX 2.

Hi Terry,

As stated on our Hardware site, the SR 2 Pre-cueing output via the controller is not supported, but headphones can be used via the PC’s built-in audio output.


Lukas E.


Which djay version and macOS version are you using exactly?


Lukas E.

Are you able to reply here with resolution. I have tried all trouble shooting. It seems like others have an issue, could you publish a resolution pls to help many ppl with issue

I have tried this and i am not getting any sound. and i dont have mapping feature for Headphones output. Why?

I cannot believe this issue has not been resolved for the Windows users, after all this time.   I believe the issue is cause by DJay Pro lack of native ASIO support.  
Take a look at this Terry, it may help:   https://help.algoriddim.com/hc/en-us/articles/360014703472-How-to-bridge-djay-to-work-with-ASIO-powe…

Lukas - are there help guides to help folks set this up correctly? Or a video? The Preferences > Devices screen selection seems to be confusing for users to setup with their individual devices? Perhaps there’s more contextual/wizard like setup like a Pendo/WalkMe tutorial that could be incorporated into the app? (that’s a dream-big enhancement, heheheh)

I also have an SX2, but I’m relatively new to DJ-in so don’t know for sure in/outs and how to set it for pre-cueing using the controller. I got it to work once and then when I started up my session a day later I forgot my settings in order to get the mic jack and the cue buttons above the fader to work when crossfader is middle and want-to-cue channel volume is all the way down.

An initial setup video would be nice for various controllers.

Thanks for all you do!

I too am having this issue even with the native mapping and have tried every conceivable permutation, this renders the software useless with the DDJ SX.

I have this same problem. Have you found a solution?

Has this issue been resolved, I am also having this problem

I’m having the same issue, after two years of No problem at all… Mac OS and DDJ-SX2, perfectly with Djay pro. Pre-cueing channels worked like a charm. Until today.

Now, I only have sound if I have the ‘MASTER CUE’ on. So usesless for now. And when I set the settings to pre-cue at channels 3-4 instead of 1-2 (as I used to) it gives me the pre cue sound in my left ear only :wink:

I think i had the issue once before, but be restarting the program it disappeared. But now, I’ve been trying to solve it for hours - but nothing helped. Even re-installed the 1.06 firmware. :(( There are several complaints about this on the internet. Please look into it.

For all you folks: a temporary workaround is pre-cueing on your laptop, by selecting that for pre-cueing. So put your headphone in there. But that’s not the best option as you cannot control it smoothly that way :(((

Ok. i tried to record it. Will send it after conversion :wink:
weird thing is that it is only sending sound to one ear (after manually choosing channels 3-4 for pre cueing).
And it’s not the earphone that’s broke, because the master cue ouputs it to both ears.