V4-Change Cue point colour.

Hi all, @Emily @Guillermo @NathanielAlgo

So, the release notes state " Cue point color editing: Change the color of your cue pads in both software and hardware to suit your workflow. Cue point colors for tracks are seamlessly synchronized across djay on Mac, iPad, and iPhone via the cloud".

All sounds promising…now to the bad bit…

I guess that the hardware colour change is specific to some controllers only, as nothing at all happens on my DDJ-SX2 and this controller is RGB pad capable.

I can change the cue point colours in the GUI but nothing at all changes on the controller.

This is annoying as the colours presented in the GUI have NEVER matched the colours on the controller and I’d hoped this was finally going to be fixed.

No joy.

I can change the colours of the cue points in each track match what the controller shows but that is massively time consuming to amend each one on a track by track basis. As what I am effectively doing is making the software match the hardware, whereas the software should be controlling the hardware.

What would be useful (in the absence of the hardware changing colour), is the ability to set the default cue point order so the 8 colours always match to my controller. Either by a setting in Prefs or just be able to drag and drop the colours in the picker to what I want and they stay like that forever.

i.e. At present the cue points default to;

CP1 - Red
CP2 - Orange
CP3 - Dark Blue
CP4 - Yellow
etc, etc…

So, whilst the new update allows me to alter them one by one, a setting to tell it to always use Orange for CP1, Green for CP2 etc would help massively.

The SX2 can’t be the only controller where a) the colours displayed on screen are not the same as the controller and b) where the claim in the release notes just doesn’t work.

Cheers

S

:+1:t3:

1 Like

I’m having a similar issue with my Denon Prime 4. However, I’m pretty sure that the Cue Point colors on the controller used match djay. Now they do not match.

1 Like

Thanks for your feedback. In order to get the correct cue point colors on your MIDI controller please ensure to select the built-in mapping for your controller.

The new release ships updated mappings with support for cue point colors for all controllers, and these required changes will be missing from any custom mappings. If you customized the mapping you’ll have to re-do these changes based on the new built-in mapping.

By the way, djay will also prompt you when connecting the controller for the first time and a new mapping version is available. When you confirm that we’ll keep your custom mapping so you can switch back any time.

Hope that helps!

3 Likes

@Anders

Thanks! That solved it…

I did say no to using the new mapping as I have mapped my SX2 to within an inch of it’s life! :slight_smile:

Just put the default map on and the CP colours are all as should be! Great news…

Only problem I’ve got now is transferring my edited map across to a new map based on the current default…

That’ll keep me busy for a while…

Cheers

S :+1:t3:

I will be facing the same mapping challenges as my Prime 4 mapping is heavily customized. Might be worth a look at the new built-in mapping to see what’s happening with the MIDI out for the cue point pads. I’m hoping it will be easier to change my custom mapping to follow this LED behavior rather than the other way around.

1 Like

@Slak_Jaw

I did think of that but I use Cues at various start and end points and also on the fly…

If I changed the cue mappings to match the colours displayed, I’d have the cues all over the place and would never keep track…

It did cross my mind though!

Good luck. :grinning:

1 Like

No dice! I was able to duplicate the MIDI out information from the built-it mapping into my custom mapping, but the on screen colors only seem to match my Prime 4 temporarily. As soon as I load a new track or change the pad mode the colors go back to some kind of default. So it looks like I’ll have to live with the mismatch or tackle the big task of duplicating my ridiculous custom mapping from scratch.

Yeah, similar to my experience which I why I suggested a way to set a default in settings in my initial post, as that seemed the only way around it.

The new default is much better though as it also does some new funky colours on Saved Loops and Reloops as well, making the SX2 pads much more serviceable. :grin:

I’m already ploughing through the new mapping….but it will be worth it to get the matching colours as it’s always annoyed me they didn’t match up!

:+1:t2:

1 Like

Here’s some hints to get cue point colors working with your existing mapping files if you want to fiddle with them (this is not officially supported and only recommended if you’re comfortable editing XML files):

  • Remove the min/max values from the output dict of the cue point actions
  • Copy the “userInfo” section from the new mapping (that contains the dynamic min/max values for the colors)

While you’re at it you might also want to check the min/max values of the meter mappings in the XML to ensure they match the official mapping, since we recently tweaked them for all controllers to get exactly matching dB readings. :wink:

2 Likes

So I was able to successfully modify the XML file for my custom midi mapping to get the cue point pad colors on the Prime 4 to match the software. This was definitely less work than remaking my mapping from scratch and I had zero XML editing experience prior to this. CAUTION: As Anders states above, I don’t recommend doing this unless you are comfortable editing XML files. I’m certainly no expert so follow these suggestions at your own risk and BACKUP your midi mappings first.

  • I started by making an edit of the built-in Prime 4 mapping so that I could see the midi mapping file in the iOS Files app.
  • Next I made a backup of my custom mapping and saved it in another folder just to be safe.
  • Then I opened the built-in mapping file and my custom mapping file side-by-side using a text editor on my laptop.
  • First you need to remove the min/max values from the output dict of the cue point actions. There are a bunch of these. Basically I searched both mappings for “cue” and looked at all the sections related to cue points. There are pretty easy to understand descriptions for these. With the mappings side-by-side, I carefully modified all the cue point output sections of my custom mapping to exactly match the built-in one.
  • Then you need to copy the “userinfo” section of the built-in mapping over the custom mapping. This is located near the bottom of the file. Again I made sure to match these exactly.

Anyway, hopefully that’s helpful. If you make a mistake and mess it up, you can always just revert back to your backup midi-mapping. Good luck!

3 Likes

Initially I thought doing this would be a right nightmare…but given @Slak_Jaw’s success and being part way through remapping and realising what a thoroughly slow job it was, I was compelled to ‘have a bash’ at it!!

So, here I am with my own mapping, the cue point colours all in alignment, on all 4 decks (I only really use 2 but wasn’t going for half a job), and the new LED meter mappings all transferred, I’m well chuffed!

Cheers @Anders and @Slak_Jaw, I got there in the end!

:+1:t2:

2 Likes

Nice! Glad it worked out for you too @sooteee. By the way, I couldn’t find the section for the level meters in my XML file. What is the wording for this? I tried searching for meter, level, vue and couldn’t find it. Thanks!

@Slak_Jaw
Hi fella,

If I’m correct, the Meters are in the 4 sections, at the bottom, just above where you copied the userinfo over.

They are now coded:

<dict>
		<key>controlType</key>
		<string>control</string>
		<key>keyPath</key>
		<string>turntable1.monoMeter</string>
		<key>midiChannel</key>
		<integer>0</integer>
		<key>midiData</key>
		<integer>2</integer>
		<key>midiMaxValue</key>
		<real>124</real>
		<key>midiMessageType</key>
		<integer>3</integer>
		<key>midiMinValue</key>
		<real>42</real>
	</dict>
	<dict>
		<key>controlType</key>
		<string>control</string>
		<key>keyPath</key>
		<string>turntable2.monoMeter</string>
		<key>midiChannel</key>
		<integer>1</integer>
		<key>midiData</key>
		<integer>2</integer>
		<key>midiMaxValue</key>
		<real>124</real>
		<key>midiMessageType</key>
		<integer>3</integer>
		<key>midiMinValue</key>
		<real>42</real>
	</dict>
	<dict>
		<key>controlType</key>
		<string>control</string>
		<key>keyPath</key>
		<string>turntable3.monoMeter</string>
		<key>midiChannel</key>
		<integer>2</integer>
		<key>midiData</key>
		<integer>2</integer>
		<key>midiMaxValue</key>
		<real>124</real>
		<key>midiMessageType</key>
		<integer>3</integer>
		<key>midiMinValue</key>
		<real>42</real>
	</dict>
	<dict>
		<key>controlType</key>
		<string>control</string>
		<key>keyPath</key>
		<string>turntable4.monoMeter</string>
		<key>midiChannel</key>
		<integer>3</integer>
		<key>midiData</key>
		<integer>2</integer>
		<key>midiMaxValue</key>
		<real>124</real>
		<key>midiMessageType</key>
		<integer>3</integer>
		<key>midiMinValue</key>
		<real>42</real>
	</dict>

In my original mapping these sections had fewer lines of code, and as there’s one for each turntable along with the term monometer, I went for it!!

It was clearly different to the old mapping and it all seems fine.

:grinning:

Okay cool. Thanks for that! I checked mine and there is nothing named monoMeter. The only thing I have remotely close is monitorlevel which I believe is for the headphone volume. Anyway my level meters on the hardware closely match the software so I think it’s all good.

Not synchronizing on my devices. I’ve set the colors on my iPad but they’re not carrying over to my iPhone or MacBook.